Couple of crashes while starting the game and shortly after

Hi,

yesterday I had no problems playing a couple of games but today I was unable to play.

I’ve tried without the launcher workaround and with it (DX12 both times) and only on the official realm.

Crashes happened in the first screen after loading (Start game or Choose Hero), after pressing Choose Hero, a couple of seconds after entering the keep, in the inventory screen and when joining a game.

I had two crash reports but I just saved the second one, which belongs to the crash when I wanted to join a game:

GUID: d21e47ac-2a09-487c-b1cf-019d29a96f65
[Crash Link]:
crashify://d21e47ac-2a09-487c-b1cf-019d29a96f65

Since I just had time for one game and I’ve to run I didn’t do more troubleshooting than a reboot after the first two or three crashes.

Console logs from today:
console-2021-04-09-14.04.05-f04c1551-37fe-48ca-b625-a463a2e2efb0.log (262.7 KB) console-2021-04-09-14.01.32-654a7f95-35e5-49ef-bbea-ac5184e47ddb.log (224.1 KB) console-2021-04-09-13.57.16-11c7ca57-4465-4e83-88af-516ccf8daecf.log (192.1 KB) console-2021-04-09-13.52.22-d26cdaf7-2de0-4fb6-8deb-96e19f3371f0.log (208.5 KB) console-2021-04-09-13.47.59-a741253a-9a16-402b-85d6-59a7f210d88b.log (204.9 KB)

Also the only crash dump > 0kb from today:
crash_dump-2021-04-09-13.52.22-d26cdaf7-2de0-4fb6-8deb-96e19f3371f0.dmp (654.0 KB)

Any help is much appreciated :slight_smile:

Thank you and have a nice weekend!

Update:
Had the PC shutdown (not hibernating/Standby) for about an hour and I’ve been playing a couple of games without a hitch.

And today we’re crashing again:

console-2021-04-10-10.20.21-2eb13af5-c85c-4f22-babb-ace2326af42e.log (204.8 KB) console-2021-04-10-10.15.20-44da5b26-352b-49a5-bfca-b6c1e8a0031d.log (253.4 KB)

crash_dump-2021-04-10-10.20.21-2eb13af5-c85c-4f22-babb-ace2326af42e.dmp (705.7 KB) crash_dump-2021-04-10-10.15.20-44da5b26-352b-49a5-bfca-b6c1e8a0031d.dmp (770.7 KB)

I’ve noticed that I’ve got events in the Windows error log corresponding to the crash. Since Windows is in German I’ve tried to translate the error Message:
During a swap operation an error was detected. The affected device is \Device\Harddisk6\DR6.

This is the SSD where Vermintide 2 is installed. SMART output for the disk:

I’m currently moving the game to another SSD, maybe this helps.

I’m not a shark but I think it’s worth asking, have you verified game file integrity at any point?
Just asking since one of the logs says something about “File does not exist”

1 Like

I hadn’t but I did now and All files were successfully validated. Unfortunately. That would have been an easy fix :slight_smile:

1 Like

Have you had any luck after moving your installation over to the other SSD?

Yeah, looks good so far. But it’s still interesting why this happened.

One thing might be more free space on the SSD, on the first one I just got around 12GB free and now it’s around 60GB on the second one.

Also I saw this in console-2021-04-09-13.52.22-d26cdaf7-2de0-4fb6-8deb-96e19f3371f0:
13:54:27.995 <>Deadlock detected. Update was not called for 15 seconds. You need to supply a crash dump or a crashify link in the report since the callstack for this crash is irrelevant.<>
<>

I’ve not been following the other crash reports in the forum in depth but I think there was something about problems with Deadlocks? Could be something completely different of course but I’m a bit concearned about my SSD. It’s not that old.

Do you have any possibility in confirming if this is a Vermintide 2 issue? I know I can play and there are people who can’t and therefore are more in need of support but if you run across an issue that seems similar I’d appreciate an heads up.

Thanks!

There was a particularly notorious Deadlock that would occur when a Minotaur spawned but that’s since been patched. Generally, Deadlocks are a mystery 95% of the time. :weary:

I can’t say this sort of SSD incompatibility is a common issue. Try scanning it for errors by right-clicking the drive → ‘Properties’ → ‘Tools’ → ‘Check’

I’ve played the first 1150 hours on this SSD without an issue so I’d say it works fine probably :slight_smile:

Did that, no errors found. I just have my steamlibrary on there so even if the drive dies, it’s no big problem.

Thank you for your support!

I’ll just add in this thread:

Crashed again today without a popup on Horn of Magnus on the rooftops:

console-2021-04-16-09.00.08-d59a82e9-1f57-45b6-bc12-db0aef98ae9e.log (463.5 KB)
crash_dump-2021-04-16-09.00.08-d59a82e9-1f57-45b6-bc12-db0aef98ae9e.dmp (714.3 KB)

Looks like a code-related crash we need to address - I’ll pop it in the database. Sorry for the inconvenience!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu