Repeated crashing to desktop during missions

Hello!
After getting a new desktop I’ve been consistently having issues with Vermintide 2 crashing to desktop.
It happens seemingly randomly during missions, sometimes right at the start and other times at the middle or near the end.
I’ve tried the following:

  • Using DDU to reinstall GPU drivers.
  • Reinstalling the game.
  • Reinstalling Windows 10.
  • Reducing worker threads to 6 and 5.
  • Using both DX 11 and 12.
  • Lowering graphics preset settings.
  • Disabling hooks/overlays
  • … probably more I’m forgetting now.

No mods installed.
There’s no overheating happening, GPU and CPU are running stock clocks. I would really appreciate help!

Console logs from two crashes today, let me know if more info is needed:

No. 1

09:10:34.610 [Lua] [GameNetworkManager] game_object_destroyed_player, game_object_id=0 owner_peer_id=110000101c6dde0 peer_id=110000101c6dde0
09:10:34.610 [Lua] PlayerManager:remove_player peer_id=110000101c6dde0 1
09:10:34.610 [Lua] [GameNetworkManager] removing peer_id=110000101c6dde0 local_player_id=1
09:10:34.610 [Lua] [GameNetworkManager] game object was destroyed id=0 with type=player, object_destroy_func=game_object_destroyed_player, owned by peer=110000101c6dde0
09:10:34.611 [Lua] [GameNetworkManager] Game session disconnected, leaving game...
09:10:34.616 [Lua] [UnitSpawner] [nil] failed to remove listener [interactable_unit_for_husk] from unit [[Unit '#ID[db217b93bd1bca31]']]
09:10:34.621 [Lua] [GameNetworkManager] No longer in game session, shutting it down.
09:10:34.622 [Lua] TRANSITION	nil	nil	load_next_level
09:10:34.622 [Lua] Transition type "load_next_level", is server: false
09:10:34.622 [Lua] StateIngame: Got transition nil, set exit type to load_next_level. Will exit at t=1025.88
09:10:36.646 [Lua] [Managers] Calling function on all managers:
09:10:36.647 [Lua] PlayerManager:remove_player peer_id=1100001047b8528 1
09:10:36.647 [Lua] [SharedState] [SharedState] network_state_110000101c6dde0: <set 1100001047b8528> actually_ingame:1100001047b8528:0:0:0 = false
09:10:36.647 [Lua] Clearing all global lookup lists
09:10:36.647 [Lua] [IngamePlayerListUI] - Destroy
09:10:36.647 [Lua] [GamePadEquipmentUI] - Destroy
09:10:36.647 [Lua] [EquipmentUI] - Destroy
09:10:36.647 [Lua] [GamePadAbilityUI] - Destroy
09:10:36.647 [Lua] [AbilityUI] - Destroy
09:10:36.647 [Lua] [IngameUI] destroy
09:10:37.199 <<Crash>>Access violation (0xc0000005) in build 2003b9c18405
    accessing address 000002308C668444 from 00007FF6E130450C<</Crash>>
<<Callstack>>
{00007ff6e1270000, 00ce9000, 60b4df1a, dcc73796-55a1-49f7-820f-8276e5354404, 00000001, E:\agent-work\tmp-builds\engine_vt2\release\chaos_wastes_2021_03_08\engine\win64\release\vermintide2.pdb}
{00007ffeab2d0000, 001f5000, 088bf621, 7fcbbfa9-5b3d-dbc6-1a90-f7c3fd4a7f37, 00000001, ntdll.pdb}
{00007ffeaae60000, 000bd000, 92f57b1a, 0245fb04-f377-b64f-56f6-326f4a5a237d, 00000001, kernel32.pdb}
{00007ffe7c0d0000, 0009c000, 5b9ff4cd, 99fcf842-aee8-4713-ba31-7eb0c01164d4, 00000001, E:\projects\engine\tools\luajit\src\lua51.pdb}

No. 2

09:20:33.631 [Lua] [GameNetworkManager] game object was destroyed id=297 with type=ai_unit_with_inventory_and_shield_and_target, object_destroy_func=game_object_destroyed_network_unit, owned by peer=110000104d86676
09:20:34.587 [Lua] [ChatManager][1]System: roarroarroarroar picked up a Loot Die
09:20:34.588 [Lua] [GameNetworkManager] game object was destroyed id=361 with type=pickup_unit, object_destroy_func=game_object_destroyed_network_unit, owned by peer=110000104d86676
09:20:34.741 warning: [WwisePlugin] Encountered event marker without label. event_id: 0x4062013679, playing_id: 0x6101, position: 0
09:20:34.741 warning: [WwisePlugin] Encountered event marker without label. event_id: 0x4062013679, playing_id: 0x6101, position: 0
09:20:34.741 warning: [WwisePlugin] Encountered event marker without label. event_id: 0x4062013679, playing_id: 0x6101, position: 0
09:20:34.831 warning: [WwisePlugin] Encountered event marker without label. event_id: 0x4062013679, playing_id: 0x6101, position: 4537872
09:20:34.852 [Lua] [GameNetworkManager] game object was destroyed id=363 with type=interest_point_unit, object_destroy_func=game_object_destroyed_network_unit, owned by peer=110000104d86676
09:20:34.852 [Lua] [GameNetworkManager] game object was destroyed id=348 with type=liquid_aoe_unit, object_destroy_func=game_object_destroyed_network_unit, owned by peer=110000104d86676
09:20:35.179 [Lua] [GameNetworkManager] game object was destroyed id=360 with type=interest_point_unit, object_destroy_func=game_object_destroyed_network_unit, owned by peer=110000104d86676
09:20:35.657 [Lua] [GameNetworkManager] game object created go_id=364, owner_id=110000104d86676 go_type=interest_point_unit go_created_func_name=game_object_created_network_unit
09:20:35.719 [Lua] [GameNetworkManager] game object created go_id=365, owner_id=110000104d86676 go_type=interest_point_unit go_created_func_name=game_object_created_network_unit
09:20:35.720 [Lua] [GameNetworkManager] game object was destroyed id=304 with type=interest_point_unit, object_destroy_func=game_object_destroyed_network_unit, owned by peer=110000104d86676
09:20:35.720 [Lua] [GameNetworkManager] game object was destroyed id=303 with type=interest_point_unit, object_destroy_func=game_object_destroyed_network_unit, owned by peer=110000104d86676
09:20:35.821 [Lua] [GameNetworkManager] game object created go_id=366, owner_id=110000104d86676 go_type=interest_point_unit go_created_func_name=game_object_created_network_unit
09:20:35.821 [Lua] [GameNetworkManager] game object created go_id=367, owner_id=110000104d86676 go_type=interest_point_unit go_created_func_name=game_object_created_network_unit
09:20:36.324 <<Crash>>Access violation (0xc0000005) in build 2003b9c18405
    accessing address 00000000EE000004 from 00007FFE7E95BAF3<</Crash>>
<<Callstack>>
{00007ff6e1270000, 00ce9000, 60b4df1a, dcc73796-55a1-49f7-820f-8276e5354404, 00000001, E:\agent-work\tmp-builds\engine_vt2\release\chaos_wastes_2021_03_08\engine\win64\release\vermintide2.pdb}
{00007ffeab2d0000, 001f5000, 088bf621, 7fcbbfa9-5b3d-dbc6-1a90-f7c3fd4a7f37, 00000001, ntdll.pdb}
{00007ffeaae60000, 000bd000, 92f57b1a, 0245fb04-f377-b64f-56f6-326f4a5a237d, 00000001, kernel32.pdb}
{00007ffe7e920000, 0009c000, 5b9ff4cd, 99fcf842-aee8-4713-ba31-7eb0c01164d4, 00000001, E:\projects\engine\tools\luajit\src\lua51.pdb}

Hope you can help me, thanks!

Could you include the whole console log and your crash dumps too, please? :slight_smile: I can then pass this on to our Engine Developers.

Thank you for the speedy reply!
I’ve put three logs+dumps in a google drive folder, from the crashes I’ve had today:
https://drive.google.com/drive/folders/15JbUf8t249lAahE6JFbBZWEc7q9tyLmk?usp=sharing

Let me know if there’s anything else.
Thanks!

Could you make it public for those who have the link please? I can’t access it. :slight_smile:

My bad, it should be accessible now.

Quick update. I have tried downgrading my Nvidia GPU driver from 471.11 to the previous one (466.77)
and have so far not had any crashes in the last 5 hours-ish, where before it was crashing every 10-20 minutes. Potentially a fix.

Oooh interesting! I never would’ve suspected your drivers would be the problem from the crash data. This might even explain the increase in Access Violation crashes we’ve been seeing. Keep us posted!

Another update!
I’ve had no crashes all day today UNTIL I did something truly radical.

At the same time yesterday I downgraded my graphics driver I also lowered my DRAM frequency in the BIOS from the default DDR4-3200 MHz to DDR4-3066 MHz. In my search to find the cause behind the crashes I tried going back to the default ram BIOS settings, and booted up Vermintide 2 and launched a mission which crashed 5 minutes in. I opened up another game (Escape From Tarkov) and again I crashed shortly after opening it.

So I lowered DRAM frequency to DDR4-3066 MHz and downloaded newest graphics driver (471.11) and I’ve so far been playing for 2 hours without issues. I’ll see how it runs over the next few days.

1 Like

No crashing in the past few days in any game, using the newest gpu drivers and a lowered DRAM frequency (From 3200 MHz to 3066 MHz.)
So it seems like it’s just some instability on my end.

How much RAM do you have and is the game being installed on an SSD? And try to run a Memory check on your RAM. It could not be that the RAM crashes games while being on the default settings.

It’s 2x 16GB of Crucial Vengeance LPX. Also when I said default settings I was referring to the default XMP profile settings.
I haven’t done a proper memory test as it seems stable on a slightly lower clock speed.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu