Hold to sprint, when toggle off, doesn’t work as expected

Issue Description:
When you put on off the option “Hold to sprint” you should use the key to toggle on/off running. But, the behavior, with this option turned off, is not working like that. In fact, several events remove the sprint:

  • when you fall from a platform
  • when you are hit by any enemy (very annoying cause you die fast in this situation)
  • when you slide (crouch key)

This defeats the utility to turn off the “Hold to sprint” option.

Keeping your finger on a key for 80% of a mission is painful for me. This option is essential as, without, the game becomes a torture (and this is not a joke). To avoid that, I turned on “Hold to sprint” and configured W key to forward and also run. As a result, I cannot manage stamina and this has a real impact on the gameplay.
I believe that this option should permit, when you hit the key bound to “run” with “Hold to sprint” turned off, that the character keeps running until you press again this key.

Steps to Reproduce:

  1. Turn off “Hold to sprint”
  2. Play


Player ID:

Reproduction Rate:
Constant (100%)

Upload Supporting Evidence:
my god! you don’t need, just launch the game

Upload Console Log:
Not needed

Then, you really think it is normal that, when the option is on off, you stop running every time something happen.
It is impossible to play with this option on off cause you cannot survive in a melee.

I would have not posted it as a bug if there was a real solution…
However Cherry MX lock production ceased in 2017 (sad…) or I would have installed that on my keyboard (I have hotswap).
Now, I have to try to find something to get a work around (let’s say it… a program that is not detected by your anti cheat system)… just to get something working. Do you think this is normal to do that just get something functionnal? Cause, let’s say it, this feature is broken.

When I read “NOT A BUG” I actually read “we don’t care and we’re too lazy to repair that”.

'Tis not a bug as there’s no error that’s causing this behaviour. People who Hold to Sprint are also getting their sprint paused by gunfire and whatnot, they’re just immediately starting to sprint again because they’re holding the button.

However, I’ve forwarded this as feedback!

With the “hold to sprint” turned on:

  • When I fall from a platform (like in beginning a mission), I can continue to sprint.
  • When I am in a melee, I can understand I am stopped in my run… however I can continue to run

Actually, when the option is turned off, you have to tap the key each time you want to switch from walking to running and vice versa. Problem is that in melee, this is absolutely impossible to do that. Please try it. Launch a game (even uprising if you don’t really play darktide, something I can understand if you program it) and test it in melee…

Also, please forgive me for the last message. But I often get pain in the hand (tendonitis it seems, but not really sure). Fact is, that keeping my thumb on a key to be able to run is really giving me pain…

Maybe give us as an option how it works, as I, on the other hand prefer how it works now.


You have chosen to turn off “Hold to sprint”?

How can you play with that?
Perso, I wanted to play without, cause i prefer one key to switch between walk mode or running mode, but I had to activate the hold to sprint (as I said) cause loosing the running state in middle of a melee would make me killed lot of times…

I don’t see how you can play in a melee as, anytime you are hit, you start to walk.

That’s a real question, cause I can’t see why you would want that anytime you crouch, been hit or let you fall to a lower level, you start to walk.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.