Problem with the weapon switch

I just don’t get it… It happens so many times, the switching between the melee and ranged weapons simply DOESN’T work and inevitably kills you in some situations…

It happens after you take a hit… Let’s say i have my ranged weapon in my hand, i take a hit from an enemy, then there’s a whole 2 OR 3 SECONDS where the switch simply doesn’t work, which obviously f*cks me up since i can’t take my primary weapon to block the upcoming attacks, which leads to taking 2 or 3 hits in a row… This is just plain ridiculous when I’m SMASHING my “1” button to take back my rapier but it simply WON’T give it back to me, stuck with the crossbow… I mean, this HAS to be a bug right ? no way this is a legit game mechanic…

I tried binding my weapons to different buttons, it still happens…

will this be patched somehow ? It’s extremely frustrating to take 2 or 3 “free” hits from rats because the game simply doesn’t want you to give you your weapon

8 Likes

It’s even better sometimes. Let’s say you’re on your ranged weapon and you’ve queued switching to your melee weapon, which will complete once your lockout from your ranged weapon animation finishes.

You then hold down right mouse to block as soon as your melee weapon is equipped.

Then you get hit, which interrupts your weapon switch queue for some reason, but since you have right mouse button held down your hero happily starts pulling back his/her bow / aims down scope / whatever.

Now you’re dead.

5 Likes

Swtiching from longbow to melee weapon… it’s so terrible.

2 Likes

Yeah, why does my hero insist on reloading the bow before putting it away? Couldn’t I pull an empty bow back out at a later point and then reload it? Like how it worked in VT1?

1 Like

i remember this was an issue as well in VT1 btw

Yeah, it wasn’t as bad of an issue though. The Longbows are both really terrible for it in VT2.

In addition to this, Grimalackt’s “Quality of Life” modpack fixed the weapon switching issues completely in Vermintide 1. It is slightly bothersome that Fatshark is yet to implement a similar fix to the switching code (even as they’ve attempted to fix the issue in a previous patch, the problem remains in slightly diminished form), but I am fairly certain that as soon as mod support is released, the issue will go away.

some of the delays are probably intentional for balancing reasons.

the longbow delay for switch weapons for kruber is definitely intentional - but i don’t think this was the point of the post.

op is saying that if he gets hit while wielding a ranged weapon, there are times where the weapon switching feels inconsistent because you are reeling from a hit and your weapon switch gets ‘cancelled’ or stuck.

yup… it continues to happen…

I finish reloading my crossbow and at the very end of the animation, i take a little hit from a trash-rat (you know the tiny pink ones), so by reflex, i spam my “1” button to equip my rapier but it simply doesn’t work. And then the gangbang starts, you’re basically stuck and take several hits in a row which obviously leads to your death. Frustrating

Okay, now that I think about this, and regarding what I’ve read here and earlier, including one or two comments from the devs, I think I get how this happens.

First, we have the Action Queue. That queues up action we’ve entered the command for, but haven’t had time to execute yet. It’s the reason we can, for example, start charging up another Heavy attack before the first one has ended. A while ago, it was changed so that weapon change (at least with Q) gets put immediately at the top of that queue. But when you get hit, the action you are executing gets cancelled. okay, no problem yet. The queue is still there. But when your reaction to enemy trying to hit you is right-click, trying to block, even when your weapon hasn’t changed yet for whatever reason, that command gets tossed in front of the action queue instead. While it’s all good when you already have a melee weapon equipped, trouble starts with certain ranged weapons, where the same command instead starts aiming and charging up a shot. You then try changing weapons again, enemy strikes, you try to block again… And a loop is ready. This happens very fast, in the space of less than half a second.

If this is really the case, it probably has to do with the command for blocking being the same as ranged secondary mode (aiming/charging) and possibly those two getting somewhat mixed up in the execution, or using similar priority regardless of what’s currently equipped. Another possibility I see is the game regarding the weapon changed for priority purposes as the weapon change animation starts, while weapon use-wise it’s still the previous weapon, so the weapon change never gets the chance to actually finish.

This is all just theorizing, of course, as I have no experience in coding and even less knowledge of the actual game code. But logic is still something I can do.

Maybe, but at least if I change weapon and then I block… just let me wait this delay. Don’t charge an arrow.

I experience this issue with Sienna(current main for Champ and Legend) quite frequently when transitioning from ranged to “panic block” melee. It has chunked quite a lot of my health so many times. Now I try to be very deliberate with the switch by dodging backwards, making sure no mouse buttons are pressed, then finally tap Q for quick switch. Problem is…theres not always time or room to do this.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu