Massive FPS drops

Experiencing a similar issue to Large frame rate drops

A friend and I both just upgraded to a GTX 1070 and both of us are having the exact same issue. In fact, I know a couple of other people running on 1070s who are getting FPS drops.

I was monitoring my PC’s performance and it seems to be because of CPU bottlenecking, but I have a i5 6600K so it shouldn’t be a problem. It’s really frustrating.

1 Like

It is a known issue which happens even when you are at the keep (as shown in the video bellow). No updates about the solution so far, though some people managed to fix it by turning on Optimize option in GeForce experience. For me personally that does the thing, but it’s irrelevant because it really lowers the graphics to the point that the game runs smooth but looks like s.hit.

1 Like

The thing is, I still get the issue even when I lower graphics to the absolute lowest. When I monitor my GPU and CPU usage, I see that it’s a huge CPU bottleneck. My CPU usage spikes right to 100% and the frames drop. I’m running a i5-6600K so well above the min specs.

For me, the issue persists no matter what graphical settings I use, so I prefer if the game looks great if it’s going to run poorly anyways :rofl:

For me, the issue is currently manifesting as the game slowing down and then speeding up as though it’s trying to catch up. Though for me, the issue persists regardless of the graphical settings I apply, or whether I optimize it in the GeForce experience panel or not. Anyway, I hope the issue is resolved soon, I’d like to play VT2 again without the issue.

We hear you! We’re very aware of the reported performance drops (particularly after patch 1.5) and are actively looking in to it.

Also - @Bankei - as you’ve recently upgraded, do be sure your previous GPU drivers have been uninstalled (if you haven’t already done this). Instructions on how to perform a clean re-installation of your GPU drivers can be seen here.

3 Likes

Thank you @FatsharkJulia

Definitely have already done a clean install of the drivers, but thank you for responding. The issue is weird because it’s definitely gotten worse since I upgraded to the GTX 1070 but it really seems to be the CPU usage that’s dropping the frames and hurting performance :frowning:

1 Like

the graphic engine is made by fs, so I think that soon or later they’ll find a way to fix it.
I hope as soon as possible for all of us :smiley:

@Angerblaze @Bankei any chance either of you’ve played any other games that use easyanticheat? I tried the division 2 beta today and I think that uses easyanticheat too. It was performing slightly better than VT2 has since the last patch, though I was getting occasional fps drops to 18 fps at times regardless of graphics settings (though no stutters or slow down and speed up issues in the division 2 beta). Apparently Battle fleet Gothic Armada 2 also uses easyanticheat, didn’t notice any performance issues in the single player, but when I launched a skirmish on the multiplayer I was certain there was just a minute occasional stutter.

Anyways, I looked up the games with easyanticheat installed, and I have Dead by Daylight, but haven’t played it much, also apex legends (which is free to play on origin) uses it. I’m going to install these games and see if there are any performance issues there. I also, a while back, got ghost recon wildlands (grw), and that had horrible performance issues, it uses easyanticheat apparently, but I no longer have grw.

Anyways, what I’m going for here is, is it possible easy anti-cheat may be the issue here and it just doesn’t like something on our systems (not sure what, no error messages so far)? I’m going to install Dead By Daylight and Apex Legends to see if they have any performance issues. This might lead nowhere, though if you’ve got any of the games easyanticheat runs in, and some free time, want to try seeing if you encounter the same problem with those (or if you don’t want to, maybe we could form a group in apex legends to see if the issue recurs, as it uses easyanticheat)? https://www.easy.ac/en-us/partners/

Just tried Dead by Daylight (already had it installed), no real noticeable slowdowns or fps problems.

Going to try apex legends and I think I just got absolver in the monthly humble bundle which uses easyanticheat too, so I’ll try that too.

Just tried Apex Legends (had it downloading a little earlier today), first match and tutorial I didn’t come across any real performance drops. Second game I got into in Apex Legends had a lot of stuttering.

Next up, going to try Absolver, as it also uses easyanticheat.

Played Absolver a little bit. Frames and performance was pretty constant in the tutorial area, fluctuating between 30-60 fps. Once I entered the portion of the game where other players could be found fps dipped as low as 20-25 fps, though the area was bigger and there was a little more going on, so I guess it could be something else. Though my computers specs compared with the recommended specs don’t lead me to think my computer’s specs are the issue.

Well, just went through the troubleshooting section for eac. I guess it might not be the cause of the problem. I don’t know. I think I’m just driving myself a little nuts trying to figure out what is causing the issue on my computer.

1 Like

I have Wildlands installed but haven’t played it since summer. I’ll test it out with a buddy of mine in coop and report back if I encounter any problems.

Another thing I’ve tried to fix this error today was going through my hardware section and making sure all the drivers were up to date. Didn’t fix it. Next I tried setting the power options to performance rather than power saving. Again, no luck. I also tried disabling the nvidia overlay and setting my graphics card to performance in 3d settings. Again, no luck.

Finally, I decided to open task manager whilst I went through a level in VT2. I set the task manager to stay on top and moniter the graphics card’s performance. What I found was the metric by which it measures 3D, whatever that means, started to make a ridge of spine like patterns. Every time 3D spiked at 100% in the task manager on my graphics card, VT2 would slow down and then speed up as though trying to catch up. It would then dip to 30% 3D and build up to 100% again repeatedly. Is this information useful @FatsharkJulia ?

Slight update to this, I set my physX configuration to use the graphics card, reinstalled my graphics card drivers and set 3D to be performance rather than quality. None of these additional steps seem to have helped fix the problem.

Also tried reverting back to a previous Nvidia graphics driver from before the most recent patch. No luck unfortunately.

1 Like

@beardeddragon1225 Do you think you could try out the modded realm and let me know if the performance issues persist there too?

2 Likes

Performance behaves on modded realm the same as in normal realm for me.
Could not see any difference so far but will keep testing.

Just tried to launch the modded realm version of VT2. Once I selected it on the launcher and told it to launch, nothing happened and the game did not launch. So I went back and tried to launch the normal version and VT2 launched that way.

If there’s anything else to try, I’ve got time today to go through a few experiments on my computer if it would help fixing the issue.

Also, tried going into the first of the bogenhafen mission on the normal VT2 client. Load times seem faster today on the normal VT2 client. Still getting slow downs and speed ups, though now my graphics card’s 3D metric in the task manager seems to be spiking around 60-70%, then dropping to 30%. With slow down at the peak and then speeding up as if trying to catch up.

I think I may have found the problem, but I’m not 100% sure. I downloaded a program called GPU-Z, and looked at the data. So I ran VT2 a bit and temp went up to between 80-90 celsius in the gpu sensor and up to 100 celsius on the cpu (100 C is the max for the CPU before thermal throttling kicks in). It keeps bouncing around and doesn’t look like it’s doing anything. So at first I thought my gpu temp sensor might be broken. It’s possible that my computer is thermal throttling unnecessarily, or maybe I’ve got dust in my machine. That said, there’s always a chance I’m misreading this program so give me some time to run some experiments to verify what I’m seeing. I’ve posted some of the data below.

@Bankei @Angerblaze can you guys download GPU-Z and see if this is the same for you guys? Let me just post my specs in case they’re similar. Lenovo Machine Type Model: 80WK00F9US, i7-7700HQ, Nvidia 1050 ti, windows 10. Legion Y520

Here’s the link to the GPU-Z download https://www.techpowerup.com/gpuz/


Just checked for dust in my computer, there was more than expected. About to try launching VT2 and see if it fixes the issue.

So, it improved performance a lot, though it hasn’t solved the issue. CPU temperature keeps hitting 100 degrees celsius now and I think it’s now thermal throttling the cpu not the GPU which I think it was thermal throttling before. So, a little improvement. I’m going to try figuring out how to manage the cpu thermal throttling next. (i7 7700 HQ max temp is 100 celsius, my computer is no where near that temperature, though it reads it as being. tomorrow I’m going to open up my computer again and see if I can figure how to fix that issue. Though I’m still not sure why this seems to have coincided with patch 1.5, and there’s still a chance I could be wrong)

@FatsharkJulia I’m going to order some thermal paste on amazon and change the thermal paste on my cpu chip. I’ll report back if that fixes the problem.

I get the stuttering as soon as I enter the keep, so I doubt it’s because of the temps. Nevertheless I did test the game with Afterburner OSD turned on (you should get that one, it has a lot more info and in game display) and I haven’t noticed any high temps.
I have a big ass compressor in the garage and clean my PC on every two or three months, so it doesn’t get that much dust.

I have:
Intel i5 2500K overcloked to 4GHZ with Arctic freezer xtreme cooler
Nvidia 970 GTX OC edition

These are my temps after 3 minutes spent in the keep during which the game was stuttering constantly.

I’ll take a screenshot after 2 or 3 games tonight when CPU and GPU reach their peak temps.

I might just not understand computers well enough. But is it possible patch 1.5 increased the power usage of the game on peoples’ computers? That might explain why my computer appears to be thermal throttling. It might also be possible that it may be throttling performance on some people’s computers due to too much power usage for the power supply to function. That said, computers are not my area of expertise so I could be completely wrong.

Well, your laptop was dusty, that’s a fact. But it seems that wasn’t the culprit for the Vermintide problems. The easiest way to test if your CPU or GPU are throttling is to play the game with Afterburner turned on. It will record the CPU and GPU workload and you will be able to see if there are any bottlenecks/spikes. @SmokerT69 said that he discovered a bottleneck with his PC if I’m not wrong.

1 Like

Alright, so I replaced the thermal paste on my cpu and GPU. Performance is night and day. GPU is 20 degrees celsius cooler, and cpu is 30 degrees cooler on average. Haven’t noticed any problems yet, so I’m lead to believe my laptop was thermal throttling. I’ll keep tabs on any games I play to see if I have any further problems, but I believe it looks like my computer’s problem has been fixed by the replacement of the thermal paste.

@FatsharkJulia I’ve collected my thoughts from this in case it can help anyone else who has performance issues. It might need some editing or additions, but I think it could be useful for people.

Troubleshooting for performance issues in VT2

  • Some things to note before beginning,
    • don’t jump to conclusions, run through the list first
    • If easy anti cheat is the issue, it’ll usually bring up an error. It may not even be related to the problem (simply something which others online have pointed to as being a possible source of various issues)
    • Try disabling mods or playing on the standard version of VT2 to see if that fixes the issue first
    • If VT2 is having performance issues, the general problems may be
      • A bug from a recent patch (possible, but troubleshoot before jumping to this conclusion)
      • Computer does not meet minimum specs
      • Possibly not enough RAM is available (shut down unimportant background programs)
      • Graphics are too high or some settings should be toggled (like V-sync) (if toggling the settings helps, this may be the solution)
      • Computer drivers may be out of date
      • Your computer’s settings may need toggling
      • Thermal throttling (cpu or gpu is heating up too much and the computer is throttling their performance to maintain safe operating temperatures) (if thermal throttling is the issue, it will likely show poor performance on other games that are heavy in either cpu or gpu usage, depending on which one is thermal throttling)
      • Or worst case scenario, there may be some degree of hardware failure (Don’t jump to this conclusion first without troubleshooting other possibilities) (there should be programs you can run to detect hardware problems)
  • First try playing a bit and change your settings.
    • See if changing the graphics does anything and test whether toggling your V-sync does anything. If yes, then reduce settings until desired performance achieved.
    • If no, proceed to next step
  • Second, go through device manager and make sure all the drivers are up to date. If your computer has software to find drivers use that, but still go through the device manager and manually make sure all the drivers are up to date.
  • Third, download GPU-Z, or MSI afterburner
    • Set this to remain on top and watch performance while you play a game or run a program that is either cpu or GPU intensive (try to test both cpu and GPU intensive programs for best data).
    • Be sure to monitor temperature and identify the max temperature for your GPU and cpu. If it goes near that, your computer may be thermally throttling your performance.
    • Also, monitor performance and voltage use (compare voltage to standard voltage for that component)
  • Fourth, a few possible fixes if the previous suggestions have not succeeded,
    • check your device’s power settings and change the power plan to performance rather than power saving.
    • I think it has been mentioned that sometimes setting your graphics card’s app to optimize the game may help.
    • Use your graphics card’s app to optimize VT2.
    • Try turning off or removing background programs on your computer
    • Sometimes setting your physX settings to use the graphics card instead of the cpu can help
    • Setting your 3D settings to performance rather than quality may also at times help
    • The most likely cause of thermal throttling is dust, so if that looks to be the issue, then open up the computer and use a can of compressed air to remove dust. Then retry VT2. If the problem isn’t solved and cpu temp keeps hitting maximum in VT2, you might need to look into replacing the thermal paste on your cpu. Do some research on thermal pastes, and look up a video on youtube of someone who knows what they’re doing to replace the thermal paste.
  • If problem persists after trying these steps, post in the tech support forum or send in a support ticket at http://fatsharkgames.com/support

https://www.techpowerup.com/gpuz/

1 Like
Why not join the Fatshark Discord https://discord.gg/K6gyMpu