Cannot seem to fix performance issues

Hey Fatshark and the community,

I have been experiencing huge performance issues with VT2, mainly framerate drops/ inconsistencies. My current rig is as follows:

CPU: i7-7700HQ 2.8GHz
GPU: GTX 1050Ti 4GB
RAM: 16GB

With these specs I have been getting an average of 13-18 frames per second on medium settings… My laptop shows no signs of struggling or overheating just the frame rate.

Heres what I’ve tried to fix the problem so far:

  • Set vsync and framerate cap off

  • Tried both DX11 and DX12 variants

  • Ensured NVIDIA setting use NVIDIA GPU rather than intergrated GPU

I’ve seen other people experiencing similar issues but I’ve also seen people with the same GPU say it works flawlessly. So just confused as to what the issue is. I’m just certain I should be able to comforably run on mid maybe even high settings. As at the moment I’m stuck playing on low :frowning: Any help is much appreciated

Hello.

According to this benchmark your CPU is on par with my former FX8350, and I had HUGE FPS issues specifically because of it. I’ve upgraded my CPU last week and redid the benchmark using the same graphics card - all the issues with low FPS appeared to have been caused by the CPU - now I have 60FPS on Extreme while I had about 12-18FPS (lowest peaks are smoothed out by the FPS logger) during hordes on Lowest. Vermintide always was very CPU hungry.

EDIT:
Here is the actual graph of the built-in VT2 benchmark cinematic. The video card remained the same:

1 Like

There are optimization issues… I ran the benchmark the other day, steady 59-60 FPS throughout. Then when I play the game, 18-29 FPS during hordes lol.

Yes, I also noticed that the benchmark cinematic is not really representative and goes a bit light on your hardware. My test shows that the lowest FPS was about 40, but in real gameplay I experienced drops to as low as 10 or so. But it is still ok for comparisons - I made two - new CPU VS old CPU and then old CPU VS OP’s CPU. To me it checks out.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

It can be hard to pinpoint the cause of a player’s performance issues, but some players with NVIDIA cards have had success by changing their ‘Power management mode’ in the NVIDIA Control Panel to ‘Prefer maximum performance’ by:

  1. Right-click your desktop
  2. Select the NVIDIA Control Panel
  3. Select ‘Manage 3D Settings’ within the sidebar
  4. Ensure the ‘Global Settings’ tab is selected
  5. Scroll down to ‘Power management mode’
  6. Change this to ‘Prefer maximum performance’


This did not increase performance unfortunately but reintroduced small stutters like DX12.
I posting this here now because my issue is very similar to op.
I’m trying adaptive now.

Ok no it has nothing to do with this setting but
image
And my game was set to DX12 again fore some reason.
So I will redo the test…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu