Sharp FPS drop since yesterday

Hello everyone. I have notices a sharp drop since yesterday. I am playing on very low settings and a poor computer and dropped from a framerate in the 25-30 range to somewhere around 15 without touching any setting. I really hope this issue can be fixed somehow, as the framerate is so low, the game is unplayable right now. Thanks for the attention

forgot to mention my specs. I have an intel i5 processor and a 920m Nvidia GPU. I know these specs suck, but I used to get a playable framerate on the lowest settings.

A lot of people have been having issues since the last patch. My FPS drop was random as well, Hedge said their was no patch when my game started acting up. But I definitely had a update in the bottom of steam.

Mine has been happening for almost a month now. Last reply hedge is trying to get some of the engine Devs to look into it. These issues have been going on for a long time, and seem to happen at random. My wife had the same issues I’m having for around a month as well, then the Summer Solstice patched fixed it for her.

Hello! We haven’t made any changes that would explain a sudden drop in performance over the weekend. Could this be a case of overheating perhaps?

Thanks for replying! I don’t think anything is overheating since I haven’t changed any settings. The GPU doesn’t feel hotter than usual either (I play on laptop and overheating is very noticeable to the touch).

The only thing I could think of would be the game using my integrated GPU for some reason. This happened with other games from time to time, but it never happened with Vermintide so far. I’ve set my dedicated card as the go-to card in the Nvidia panel and the settings seems to stick. Is tehre a sure-fire way to tell which one the game is using, other than the performance itself? (I would force it on startup just to make sure, but I have no idea how to do that from Steam and haven’t been able to launch the game from the executable)

It’s me again. I just found out you can see what GPU is being used by just using ctrl + alt + del, and it appears that I’ve been using my integrated GPU in the last few days. This is also happening in another game, so the issue has probably nothing to do with Vermintide. Thanks for replying, and sorry for opening a thread that has nothing to do with the game, really.
That being said, if you have any suggestions as to how to solve this, I’m all ears. I’ve tried the obvious ones already (power plan, forcing my Geforce on launch, and setting it as the go-to GPU both globally and specifically for the game from the GeForce panel).

No problem, happy to try and help! Is your monitor definitely plugged in to your dedicated GPU, and not your integrated GPU? :slight_smile:

UPDATE: the problem has been solved. I did a deep cleaning of the Nvidia drivers with a third party software and reinstalled them (just launching the driver installer and using the clean install option was not enuogh).
I’ll flag the thread as solved if I can find the option. Thanks for replying

I solved the issue. Thanks for replying anyway :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu