The game lags and makes it unplayable

god I really hope someone can help me with this, but basically my vermintide 2 lags terribly to the point where the game is unplayable. I have turned my graphics all the way down, im using Dx11, I have the LOWEST resolution, and i even have my worker threads at 1. My graphics card does say that it is not good enough but i have found ways to work around that in every other game by lowering graphics and this tactic has worked even in games that are graphically intensive. I got the game to run smoothly when no enemies were around but the second a few appeared on screen the game lagged terribly again. Does anyone know how i can solve this issue thanks !

Could you share your PC’s specifications with me please?

2 Likes

I am also experiencing this issue. I’ve stopped playing for about a month or so now as it’s become borderline unplayable and even more so at high difficulty. The frame rate drops significantly below 30 very frequently and the amount of stutters are insanely high. Some stutters have lasted for around 1-2 seconds which if you’re playing on Cata or above, is pretty much game over if you’re in the middle of a horde. Before the update in November, I never had a single issue with frame rate (I play on the lowest settings anyway) - not saying the update had anything to do with it, it just seemed to be from that point I’ve had this issue. I don’t get it in any other game I play.

My specs are as follows:
Ryzen 7 1700X 8-Core (CPU)
16GB DDR4 RAM
Radeon RX 580 Series (GPU - 8GB VRAM)
Windows 10 Home Edition (64-bit)
Game installed on a 2TB HDD (Not the best I know, but I never had any issues before)

Thing to note:

Fresh install of latest display drivers - no effect
Validated Game Cache through Steam - no effect
Cleared Download Cache (why not) - no effect
Tested in Fullscreen and Windowed FS - windowed FS improves frame rate by a good 20 frames or so, but doesn’t stop the stuttering
Capped monitor fresh rate at 60Hz, capped frame rate (in game settings) at 60 FPS - no effect
Tried with and without vsync enabled - no noticeable change
Haven’t tried re-installing the game yet, I want to explore all options first before going down that avenue. A game that nears 100GB on my net which downloads through steam at no more than 6mb/s gives me nightmares so I’d rather do that only as a last resort :sob:
Tried messing around in the Radeon software settings, turning some things on and off that may impact on the game - no effect
Unsubscribed from all mods on the workshop - no effect
Probably some more things but can’t think off the top of my head - no effect either way lol :frowning:

Any help with the matter would be much appreciated. :slight_smile:

Edit:
Tried the launcher bypass and it seems to have had a significant effect and my frame rate has improved quite substantially thanks to the suggestions of other players. Sadly, the stuttering is still a thing though but I can at least play to some degree now :slight_smile:

Try disabling the steam overlay

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu