KNOWN ISSUE: Fatal Error! Failed to read:

Hi, it was a SSD connected via M2 interface

if you are willing you could try the workaround, since it should in theory have faster reads than on a HDD. This is basically what we had before the patch

We will set this live with 1.3.2, and hopefully add it later as a launcher option, since there seems to be plenty of direct storage issues of various reasons atm.

To clarify - I already moved the installation directory back to SSD to test this experimental release, but the error still persist,as shown earlier

Please note, I have changed the instructions above slightly, to include the part below:

  1. Navigate to your Darktide AppData by:
  • Press the Windows key + R
  • Enter %appdata% within the search input and select ‘OK’
  • Navigate to AppData\Roaming\Fatshark\Darktide
  1. Open the user_settings.config
  2. At the VERY TOP of the user_settings.config, enter the line disable_dstorage = true
  3. Save your changes
  4. Play!
  5. Post here to let us know the outcome

Right. It runs now,sorry for missing the last bit.
Thanks

my current theory is that DirectStorage is not properly supported on older os Versions.

  • Narpason* I have your OS version, but if anyone else is willing to provide their OS version that would help to identify it that’s causing this issue.

We can probably query this in runtime to see if we should enable direct storage or not.

When I apply the change of user_settings.config, fixed…hope so…I have to test today, thanks.

Oh…still crash, my OS is Windows11 Version X64 (KB5036980)

do you get any crashify link as well? it looks something like this

GUID: 01978d9f-374d-420c-be11-12f63fa14538

could you try the experimnetal branch and let me know if it works.

See if it works with dstorage enabled as well since we might catch your issue on init

Do you know what kind of formatting your drive is? In Disk Management you should see if filesystem is for example NTFS.

Hello, I’ve been suffering this known issue since the new patch. I’ve tried changing settings, reinstalling, verifying files, disabling mods, etc. After reading this thread, I’ve enabled the experimental build and inputted “disabled_dstorage = true” in the user settings configuration file. It still results in the same outcome, I’ll crash on launch, in the Mourningstar hub, and even mid-mission. The game is installed on my M.2 SSD which is an NTFS file system. If there’s any way I can upload any crash data or anything, please let me know as I don’t know which type of crash logs will help or how to find the crashify links for them.

New instructions incoming… :arrow_down:

We’ve put a number of changes on our experimental build, to address issues that have recently arisen with the ‘Path of Redemption’ update.

You may be recommended this build, if you are experiencing the issues below:


Part 1: How Do I Switch to The Experimental Build?

  1. Open the Steam client
  2. Right-click Darktide in your Steam library
  3. Select ‘Properties’
  4. Select ‘Betas’
  5. Enter the password cTYPtKTsfMDsLHAV
  6. Select ‘Check Code’
  7. Select the ‘None’ dropdown, and experimental - Experimental Builds should now be within the list
  8. Select experimental - Experimental Builds
  9. Close the pop-up window
  10. A download should now start

Part 2: Setting Feature Flags

  1. Navigate to your Darktide AppData by:
  • Press the Windows key + R
  • Enter %appdata% within the search input and select ‘OK’
  • Navigate to AppData\Roaming\Fatshark\Darktide
  1. Open the user_settings.config
  2. At the VERY TOP of the user_settings.config, enter the lines below:
direct_storage = {
    enabled = true
    disable_bypass_io = true
    force_file_buffering = true
    force_mapping_layer = false
}
  1. Save your changes
  2. Play!
  3. Post here to let us know the outcome

NOTE: If you currently have disable_dstorage = true in your user_settings.config from previous instructions, please remove it and replace with the updated version above.

Part 3: Didn’t Work?

In the event the instructions above did not help with your issue, please try:

  1. Navigate to your Darktide AppData by:
  • Press the Windows key + R
  • Enter %appdata% within the search input and select ‘OK’
  • Navigate to AppData\Roaming\Fatshark\Darktide
  1. Open the user_settings.config
  2. Remove the changes made previously
  3. At the VERY TOP of the user_settings.config, enter the line below:
direct_storage = {
    enabled = false
}
  1. Save your changes
  2. Play!
  3. Post here to let us know the outcome

NOTE: If you currently have disable_dstorage = true in your user_settings.config from previous instructions, please remove it and replace with the updated version above.


What Does the Experimental Build Include?

  • The ability to experiment with direct storage options in the user_settings.config, which are suspected to be causing a number of issues
  • Improved error reporting, including stall warnings to help us identify newly introduced performance issues
  • Changes to our PSOs, to identify certain start-up crashes that present after the shader cache has been built

To learn more about direct storage, please see: DSTORAGE_CONFIGURATION1 - Win32 apps | Microsoft Learn

followed the steps and immediately after selecting a character fatal crash error

Thanks for trying, could you share your most recent console log with us, or attempt to reproduce the crash and provide your crash report please? :slight_smile:

Tagging our developer @Axloss for visibility.

console-2024-05-08-00.26.44-8b060d07-ae62-477b-b997-d3905b484bbd.log (16.0 KB)

This is my most recent console log following your instructions, the game just crashes on start up multiple times in a row. Sometimes it doesn’t occur and crashes at main menu instead or loading into the Mourningstar hub.

from experience these kind of errors are either

  1. broken install which on steam can be verfied
  2. we’ve seen issues with Intel Raptor lake CPU’s, since you have a raptor lake cpu you could be affected by this if you already tried to verify the installation.

you can read about it here

i would probably need a crashify link or the crashlog to figure out why you are crashing. Best thing is if you can send the crashify link that you get during a crash

How does one prevent the user_settings.config file from being reverted back to a version that lacks the lines written above? Every time I change the file, it goes back to being a version without those lines when I start the game.

I tried making the file read only, but then the game starts with only the basic options.