KNOWN ISSUE: failed_handshake_timeout / Error Code: 4008

After several more attempts (and a few minutes break) it has now made it in, and past that point.

console-2022-11-17-22.04.25-b2b1d16e-5615-405e-962a-7188482a32fd.log (147.3 KB)
console-2022-11-17-21.10.26-81ca3ea6-5f45-4360-b630-eb33c70134ee.log (405.9 KB)

Still can’t play since yesterday.

Trying to join for a first time a game session when the issue failed-handshake_timeout occured

plateform : steam

player id:Kwisatz

Approx. Time of issue & timezone: 2022-11-18-13.24.09 [UTC+1]

console-2022-11-18-13.24.09-a7261c87-d36f-440c-8aca-9b91595014f7.log (73.6 KB)

Steps to Reproduce:

After i’m done with the tutorial as Ogryn and try to join my first mission i get the “Failed Handshake” error, impossible to join any mission.


Console Log:

console-2022-11-18-15.29.04-7cdda1e2-ca32-4626-bae5-ff7e803aac6f.log (74.0 KB)

Platform: steam

Console logs:
console-2022-11-18-16.12.27-3ba5f2f6-ccfb-48bf-93d2-f2c07f55151a.log (70.1 KB)

I had the same issue during the open beta couldnt play at all please fix this quickly

console-2022-11-18-21.32.45-0c4ee465-2d2d-4210-8969-2ad912755663.log (143.5 KB)
console-2022-11-18-21.45.43-056fa3ab-b4cd-49dd-bda4-94284114ba79.log (66.1 KB)

Here are my logs, I’ve been able to log in, I get suck on a loading screen, I close the game then I can’t play that character again.

console-2022-11-19-01.27.01-0e7ffab9-c72d-4729-b730-e3a99fe7b7a7.log (84.1 KB)

Been having issues for the last two days please help this humble servant of the Emperor

  1. Logging into a Veteran Sharpshooter character
    Steam ID UNKN0WN397
    11/18/2022 7:33 PM Central

Hello. I just had this same error but just resolved it. Here is my report (<3 the game, <3 Fatshark):


Player ID:


Approx. Time of Issue & Timezone:
[11/19/2022, 12:28AM] [U.S. Central]

Of Note

  • I experienced this issue initially, quit my game, launched again, pressed start from the main operative select screen and still experienced it.
  • I then alt tabbed to open my AVG and just turned off the firewall and alt tabbed back.
  • Hit start from the operative select screen and boom - connected, without having to restart the game again.
  • From there I powered down the game again for unrelated reasons.
  • Thanks!

Console Log:
console-2022-11-19-06.23.02-1e3383c9-46d6-42b0-8f40-1954e79e01c6.log (67.3 KB)

Hi , same problem here.
I’m in a 4G modem internet connection.
2 days I cannot play because of the failed_handshake_timeout, I tried restart the game, the computer, verify files integrity via steam, launch in administrator mode,desactivate any firewall or antivirus, nothing works…Still same problem…

Plateform: Steam
Player ID : Scalpatif95280
Approx. Time of Issue & Timezone: 10h45 (Paris/France)

Console log:
console-2022-11-19-09.45.51-6c0caec7-ef14-4079-9293-fdf5c2278036.log (78.9 KB)

console-2022-11-19-08.02.42-11ce2931-56c2-4807-b5eb-36b62bf6d3e7.log (78.9 KB)
console-2022-11-19-07.47.55-4046677e-47ef-41b3-8144-a7c60c7a8c08.log (94.1 KB)

I have the problem when I am in the central hub and I want to start a quick game
Plateform : Steam
Player ID : Aburdil
Time Approx : all the time
Consol log :
console-2022-11-18-23.17.47-c6160213-53d8-41f9-a572-cf1c124449cb.log (216.9 KB)

can’t play past the prologue at all due to failed_handshake_timeout

console-2022-11-18-03.22.24-ed0e52db-0b49-4d2e-b3e2-1f69ded04bbf.log (253.2 KB)
console-2022-11-18-12.39.44-7953034e-fed4-40c4-b1e4-77bc6071d124.log (383.6 KB)
console-2022-11-19-04.02.20-457e856a-4110-4e77-a81b-98b0c4a53c30.log (29.3 KB)
console-2022-11-19-14.32.13-ae65395d-2d25-4ae0-86d2-cd5b6462bc4b.log (41.4 KB)

Japan Standard Time UTC +9

Team, Love the feel of the game. I initiated the game in the Steam interface on my Windows-based system. The screen is where the operative is standing, and the start button is in the right lower-hand corner of the screen. Psyker Psykinetic 1, named ‘Phuria,’ is showing. I select the ‘START’ button. The loading screen shows, and then, ‘Failed joining server: failed_handshake_timeout.’ There is a hard return after the ‘:.’ The text is almost ‘right justify’ (except there is a space after the ‘:.’
Please see the following:

console-2022-11-19-15.14.37-e4dbe7af-7b58-4e00-86ee-bd28357962eb.log (16.1 KB)
console-2022-11-18-22.40.41-1ac73447-d2bc-4a4e-b410-39f860d5c1af.log (215.5 KB)
console-2022-11-19-12.52.17-ac09ff24-7fad-4e53-9af1-cbe4d64daba0.log (540.8 KB)

I look forward to enjoying your great work.

Thank you and take care.


Got this error after finishing the training

Platform: Steam
Player ID: mineinglegend51
Approx. Time of Issue: 11/19/2022 6:14pm
Timezone: GMT+2
Console log:
console-2022-11-19-15.36.29-bd441c35-92a4-4dde-88e2-1b19c062bbe1.log (114.2 KB)
console-2022-11-19-15.56.25-9aa91ffe-d562-4a81-9324-aefee1adec5e.log (178.3 KB)
console-2022-11-19-16.09.10-0849d7f0-3353-4ea1-8c29-6fe044a90fe3.log (38.8 KB)
console-2022-11-19-16.12.43-929527c5-67f4-4649-8b1d-d98d61346fe6.log (29.6 KB)

same issue after tutorial when I go for inquisator


here is the log

console-2022-11-19-14.54.01-90af3b25-063d-494b-b86c-70edfe671613.log (255.1 KB)

Hi, have some problems too, can’t play from start of beta
Platform- Steam
Steam ID: 7656119807258440
console-2022-11-19-18.45.36-c2cd938d-36b7-40b5-b431-addbc1827cce.log (57.4 KB)
console-2022-11-19-19.13.49-0c0e7036-9585-4603-b445-7178221be72b.log (35.5 KB)

Crash Report
console-2022-11-19-19.29.13-e6279029-3b0c-4dab-a45a-d5044657a50d.log (49.4 KB)

Steps to Reproduce:
1-after prologue going to meet the inquisitor
2- approaching the door
3- go in to loading screen and observe failed_handshake_timeout error
4-return to main menu
5- clicking start takes me into loading screen and observing the failed_handshake_timeout error


Player ID:
[(Steam Community :: Intention)]

Approx. Time of Issue & Timezone:
[11/19/2020, [9:31 PM] [UTC +02:00 ]

I can join a mission and play for 10-15 minutes before no specifics action times me out and asks me to fill out a crash report. Here are all the related logs, I’ve attempted all of the commonplace crash fixes.

console-2022-11-19-01.13.15-ee4b916f-9a08-4ee3-b0d6-77d1d04e912e.log (83.2 KB)

console-2022-11-19-02.28.35-51c8a287-93b7-4744-9a83-289c8404bf19.log (45.8 KB)

console-2022-11-19-02.30.51-7c7e4bfc-4354-43d2-a9cb-54d6deca7eb7.log (156.5 KB)

console-2022-11-19-03.14.59-77659948-9e8c-464c-996c-fb7d0cff165d.log (46.1 KB)

console-2022-11-19-02.30.51-7c7e4bfc-4354-43d2-a9cb-54d6deca7eb7.log (156.5 KB)

console-2022-11-19-02.53.11-29d62731-a3a0-4587-9a34-9165f53efb53.log (103.1 KB)

console-2022-11-19-03.07.54-4bb90c38-2359-4e29-b018-791d1ff1a1c5.log (65.4 KB)

console-2022-11-19-03.10.56-be55ce94-3b1c-40b5-aa47-ab68c6796e67.log (47.4 KB)

console-2022-11-19-16.07.06-53b1cb6e-e382-487f-ba06-f500ab2eef58.log (117.7 KB)

console-2022-11-19-16.14.07-3256c923-33ed-4ee5-8d3d-b9efc993fe60.log (65.9 KB)

failed joining server empty ticket

console-2022-11-18-04.37.25-b4892fde-2420-4cfc-a79d-12bc2fd3ae42.log (230.8 KB)
console-2022-11-18-05.18.36-d00d1284-f995-476e-8390-856d44133b4a.log (345.8 KB)
console-2022-11-18-06.05.06-e088ec6e-e64f-4c74-91b3-210d10bb18b7.log (1.0 MB)

EDIT: tried on a VPN, same series of errors.

I was able to play through the prologue. My first error occurred in the middle of Grendyl’s cutscene. Upon relaunching the game from that point with my current operative, I am unable to play any further. I get a number of errors including:


From the operative selection screen, I am able to spawn into the voidship mission area about 50% of the time (the other 50% I just encounter an error on the blank starfield loading screen). However dropping into the voidship only lasts for 10-20 seconds before I am booted back to the operative selection screen, along with one of the above mentioned error messages.

One one occasion I was in the voidship mission area long enough to race up to the big green mission computer and quickly select a quickplay game…which worked! I went into the pre-game lobby …and then got booted due to one of the above-mentioned errors before the mission loaded up.


Player ID: comrade_patrick
console-2022-11-20-04.16.18-0043b350-2be2-4290-bf25-3af3d3895566.log (736.7 KB)
console-2022-11-20-00.09.35-a4047062-39ef-492c-a743-c80f87952073.log (341.0 KB)
console-2022-11-20-04.00.00-12e83658-1c69-408d-bc76-a1868d4e6108.log (176.8 KB)

1 Like