KNOWN ISSUE: failed_handshake_timeout / Error Code: 4008

Hi @exotrax,

Please can you provide your console log from a session this issue happened?

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload*the appropriate console log to us

Thank you!

I managed to get it but now like many other players can’t join any missions at the terminal.

1 Like

We’re experiencing some server issues - we’re working to resolve this ASAP.

Apologies for the inconvenience!

I can’t even log in with my operative to a single player instance of the hub because I can’t even get to the inquisitor cutscene!

My friend have the exact same error message. Any news ?

Same error here. failed_handshake_timeout.

Here are the logs

21:09:34.509 [Lua] INFO [PartyImmateriumHubSessionBoot] Searching for WAN lobby on
21:09:34.509 [Lua] INFO [SessionBootBase] Changed state fetchingserverdetails -> handshake
21:09:40.508 [Lua] INFO [MatchmakingNotificationHandler] Failed to boot
21:09:40.508 [Lua] INFO [SessionBootBase] Changed state handshake -> failed
21:09:40.508 [Lua] INFO [SessionBootBase] Changed state failed -> idle
21:09:40.508 warning: [Lua] WARNING [ErrorManager] Error "MultiplayerSessionBootError"
stack traceback:
	scripts/managers/error/error_manager.lua:31: in function '_log_error'
	scripts/managers/error/error_manager.lua:106: in function 'report_error'
	...pts/managers/multiplayer/multiplayer_session_manager.lua:570: in function '_show_session_error'
	...pts/managers/multiplayer/multiplayer_session_manager.lua:404: in function '_handle_session_error'
	...pts/managers/multiplayer/multiplayer_session_manager.lua:532: in function 'update'
	scripts/game_states/state_game.lua:111: in function 'network_receive_function'
	scripts/game_states/game/state_loading.lua:132: in function 'update'
	scripts/foundation/utilities/game_state_machine.lua:80: in function 'update'
	scripts/game_states/state_game.lua:561: in function 'update'
	scripts/foundation/utilities/game_state_machine.lua:80: in function 'update'
	scripts/main.lua:124: in function 'update'
	scripts/main.lua:172: in function <scripts/main.lua:171>
, message: source: game, reason: failed_handshake_timeout, error_details: n/a
21:09:40.508 [Lua] INFO [MechanismManager] Change mechanism "left_session"->"left_session"
21:09:40.508 [Lua] INFO [MechanismManager] Leaving mechanism "left_session"
21:09:40.508 [Lua] INFO [MechanismLeftSession] Entered with reason failed_handshake_timeout
21:09:40.508 [Lua] INFO [StateLoading] ### is_stranded ###
21:09:40.525 [Lua] INFO [GameStateMachine] Changing state to StateExitToMainMenu
21:09:40.525 warning: [Lua] WARNING [Gear] Deprecated, use fetch_paged instead
21:09:40.525 [Lua] INFO [ConstantElementLoading] State changed StateLoading -> StateExitToMainMenu
21:09:40.525 [Lua] INFO [ConstantElementOnboardingHandler] State changed StateLoading -> StateExitToMainMenu
21:09:40.541 [Lua] INFO [BackendManager] title_request: GET /data/8ede87b6-ca14-4a08-85c7-beb54ef36878/account/gear
21:09:40.541 [Lua] INFO [BackendManager] title_request: GET /data/8ede87b6-ca14-4a08-85c7-beb54ef36878/characters
21:09:40.541 [Lua] INFO [BackendManager] title_request: GET /data/8ede87b6-ca14-4a08-85c7-beb54ef36878/progression
21:09:40.541 [Lua] INFO [BackendManager] title_request: GET /data/8ede87b6-ca14-4a08-85c7-beb54ef36878/account/data/core
21:09:42.293 [Lua] INFO [GameStateMachine] Changing state to StateMainMenu
21:09:42.293 [Lua] INFO [FrameRateManager] Reason "main_menu" requested. Setting frame rate to 0
21:09:42.293 [Lua] INFO [ConstantElementLoading] State changed StateExitToMainMenu -> StateMainMenu
21:09:42.293 [Lua] INFO [ConstantElementLoading] Closing view "loading_view"
21:09:42.293 [Lua] INFO [ConstantElementOnboardingHandler] State changed StateExitToMainMenu -> StateMainMenu
21:09:42.306 [Lua] INFO [ScriptWorld] Registering level named: "content/levels/ui/main_menu/main_menu" with id: 1

This is the same error that happened to me on the closed beta and I was never able to play a single game since then. Hopefully this is resolved soon.

1 Like

Same error here.
console-2022-11-17-22.27.49-3c3ea97b-a906-476a-be10-c3b637ef2c7b.log (62.8 KB)
console-2022-11-17-21.32.27-d0932996-95ed-427d-866c-f0dce6677c41.log (317.4 KB)
Like, it was already a problem during the last alpha and I was really hoping to see it fix for this beta.
Hopefully it’ll be solve soon because it would be a shame that some player couldn’t play the game on release. :disappointed:

console-2022-11-17-22.39.40-a007b6e7-3c3b-4147-ac0e-4d10ccb22da7.log (49.9 KB)
console-2022-11-17-22.48.50-0f7cf2dc-f6eb-4ba7-917d-cdc9e5fc916f.log (17.5 KB)

getting “Failed Handshake” errors.

Tried a VPN and it seems to work, it is possible that the ISP is blocking DarkTide’s servers as a false positive or something.

Still, I don’t think we need to pay for a VPN to play the game that we pay for, no?

1 Like

console-2022-11-18-03.08.37-a07e9eb7-5c65-494c-adbb-c84e3c46e578.log (188.6 KB)
hope it works

Having the same since ~4 hours after the servers went life. These are some of the logs with the issue. The first log I was already connected and got disconnected mid session.

console-2022-11-17-21.22.06-c0f9b619-9643-405a-ae85-545fa859dd49.log (326.7 KB)
console-2022-11-17-23.05.20-4273bba9-70d7-40fd-8d64-6a8796ddef2a.log (48.9 KB)
console-2022-11-17-23.28.24-2ef48467-0ea7-40ac-beee-0b369c1a661c.log (34.6 KB)
console-2022-11-18-00.28.05-57ec9358-18fd-4e7d-8b3f-516b77b72129.log (39.4 KB)
console-2022-11-18-03.53.44-2f883226-8631-49f3-b862-6378012417d9.log (29.4 KB)

For all having this problem, turning of AVG (antivirus) worked for me!

Still the same issue previous beta had and Back4Blood beta had as well. VPN solves the issue, so it’s on the server side, somehow blocking the communication with certain accesses for whatever reason. B4B devs managed to fix it after a week, so hope we can get it fixed fast,because this is a big problem if thousands of people cant even connect to a game we bought.

1 Like

A simple update from the devs would be awesome… but i guess they are too hard at work to do something like that??

console-2022-11-18-09.14.39-e44a3ab9-13ef-4da9-886a-635d03742781.log (477.2 KB)

Hello, sorry to bother, i was worried about the failed_handshake_timeout, is it because im in East Asia region? a bit worried i hope the East Asia region can get a good connection

Issue Description:

Steps to Reproduce:
I finished the training nd need to go to inquisitor room, but i cant because of failed_handshake_timeout

Mission Name:
Get to the inquisitor room


Player ID:

Approx. Time of Issue & Timezone:
[11/18/2022, 00:00AM/PM] [world time]

Reproduction Rate:
i dont know what it means

Upload Supporting Evidence:
i dont know how to screenshot

1 Like

I’m getting the same thing, at the same time trying to visit Inquisitor. From Australia.

1 Like

After several more attempts (and a few minutes break) it has now made it in, and past that point.

console-2022-11-17-22.04.25-b2b1d16e-5615-405e-962a-7188482a32fd.log (147.3 KB)
console-2022-11-17-21.10.26-81ca3ea6-5f45-4360-b630-eb33c70134ee.log (405.9 KB)

Still can’t play since yesterday.

Trying to join for a first time a game session when the issue failed-handshake_timeout occured

plateform : steam

player id:Kwisatz

Approx. Time of issue & timezone: 2022-11-18-13.24.09 [UTC+1]

console-2022-11-18-13.24.09-a7261c87-d36f-440c-8aca-9b91595014f7.log (73.6 KB)