KNOWN ISSUE: failed_handshake_timeout / Error Code: 4008

Had error 4008 after picking character selection. Can’t load and send back to character seletion with error 4008.

DNS change probably fix this, but i’m not confidend to do this

console-2023-03-24-12.56.31-0224d22d-a96c-486a-b8c1-2e17eaf1074d.log (34.0 KB)

Thank you for answer.
And it’s ok, i just dowloaded the last little patch: All is ok.
Thank you ! :slight_smile:

Just tried to play and it worked without issue, many thanks to you guys for the quick reaction.
For other players knowledge i haven’t changed my ISP nor my Windows DNS for it to work again.

Hello
I still have the same issue I posted for on January 3rd, even though I downloaded today’s patch.
I am in France with Free too, and using my phone’s 5g (which is not a problem with any other game).
Here are my logs from today’s attempt :

console-2023-03-24-20.58.45-94763094-65eb-4f47-a5ab-4752ba6f753d.log (74.2 KB)

Hope you’ll find a fix for my case too…

With Hope,

Hello, player from France, using Free 4G box here. Checking the dates between the hotfix post and FatSharkJulia’s reply, I conclude the fix hasn’t been deployed yet?
Because it doesn’t work right now
Thanks for caring for us cheese lovers!

And this keeps on going even more since last patch.

Starry night.
2001
4008

urgh.

1 Like

Bonjour
ALors j’ai l’erreur 4008 comme tout le monde, mais moi c’est au moment de rentrer in game … impossible de lancer une game.
Voila j’ai pris un abonnement game pass pour ce jeux et je ne peux même pas y jouer

Failed to join server : error code 4008

platform:
Microsoft store (game pass)

PlayerID:
CodeX996

Approx. Time of Issue & Timezone:
Everyday , all the time

Console log

Can u tell us what the time to fix this i wait like 4 month now and nothing word steel get code 4008 that was stuipd i never see that at any game i played

Error 4008 occurring for the past 2 months for me. Waiting for “we are working on it ASAP” made me grow a mustache.

I am also having this issue, i have posted twice (incorrectly, i know, i was exceptionally upset at the time) about seemingly co-related issue of error 3001 in approriate thread. This issue was not a thing until one of more recent patches, for sure.
I am playing from Russia, my ISP is PJSC Rostelecom.
Please fix this, i really do want to play the game i have paid for.
I would be inclined to believe that it is my country’s ISPs doing shady censorship/blocking stuff, as they do a lot these days, but then it surely wouldn’t be so selective as to only affect one game specifically.

Issue Description:

Constant error codes 4008, 3001, 9999

Crash Report (If Applicable):

Steps to Reproduce:
Attempting to connect to Mourningstar as any of my characters

Platform:
Steam

Player ID:
Mr Darkly Beard

Approx. Time of Issue & Timezone:
05/03/2023 10:44 AM GMT+5

Upload Console Log:
console-2023-05-03-05.42.05-6055c233-40d7-44e6-91bc-c7574e5c4fcc.log (61.8 KB)

Edit:
Here is an extra log i just got that by some miracle connected on first try, if that is of any help.
console-2023-05-03-07.34.51-b56846ac-691e-41f5-8c49-23b59d1b8b29.log (56.4 KB)

Extra Edit:
My friend who is into net stuff analysed the logs i had and came to conclusion that my connection keeps cutting off when trying to connect to 34.242.56.85:35590, 34.242.56.85:35640, 34.242.56.85:35650 or 34.242.56.85:35620 i time out trying to join anything from that peer.
But some times it routes me towards 54.155.84.133:35530 and it works perfectly.
I also can connect successfully if i use a VPN to connect from US, to AWS-US-West-2, so there is some pathing issue with AWS-EU-West-1.
Supposedly the ips 34.242.56.85 and 54.155.84.133 are both AWS DBs in Ireland.
I also did AWS speed test to even see if my traffic even reaches EU datacenters, just in case, and there were no issues at all.
Hope that might help.

Issue Description:
Cannot join the game post prologue and I am using the PC Game Pass from Microsoft
Edit: I am from Egypt.
Crash Report (If Applicable):
[Please see instructions on how to provide a crash report in the pinned Topic]

1-Started the game
2-played the prologue and the training
3- went to the inquisitor and got kicked out
4- tried to rejoin got the same error 4008
Platform:
Microsoft Store: PC Game Pass

Player ID:
Warmaster1899

Approx. Time of Issue & Timezone:
05/26/2023 2:31 PM GMT +3

Upload Console Log:
console-2023-05-26-10.56.17-2aba6db9-c259-4871-9fe4-8d167e35364c.log (9.6 MB)

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

This has been happening a lot lately:

Group with friends. Do a mission. Then try to do another mission. Attempt to join/create match, either public or private, doesn’t seem to matter which. Get a “Reconnect to ongoing game session” message. Then get a failed joining server error code 4008. Happens repeatedly and completely prevents us from playing any missions. Sometimes it’s fixed by restarting the game, sometimes not. Sometimes it’s fixed if a different person creates the game, sometimes not. I think this only occurs after we do a mission, not on the first mission, although I’m not 100% sure of that.

Hi Julia! I am from Egypt and I am seeing a lot of Egyptians complaining about the 4008 error and I am seeing no updates, can you provide one as I am already seeing that it is country specific and you already fixed in France ?

Hello Fatshark,
I recently got the new update after not being able to play due to Error Code 4008 for 3 whole months in the “Choosing your Operatives” Area, and was able to FINALLY get to the mission area after so long. Had to leave early due to errands, but when I came back to try again I got the same Error Code 4008 again despite your update and now I am back to not even getting to the mission area. What the hell I thought you fixed this

Keeps getting error 4008 starting from late may until now. Always happens on 19:00 GMT +7 and above . And above. 300+ hours, never happened like this before.

Platform:
Steam

Approx. Time of Issue & Timezone:
Always happens on 19:00 GMT +7 and above. Region Indonesia, ISP BIZNET.

Reproduction Rate:
Constant (100%), Whether its from char selection / mission selection.

Rest assured we are still looking in to this - we’ve made improvements over the months, but we understand issues remain especially in certain parts of the world.

Issue Description:
when I select a character, it will try and load into hub then then get an error of 4008. sometimes ill make into a hub and it takes me many Trys to even get into a mission and when I get into a game its fine until we finish or lose and I am kicked to the characters select screen and with the code 4008. the cycle begins again.

Steps to Reproduce:
hit play with charater and get error, search for game and get booted from the search but stay in hub, finally get to a mission play till end just kicks me out at the end

Mission Name (If Applicable):
all

Platform:
[Steam/Microsoft Store]
steam
Player ID:
mrwhaal

Approx. Time of Issue & Timezone:
since latest patch

Reproduction Rate:
Once - Rare (<10%) - Unusual (<25%) - Common (<50%) - Often (<75%) - Constant (100%)

—100

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log & darktide_launcher.log:
[Instructions: How To Provide a Crash Report, Console Log, or darktide_launcher.log]

[Log version] 1
[Session] 06834373-28f2-4067-9503-5df3569dbb72
UTC time stamps
14:43:14.506 [Application] STARTUP: setup_crash_report, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3602
14:43:14.506 [Application] STARTUP: DLCList::setup, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3614
14:43:14.506 [Application] STARTUP: setup_timer, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3617
14:43:14.507 [Application] STARTUP: make system_info, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3622
14:43:14.507 [Application] STARTUP: setup_jobs, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3625
14:43:14.507 [Application] STARTUP: setup_resources, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3641
14:43:14.528 [Application] STARTUP: make game, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3667
14:43:14.558 [HTTP Cache] Initialized cache: C:\Users\video\AppData\Roaming\Fatshark\Darktide\http_cache.db
14:43:14.559 [HTTP Cache] Cache file size: 12 kB
14:43:14.559 [Backend] Created
14:43:14.559 [Application] STARTUP: init steam, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3672
14:43:14.751 [Application] STARTUP: setup renderer, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3698
14:43:16.511 [D3D12_RENDER_DEVICE] choosing adapter: 0 (NVIDIA GeForce RTX 3070)
14:43:17.734 [D3D12_RENDER_DEVICE] TILED RESOURCES TIER2 SUPPORTED: true
14:43:17.734 [D3D12_RENDER_DEVICE] D3D12_RAYTRACING_TIER_1_1 SUPPORTED: true
14:43:18.025 [d3d12 pipeline state] Failed to open pipeline state stream at C:\Users\video\AppData\Roaming\Fatshark\Darktide/state_stream_library.pso_lib
14:43:18.025 [d3d12 pipeline state] Failed to open pipeline state library at C:\Users\video\AppData\Roaming\Fatshark\Darktide/shader_library.pso_lib
14:43:18.155 [Application] — CPU
CPU: 12th Gen Intel(R) Core™ i7-12700F
Vendor: GenuineIntel
Logical processors: 20
Family: 0:6, Model: 9:7
Type: 0, Stepping: 2
Features: SSE SSE2 SSE3 SSSE3 SSE4.1 SSE4.2
Feature bits:
EBX: 00010000 10000000 00001000 00000000
ECX: 11111111 11011010 11110011 10001011
EDX: 10111111 11001011 11111011 11111111
— Memory
Physical Total: 16225MB
Available: 9040MB
— OS
Windows version 10.0 build 9200, 64 bit
Windows 10
Machine ID 995aba48-2d19-4824-88dc-5fb4f1063323
— Desktops
Monitor 0 (1920x1080): left=0 top=0 right=1920 bottom=1080
— Network
Network interface: Realtek Gaming GbE Family Controller (IPv4, IPv6)
Network interface: Intel(R) Dual Band Wireless-AC 3168 (IPv4, IPv6)
Network interface: Microsoft Wi-Fi Direct Virtual Adapter (IPv4, IPv6)
Network interface: Microsoft Wi-Fi Direct Virtual Adapter #2 (IPv4, IPv6)
Network interface: Bluetooth Device (Personal Area Network) (IPv4, IPv6)
— Input
No input devices detected.
— Volume
Volume for path ‘C:\Program Files (x86)\Steam\steamapps\common\Warhammer 40,000 DARKTIDE\binaries/…/bundle’ is on SSD
— Graphics
Graphics card: NVIDIA GeForce RTX 3070 (DirectX 12.1, 8032MB) Driver version: 53598 Hardware Accelerated GPU scheduler: false
Graphics card: Microsoft Basic Render Driver (DirectX 12.1, 0MB) Hardware Accelerated GPU scheduler: false

14:43:18.156 [Application] STARTUP: setup_window, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3702
14:43:18.161 [Window] Window => active
14:43:18.172 [Application] STARTUP: setup input, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3713
14:43:18.173 [Application] STARTUP: setup physics, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3719
14:43:18.174 [Application] STARTUP: config renderer, File: D:\a\d\rel_engine_darktide\release\rel_2023_04_24_Patch1.1.0x\runtime\application\application.cpp, Line: 3722
14:43:18.332 [RenderInterface] user specified render setting: cached_local_lights_shadow_atlas_size doesn’t exist in render settings – skipping
14:43:18.332 [RenderInterface] user specified render setting: max_shadow_casting_lights doesn’t exist in render settings – skipping
14:43:18.332 [RenderInterface] user specified render setting: local_lights_shadow_atlas_size doesn’t exist in render settings – skipping
14:43:18.332 [RenderInterface] user specified render setting: max_shadow_casting_lights doesn’t exist in render settings – skipping
14:43:19.250 warning: [Shaders] could not find any pipeline for ‘#ID[2a340f46]’
14:43:19.255 [d3d12 pipeline state] creating pipeline state for #ID[5ff391f3]
14:43:19.267 [d3d12 pipeline state] creating pipeline state for #ID[ff9e577e]
14:43:19.274 [d3d12 pipeline state] creating pipeline state for #ID[937c3ef1]

it let me in the hub but said i joined mission but i never left the hub and kept getting error 4008

we understand issues remain especially in certain parts of the world.

I guess Uppsala is one of these certain parts of the world :rofl: (I am based in Uppsala, Sweden ~1h away from Stockholm)

On a more serious note, I have been experiencing this very issue on Wednesday and Thursday and was unable to log in due to handshake timeouts when joining the lobby/hub. Checking the game logs the failing bit was usually:

16:15:17.014 [Lua] INFO [PartyImmateriumHubSessionBoot] Searching for WAN lobby on 3.70.172.14:35530
16:15:17.016 [Lua] INFO [SessionBootBase] Changed state fetchingserverdetails → handshake
16:15:23.000 [SSLSocket] Connection timed out. (ip: ‘3.70.172.14:35530’)
16:15:23.000 [SSLSocket] Removing peer (ip: ‘3.70.172.14:35530’)
16:15:23.000 [SSLSocket] Disconnecting. (ip: ‘3.70.172.14:35530’)

though I had one instance with a different failure:

16:51:27.511 [Lua] INFO [PartyImmateriumHubSessionBoot] Searching for WAN lobby on 3.70.172.14:35600
16:51:27.511 [Lua] INFO [SessionBootBase] Changed state fetchingserverdetails → handshake
16:51:27.695 [SSLSocket] Connected to server. (ip: ‘3.70.172.14:35600’)
16:51:27.695 [Lua] INFO [SessionBootBase] Changed state handshake → searching
16:51:30.696 [Lua] INFO [PartyImmateriumHubSessionBoot] Found no lobby, search finished.
16:51:30.696 [SSLSocket] Removing peer (ip: ‘3.70.172.14:35600’)
16:51:30.696 [SSLSocket] Disconnecting. (ip: ‘3.70.172.14:35600’)

Today (Friday) the error has resolved itself. I also learned today that my network provider (not the ISP, but the one owning the physical cables) had a network issue during the time I had connection issues. They throttled everybody’s connection to ~2-3M (down from 100M in my case).

This suggests the hypothesis that the issue is related to latency and is most likely caused by a too-aggressive timeout during the SSL handshake (and while waiting for a list of lobbies to join). Making this more relaxed might fix the problem for some (many?) players.

Ofc, high latency has a direct implication on the quality of the gameplay experience, so if the failure to connect is intentional an alternative route would be to display a more friendly error message like “failed to connect due to high latency”…