KNOWN ISSUE: Backend Error

The last two days I was able to play darktide without the error and thought it was fixed, I did not do anything it just suddenly worked.

However when I tried to play again today the error was back, tried verifying files and resetting the router without either working. I guess all I can do is wait and hope it just fixes itself somehow.

Hey everyone, just created an account to post some fantastic news. I believe I’ve discovered what is causing the specific backend error that occurs after character creation.

TL;DR: Simply take the space out of your character name!!!

The backstory and how I came about these findings:
I downloaded Darktide since it was available at 1.0.0 and I have not been able to get past the character creation screen. After clicking “continue” after creating my character, I would get the backend error and the game would exit out.

I tried VPNs, driver updates, verifying game files, reinstalling, disabling Windows Defender, etc., and could not get it working no matter what I tried (much like many other people are reporting). With the 1.0.8 update that dropped earlier, I was hoping to have some luck, though I was still getting the error.

I decided to look at the console logs myself purely out of sport and found something interesting.
Per the log file, I identified what action is making it occur. Here is a short excerpt of one of my logs:

06:26:10.104 [Lua] INFO [BackendManager] title_request: GET /social/names/veteran?gender=male&planet=birthplace_planet_01
06:26:15.468 [Lua] INFO [TextInputPasses] Selected text:
06:26:15.694 [Lua] INFO [TextInputPasses] Selected text:
06:26:19.679 [Lua] INFO [TextInputPasses] Selected text:
06:26:20.808 [Lua] INFO [TextInputPasses] Selected text:
06:26:24.608 [Lua] INFO [BackendManager] title_request: GET /data/characters/name/Wykell Hasatt/check
06:26:24.667 warning: [Lua] WARNING [ErrorManager] Error “BackendError”

Trying to gather more information and scrolling down a little further down the line, I noticed that this merely results in a 400 HTTP error (which in non-specific terms, just merely means “bad request” from the client). As soon as I saw it was using HTTP, I quickly thought about that space in my character name, and thus the space being present in the HTTP request, and thought “hey… maybe I should try this without a space”.

I launched the game, quickly made another character, and… it actually went right through. No backend error!!! I got through the cutscene that plays and got to being in the first person view and everything looks great. I did not actually go and play it because I wanted to immediately share my findings here with all of you and the devs!

I understand that there are some other errors and backend errors going on with the game, and I cannot speak for any of those. But I have some real confidence in this being a possible working resolution for players experiencing the same issue.

On this note, I’d also avoid any other characters in your character name (if they’re permitted) that aren’t strictly alphanumeric (i.e. A-Z, a-z, 0-9).

To the devs: I am not a coder, so I’m not really sure how to correct this issue on your side of things (outside of making spaces an illegal character for your character name field), but perhaps you can allow spaces (among other characters) if there’s incorporated UTF-8 encoding in whatever is making these requests. Hopefully that’s feasible, I truly don’t know (I work on the infrastructure side of things so all of this is just black magic to me).

I hope this works for everybody!

Just wanted to post a quick update:

I’ve successfully completed the tutorial levels without any issue whatsoever! I also asked some friends who play this game and confirmed with them that they only have alphanumeric characters in their name as well, which further solidifies my findings. Happy gaming! :smiley:

Already tried that, no joy.
Glad it’s working for some though!
If that’s really the problem, it’s pretty stupid though. It means there not parsing steam name is correctly at all.

help me stepshark im stuck :frowning: please

IMPORTANT! Our developers are asking if anybody with the Backend Error (NOTE: NOT the internal_error (Error Code: 2007) or any other error) can try the experimental branch in Steam, and see if that resolves their issue.

PLEASE READ THE INSTRUCTIONS BELOW FULLY! THANK YOU.

  1. Open the Steam client
  2. Right-click Darktide in your Steam library
  3. Select ‘Properties’
  4. Select ‘Betas’
  5. Enter the password cTYPtKTsfMDsLHAV
  6. Select ‘Check Code’
  7. Select the ‘None’ dropdown, and experimental - Experimental Builds should now be within the list
  8. Select experimental - Experimental Builds
  9. Close the pop-up window
  10. A 20mb download should now start
  11. Play!
  12. Post here to let us know the outcome

2 Likes

I have been trying to get into the game for several days, And I have gone through 2 patches. 2 reinstalls. 5 File Verifications and spamming space bar a trillion times to see if it will work. Has anyone else had this issue or know where to point for help?

1 Like

Exactly the same for me - my son lives in the same house and has had access from day one? I’ve done all the fixes on the various pages - dns, vpn, updates etc etc - no login!

1 Like

im having the same issue

I successfully downloaded the experimental build but it did not work. I am still stuck on getting the Backend Error after I press space to load into the game after the initial cutscene. I tried with and without a VPN and with my DNS server connected to google 8888, 8844.

Issue Description:
Each time I try to boot into the game after the initial cut scene, the game tried to process inquisitorial clearance before the Backend error, Error signing in appears.

This started to occur for me between Hotfix 1.0.6 and 1.0.7. No update occurred when I developed these problems, and I have not yet been able to get in the game since no matter what I try. Been just under a week since I was last able to play.

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Start game
  2. Press space to enter game
  3. Observe Backend Error

Platform:
Steam

Player ID:
(Steam Community :: BobTheGuy)

Approx. Time of Issue & Timezone:
[11/20/2022] [Central US]

Upload Console Log:
console-2022-11-25-19.14.06-e4293520-1ff1-48af-b864-88ff55152137.log (45.4 KB)
console-2022-11-25-19.18.54-79694bb2-95dd-42fd-a8ef-59206633b690.log (23.9 KB)
console-2022-11-25-19.32.14-940c0f59-b15f-40c6-8762-8c9d6bda648d.log (44.9 KB)

Thank you for trying, and for the detailed account. I’ve let our developers know. :frowning:

So far this has worked for me personally! Surprised me greatly. I have not used a VPN, or anything of the sort. This has been the first time I’ve actually gotten to play, and I managed to both get through the character creation and opening prologue, and have gotten to the main ship.

Super! Seems we’re making some progress. :slight_smile:

Seems to have worked on my end.
Firewall was not blocking the game, did not use a VPN.
Finally was able to play through the prologue and 3 missions so far.

Still not working for me. I’ve had the backend error for the last 3 days every time I Press ‘space’ to enter the menu. I downloaded the experimental build, verified the game files, redownloaded the entire game, nothing has worked.

Platform: Steam

Player ID: Steam Community :: iTztheKaiser

I had to disable my fire wall again, but with that and the beta patch I can now play.
I still have the dns server set to googles’ (8.8.8.8).

So my update is:
Pre-Order Beta 1.0.8 with Experimental Build: was able to play, dns server set to googles’ (8.8.8.8), fire wall disabled (kaspersky total security)

console-2022-11-25-21.18.10-d438474d-ada3-4271-9eeb-795b57de368a.log (539.4 KB)

It worked! I was experiencing the backend error.
I booted up the game as normal before the experimental build just to confirm I was still getting the bug, and I was. I then installed the experimental build and I can now enter the game.

Used the experimental build and I am now able to proceed past the “inquisitorial” menu and select a character, so that issue has been resolved :slight_smile:

console-2022-11-26-02.24.00-3835da7f-0571-48be-953c-2668715770bd.log (7.1 KB)

Still nothing, only the backend error popup at spacebar prompt.

edit: i mean with exp build