Issue with Launcher/Easy Anti Cheat [SOLVED]

I’m having trouble launching the game since the 2.0.3 patch (I was playing the day before [8th Aug])

I can open the launcher, hit play and then the splash screen opens up. After a few moments a dialogue box opens that reads, “Unknown file version (vermintide2.exe)”, and the launcher itself says, “Launch Error. Unrecognized game client. Cannot continue.”

I have tried all of the following multiple times:

  • Verifying game integrity through Steam
  • Deleting the EAC Certificates (and some other ‘problem’ files that Steam/EAC had issue with), then verifying game integrity to get them back
  • Uninstalling/reinstalling the game
  • Setting my graphics lower, as well as changing my DX11 to DX12 (and back)
  • Unsubscribing from all mods (all of which were approved mods previously)
  • Restarting the PC (including after various steps of the above)

I have been able to load into the Modded Realm, and have previously had different error messages (that have been resolved) and this leads me to believe that it is related to the EAC system.

[Edit: Just to add, my Steam current content build ID is 4091615, as of 9 Aug, 21:00GMT]
[Edit 2: Randomly found out that cancelling, instead of hitting “save” gave me a crash link:
GUID: f34acc6b-c386-4e12-890f-afd2f34620e8
Log File:
Info Type:
[Crash Link]:

And a second one - same process:
GUID: d1f0f67e-1c69-4fb1-8b24-6928d582ec71
[Crash Link]:

Hopefully this helps!]

I have no idea what else I can try, as I’ve been searching online as exhaustively as I can.

I have uploaded a short video of exactly what happens


GUID: a4422a33-32aa-436d-9b2a-ce1ed4a703ae
Log File:
Info Type:

weekend has arrived finnaly time to actually play new stuff
alas same problem as OP


waiting patiently for fix/help


I have this problem as well, I also have tried all solutions mentioned above and more.

Can this please be fixed?

1 Like

same here. want to play the new dlc and i cant:

Same issue here, tried everything listed here aswell, no fix.

I have also the same problem :frowning_face: Please help

GUID: ec840e8a-db6e-4807-a1c3-6ffca833f42c
Log File:
Info Type:

im in same situation, ill be checking this threat if any solution is found, meanwhile, ill find something else to play unfortunately. hope it gets a fix soon

I got the exact same bug today and can’t play the game. I tried the same as you.
It came right after I clicked on a beta-survey in the launcher. Never used mods though, just the base game.

Same problem here as mentioned above :frowning:
Would very much like some help since i can’t play because of the recent patch

Interesting that you mentioned the survey - I had my troubles after that appeared (and I’d responded).

How many of you other folks used the launcher Survey link?

We’re in talks with our Anti-Cheat provider, sorry we have no workarounds at current. We appreciate this sucks.


I don’t have any mods downlaoded either, i think it just a bug and it will be fixed on the 13th, when the Winds of magic, releases…

Steam said there was a tiny update to VT2 today, and the launcher no longer had the feedback link.

Not sure if it was intended as a fix to this issue, but it definitely didn’t!

GUID: fb3aaa39-d64e-4735-81b0-89b27afec47c
Log File:
Info Type:

1 Like

I have the EXACT same problem!

Didint fix it for me either…

Yeah the update today, although unclear whether it was meant to patch this issue out, certainly has not done so.

I hope this is fixed tomorrow on the 13th.

1 Like

Any update on this?

1 Like

I got this fixed just now, by having one of my friends send me his .exe file (which worked for him) and replacing mine with that, IT WORKED! Hope this helps someone!

i have tryed that, with no luck.

Tried that as well and it did not work for me :frowning: