"Unknown file version (vermintide2.exe)"

When I launch the game and click play on the client, i’m met with the error message “Unknown file version (vermintide2.exe)”
I tried deleting this file only to be met with “Unkown file version (vermintide2_dx12.exe)”
I tried deleting that and I couldn’t click play on the client anymore.

Please note that I’ve played about 16 hours already with no issues until now.

I tried verifying the games file through steam only to be met with the same issue and I tried reinstalling the game as well with the same result.

I’ve checked online and couldn’t find anymore fixes, can somebody please help?
GUID: a4f0821e-6731-4770-a00e-b4dac2a90f07
Log File:
Info Type:

We’re in talks with our Anti-Cheat provider, sorry we have no workarounds at current. We appreciate this isn’t ideal and hope to have an answer or solution for you soon.


It’s pretty frustrating not being able to play the game, but I am appreciative that the problem is being worked.
It’s also nice that your reply was pretty quick, thought I was going to be ignored! Thanks for your hard work Hedge!

I got the exact same problem. I can’t play the game :S

It popped up after I entered the beta survey.

1 Like

I have a fix. Go into local game files and then go into launchers, easyanticheat, launchers again. Then make sure the vermintide2 and vermintide2_dx12 are not (the name then . Something). If they are change them to .exe . Should work

Could those with the problem run another file verification for Vermintide 2 and check once more?

Verifing files does not work and the fix that thenakedfalcon mentions allows you to start the game, but it feels like it is a modded version since crafting, spoils and connecting to friends are not allowed.

I didn’t quite understand what nakedfalcon meant, could you explain to me perhaps?

After verifying the game, i was able to actually launch the game. I got onto the screen that displays the player character before a new problem cropped up.
I can’t remember what it said exactly but a window popped up that said something about ‘Backend not supported’ or something and displayed a prompt to quit. I clicked on it and it exited me out of the game with no error report.
When i tried to launch the game again… the original problem came back. I then verified the game files again with the original problem still persisting. I couldn’t get back into the previous screen with my player character and the “Backend not supported” window pop up.

GUID: 13971ff6-86da-4014-a8e1-ba11eb846d44
Log File:
Info Type:

I also tried TheNakedFalcon’s fix and, while the game launch like it would normally, the game thought that it was in a modded state. I couldn’t interact with crafting or open any loot.
The files were “vermintide2.json” and “vermintide2_dx12.json” in the directory (Warhammer Vermintide 2 > Launcher > EasyAntiCheat > Launcher) and I changed them into .exe instead. I hope this helps with

I hope this info helps in fixing the problems.

Tried a lot of different things now, and the issue seems to be on the local PC. Tried login in as a different steam id, and had the same issue.

Seems to some file or registry that is broken, and is not removed when removing and installing vermintide again under steam.

Hope you guys are working on a quick fix, sucks to have bought the newest dlc, and now the game is broken

Same thing happens to me. Tried verifying the files in steam and it succeeds with no errors but the game won’t launch. Says "unknown file version (vermintide2_dx12.exe). I’m just launching as normal from desktop or steam.

Played many hours with no issues and this started a few days ago.

Hello again
Is their any progress being made on this issue? I’ve been experiencing this issue for about a week now and i am still unable to play the game. I don’t want to own a game I can’t play and can’t even refund because the game breaking bug happened to late to do so.
This post was about to be closed without a resolution. Any sign that the problem is being dealt with will do just give a reply!

Hey guys, are you using BullGuard anti-virus?

Yes, I am.

I got a message from Towly that answered my problem, here’s a link to his solution!

Stolen from someone else in the forums as link may not work:


I seem to have solved the issue on my end with BullGuard:

  • Go to BullGuard settings
  • Antivirus -> Advanced settings -> Tuning
  • Tick the “Skip files/folders” -> click the “files/folders” hyperlink to bring up a selection -> I chose to exclude the whole Steam folder in my SSD
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.