Game closes without crash report or mentioning problem

We kindly ask that you complete the questions below. With this information, we can investigate your issue properly.


Issue Description:
Version from Windows 11 store gamepass.
After random amount of time, not dependant in what state of the game i am, game just closes without any error messages.
In logs couldn’t find any tags that would indicate a Crash To Desktop

Crash Report (If Applicable):
[Please see instructions on how to provide a crash report in the pinned Topic]

Error Displayed (If Applicable):
Nothing shown

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Start game
  2. Some time passes while in lobby or in mission
  3. Game closes

Mission Name (If Applicable):
Every mission, lobby,cutscene.

Platform:
[Steam/Microsoft Store]
Microsoft Store

Player ID:
[Steam ID/Steam Profile URL/GamerTag]
Xerafim

Approx. Time of Issue & Timezone:
[MM/DD/YYYY, 00:00AM/PM] [TIMEZONE]
from 12-12-2022 UTC+3 till current date

Reproduction Rate:
Once - Rare (<10%) - Unusual (<25%) - Common (<50%) - Often (<75%) - Constant (100%)

Constant.

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

console-2022-12-13-15.54.00-926e8cf1-9854-4622-bc9c-6afb45fa7e63.log (60.1 KB)
console-2022-12-13-15.57.53-501057af-95bb-49a6-b123-c86fd116e174.log (266.1 KB)
console-2022-12-13-16.27.12-c0ff7fe5-5e3a-487c-9661-02a0fec491ee.log (276.2 KB)

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here

darktide_launcher.log (185.6 KB)

I tried:

  • Threads 1-10
  • disabling/enabling FidelityFX
  • 30/60/120 fps
  • borderless/fullscreen/windowed mode
  • reinstalling drivers - from official site and Microsoft Store versions
  • Repairing game, deleting \AppData\Roaming\Fatshark\MicrosoftStore\Darktide
  • Removing xbox gamebar overlay

This is a tough one. Is there anything in your Windows Event Viewer (under ‘Windows Logs’ > ‘System’) that corresponds with when this has occurred?

There actually is something that correlates with log timing.

Latest log is this one (got in mission with 3 bots, started moving and game closed)

console-2022-12-14-15.35.15-d5e88ef8-2fc3-49a7-a5b3-be4829fdf0f2.log (243.9 KB)

darktide_launcher.log (281.6 KB)


This is event viewer from Windows Event Viewer (under ‘Windows Logs’ > ‘System’)

First is event from screenshot:
from general tab:

The file system filter "EasyAntiCheat_EOSSys" (version 6.1, ‎2022‎-‎10‎-‎21T12:10:15.000000000Z) has been uploaded successfully.

From other tab:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
  <Provider Name="Microsoft-Windows-FilterManager" Guid="{f3c5e28e-63f6-49c7-a204-e48a1bc4b09d}" /> 
  <EventID>1</EventID> 
  <Version>0</Version> 
  <Level>4</Level> 
  <Task>0</Task> 
  <Opcode>0</Opcode> 
  <Keywords>0x8000000000000000</Keywords> 
  <TimeCreated SystemTime="2022-12-14T16:04:54.5345928Z" /> 
  <EventRecordID>63984</EventRecordID> 
  <Correlation /> 
  <Execution ProcessID="4" ThreadID="2168" /> 
  <Channel>System</Channel> 
  <Computer>K-Zet</Computer> 
  <Security UserID="S-1-5-18" /> 
  </System>
<EventData>
  <Data Name="FinalStatus">0x0</Data> 
  <Data Name="DeviceVersionMajor">6</Data> 
  <Data Name="DeviceVersionMinor">1</Data> 
  <Data Name="DeviceNameLength">20</Data> 
  <Data Name="DeviceName">EasyAntiCheat_EOSSys</Data> 
  <Data Name="DeviceTime">2022-10-21T12:10:15.0000000Z</Data> 
  </EventData>
  </Event>

And warning / general tab:

Application-specific permission settings do not grant Local Activation permission for COM server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
  and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
  user K-Zet\Xeraf with SID (S-1-5-21-4290823128-4184093399-682349857-1003) and LocalHost address (using LRPC) running in application container FatsharkAB.Warhammer40000DarktideNew_1.0.372.0_x64__hwm6pnepa3ng2 with SID (Not available). This security permission can be changed using the Component Services Administration tool.

And warning / other tab:

 <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
 <System>
  <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" /> 
  <EventID Qualifiers="0">10016</EventID> 
  <Version>0</Version> 
  <Level>3</Level> 
  <Task>0</Task> 
  <Opcode>0</Opcode> 
  <Keywords>0x8080000000000000</Keywords> 
  <TimeCreated SystemTime="2022-12-14T16:05:09.2410124Z" /> 
  <EventRecordID>63985</EventRecordID> 
  <Correlation ActivityID="{76e5f902-5fe2-409c-bac4-be9ab711f916}" /> 
  <Execution ProcessID="1376" ThreadID="14492" /> 
  <Channel>System</Channel> 
  <Computer>K-Zet</Computer> 
  <Security UserID="S-1-5-21-4290823128-4184093399-682349857-1003" /> 
  </System>
 <EventData>
  <Data Name="param1">для конкретного приложения</Data> 
  <Data Name="param2">Локально</Data> 
  <Data Name="param3">Активация</Data> 
  <Data Name="param4">{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}</Data> 
  <Data Name="param5">{15C20B67-12E7-4BB6-92BB-7AFF07997402}</Data> 
  <Data Name="param6">K-Zet</Data> 
  <Data Name="param7">Xeraf</Data> 
  <Data Name="param8">S-1-5-21-4290823128-4184093399-682349857-1003</Data> 
  <Data Name="param9">LocalHost (с использованием LRPC)</Data> 
  <Data Name="param10">FatsharkAB.Warhammer40000DarktideNew_1.0.372.0_x64__hwm6pnepa3ng2</Data> 
  <Data Name="param11">Недоступно</Data> 
  </EventData>
  </Event>

Seems like around the time I get a crash, a similar event of Easy Anti-Cheat gets created.

do you have a drawing tablet or monitor? if so it may be the winTab32.dll problem with EAC.

Monitor, but i’ll try to find advices from winTab32 problem, by now i tried pretty much every solution that i could google.

console-2022-12-15-03.30.17-74dfa67f-dec9-416b-9096-35fe4f0b01d9.log (454.8 KB)

Today i had 1 hour and 27 min of uninterrupted gameplay, could do 2 missions. Best fun i had.
By end i was hoping that problems fixed themselves… :frowning:
Sadly, app-close-to-desktop still happens

After patch - problem still exists.

the wintab32 issue is with Easy Anti-cheat. it is kinda random. when i first got the game, it didnt have an issue when I played ogryn, but did when i played anything else. now it is just random at to it having a problem or not.

the patch notes do not mention this issue…so guess we have to wait.

Uninstall/Install not helped with problem.

Hello, maybe something new happened with my story.

Made full uninstall. Deleted created folders from %appdata%
Reinstalled.
After first launch disabled raytracing settings according to gameslantern web-page to

  • rt_checkerboard_reflections = false
  • rt_light_quality = false
  • rt_mixed_reflections = false
  • rt_particle_reflections_enabled = false
  • rt_reflections_enabled = false
  • rt_shadow_ray_multiplier = 0
  • rt_transparent_reflections_enabled = false
  • rtxgi_enabled = false
  • rtxgi_scale = 0

in user-settings.config

Also followed advice from KNOWN ISSUE: Out of Memory

but put cache to 2500-4000 MB. And not what was advised. (Which probably got me an error)

After 40 min of playing I alt-tabbed to check some info and got windows pop-up about
fatal error “out of memory”

GUID: ffc4c2c5-fa14-4c95-b6e7-43df91aa74e6
Log File: 
Info Type: 
-----------------------------------------------

-----------------------------------------------
[Crash Link]:
crashify://ffc4c2c5-fa14-4c95-b6e7-43df91aa74e6

console-2022-12-17-22.46.47-ffc4c2c5-fa14-4c95-b6e7-43df91aa74e6.log (292.9 KB)

darktide_launcher.log (52.5 KB)

Done fix from “Fatal Memory error” thread.
Will report tomorrow if problem is finally fixed.

EDIT: 3 hours with no crash.
EDIT2: Aaaand game crashed just as in first post.

I wonder if I have this issue, because I have a Huion tablet (3rd monitor)

And I get some very weird crashes only on mission start (after entering the map)

If it leaves no crash-dump and no error message - just plain “App closes to desktop and last messages in log have no errors/crashes”
Then probably same.

I checked other threads here about crashing and all of them have error/crash logged in files.

I will try to delete %appdata% folder again and try it later, because i had 3 hours of gameplay.

My best guess - game somehow installs in Windows 11 weirdly and after some time it starts to silently crash.

EDIT: Deleting %appdata% game folder and doing rtx fixes - does not help.
So probably 3 hours of gameplay was clean reinstall.

It’s so amazing doing 90% of mission to randomly crash and lose all rewards…