Unable to start the game on official realm

I am unable to start the game on Official Realm. No error message received and I am still able to tab to the launcher itself.

I am however able to start the game on Modded realm even though I have never installed any mods.

If I make launcher run as administrator then it works fine, however that is not an option since i get steam_appid.txt presence error in the folder which annoys the hell out of me (I was able to ignore it for over a month but enough is enough).

I have tried re-installing the game, fixing the anti cheat etc but nothing works.

So yeah, I need a solution to game not starting on official mode and to that steam_appid.txt file error pop up if i make it run as administrator (deleting the file aint working).

If you haven’t already, could you please try:

  1. Remove the ‘Certificates’ directory located here:
    C:\Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\EasyAntiCheat
  2. Then, proceed to repair Easy Anti-Cheat using the EasyAntiCheat_Setup executable located here:
    C:\Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\installers\EasyAntiCheat

You may be prompted to Verify Integrity of Game Files on launch. Keep me posted!

Hello, I’m unable to start a game in the Official Mode, every time I start I get a Backend Error - Server cannot connect. I’ve verified the game files - no errors at all.

What do I do in that case then? Vermintide is added as an exception to my firewall already.
Just in case, do you need my console log or sth?

I did manually verify the files as well and steam found 2 conflicts so it downloaded something new, however that also did not fix anything.

That did not help.
My steam is also located on D drive, not C.

I was not prompted to Verify Integrity of Game Files on launch.

Any other update regarding this issue?

Could you try a Selective Startup, to see if any of your programs are conflicting with Easy Anti-Cheat?:

  1. Press the Windows key
  2. Type ‘msconfig’ and select ‘System Configuration’
  3. On the ‘General’ tab, select ‘Selective Startup’
  4. Deselect ‘Load startup Items’
  5. Reboot your PC
  6. Launch Vermintide 2 as normal

Hi Julia,

Still same thing, won’t start in official mode. Let me know what other steps I can take.


It’s a complicated one unfortunately. Am I right in saying that you can dismiss the steam_appid.txt error, and the Official realm will work as normal?

I can only dismiss the error if I do not run the game as Administrator which in turn won’t even start the game even though the modded starts.

So my options are: either play it in admin mode and get the same error every time or do not play the game at all cause it won’t start part of it otherwise.

I need solution to either of these 2 things

I think you may need to reach out to Easy Anti-Cheat directly, in this situation. They’ll be best suited to assist with this. You can reach them at: https://www.easy.ac/en-us/support/game/contact/tech/

It’s likely a Process Monitor Log will be requested. Instructions on how to do this can be seen here: https://www.easy.ac/en-us/support/game/guides/logs/

Sorry we can’t be of more help. :frowning:

I’m having the same issue, so I followed this tip and deleted the Certificates folder. Unfortunately, when I run the eac_launcher.exe to restore the certs, it says that my Vermintide2.exe is invalid.

I did a Verify Local Files, which identified 3 items to be reacquired. It did acquire them, but the game still won’t launch, with or without mods.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.