Turning off Blood and Gore should do more

It would be great if when you turn off blood and gore it would change the visuals more. I noticed that while it will remove the blood that covers various enemies when hit but not killed, you still get blood fountains when chopping off enemy heads and you can still cut enemies in half (which makes me think this might be a bug?)

Obviously I signed up for a violent game and some is to be expected, but sometimes I just don’t want to see innards while playing, y’know?

I can’t say that I ever even considered turning off blood and gore, but if it’s true what you say then that should definitely be addressed.
If there are those who do not want to see such things, that option should definitely turn that off. No point in having such an option if it doesn’t do what it advertises.

For some reason, the blood sprite effect that appears directly on your camera lens is attached to particle quality, and the only way to disable it entirely is to turn particle quality to lowest. The difference, especially in thick hordes, is like night and day, and I find it highly frustrating that I have to kill the quality on all other particles in order to get rid of it. It would make a lot more sense to have this attached to blood and gore as well.

I reported this as a bug in april and it got tagged as “acknowledged” but nothing came of it…
http://forums.fatsharkgames.com/t/camera-shake-blood-and-gore-persist-regardless-of-settiing/21976

I personally would enjoy this game like 2x as much if it got removed, i just find it really disgusting.

It doesn’t bother me too much; I turned it off originally to help someone else. It does cause some changes, which is why I don’t think it’s the same issue that you reported in April, just not enough imo.

Nothing changed since then, i was talking about the same stuff that is still present now.

It does turn it down, just not enough imo. I turned it off to help someone else test it and it took a couple runs for us to recognize something had changed.

I hadn’t even noticed that. Possibly because my computer is pretty basic so I don’t have the quality up very high to begin with.

Sorry to necro this thread, but I want to second the original request (and the bug link above does not work). Of course I like the violence and gore, but I want to be able to play around my older kids sometimes without my wife skinning me alive–that kind of violence I’d like to avoid. Lack of gore certainly does not make the game G rated, but it’s at least a little better. So turning off blood and gore should disable blood spurts and dismemberment animations, please. Thanks!

It’s no worries, we actually have expanded the options for Gore level in the upcoming content update which will come alongside Winds of Magic.

4 Likes

Please make sure that the on-the-screen blood decals (that block vision) are in a separate setting from the rest of the gore. Personally I like the gore just fine, but I also like to see what I am doing, so I have this turned off.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu