I recently built a new PC, and am unable to launch Vermintide 2’s official realm. I can start a match in the Modded realm, but at the end of the game, it has an error and kicks me out. I can play Vermintide 1 just fine, if that helps.

I can view with no errors. Edge, Chrome, and Waterfox all load a blank page with a valid security icon:

I get this certificate, which seems valid: playfabapicom.crt.txt (1.9 KB)

New PC details

  • AMD Ryzen 9 3900X @ stock speed (no overclock on CPU or RAM)
  • nVidia GeForce GTX 980 Ti @ stock speed
  • Windows 10 Enterprise, version 1903 (Build 18362.295)
    • Patched up to KB4512508 (2019-08-13)
    • No KB4512941 (2019-08-30); it causes Cortana to use 100% of one core, so I uninstalled it for now.
    • Domain joined, logged in to a domain account with admin privileges

My old PC ran Windows 7 Enterprise and was also domain joined (to the same domain, with the same minimal Group Policy applied), so I don’t think the domain is the problem.

Network Setup

I am on cable internet, with a business subscription and static IP. They don’t block/filter anything. My router is pfSense 2.4.4-RELEASE-p3 with UPnP enabled. All other Steam games (including Vermintide 1) work fine, as does my PS4.

I tried connecting to a VPN (Private Internet Access) but it made no difference. I tried Seattle (closest to me) and Japan. In both cases, I ran an Administrator command prompt and ran ipconfig /flushdns before launching the game. I get the same error on the VPN or not. The VPN appears to be working, as webpages see me coming through the VPN.

Logs from my new PC:

Official realm, SSL_CONNECT_ERROR before lobby: console-2019-08-31-03.16.47-e0b4dd96-f3e7-4144-8910-8270b469acbb.log (40.1 KB)
Modded realm, error after game: console-2019-08-31-03.28.19-c2916f9d-96b3-4c27-877c-e348a169f249.log (326.0 KB)

Logs from my old PC

This was my old PC that worked perfectly on Windows 7. Did a clean install of Windows 10, installed Steam, installed Vermintide, and I get the same error:
console-2019-09-06-23.31.17-117d038c-bfeb-4532-abf0-8365fbdf9b99.log (45.4 KB)
Again, this exact PC, but running Windows 7, worked fine. I can restore a working Windows 7 log from my backup if that helps.

Any help is appreciated! Is this just a compatibility problem with Windows 10 version 1903 I will have to wait for the developers to solve?

Thank you for your superbly detailed report! I’ve queried this with our developers and hope to have an update for you soon.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.