Possible bug with capping framerate and potential fix

While following the options posted posted by Julia in a poll on the GPU-related errors thread (here) I tried capping the framerate to 60fps and didn’t crash once and noticed the GPU usage went down to 30% instead of the usual ~97% aboard the Morningstar on during matches [for reference, using 3080ti].

However, the next day and without changing any settings, I noticed the framerate was uncapped again in NVIDIA’s performance overlay with framerates way beyond 130fps and GPU usage hovering at ~97% rather than 30% like previously). I verified in the game settings and the framerate option was still displaying capped at 60 even though the game was rendering more than that. The game continued crashing as it did to me before, during prologue, cut scenes, and actual gameplay in matches.

Each time I started the game from the steam launcher, the only way to ensure the framerate would be capped at 60 involved:
(a) going into the settings menu
(b) changing the selected (but wrong) framerate cap settings at 60 to any other value (eg. 120fps)
(c) exiting the settings menu to apply changes
(d) re-enter the settings menu
(e) change selected framerate back to 60 fps
(f) exit the settings menu to apply changes

Possible workaround for self-resetting framecap option
My crash rate has gone from 2-4 times per match to once every 5-7 matches using this method.

Rather than having to fiddle with the settings at each new play session, I manually capped the framerate using the NVIDIA Control Panel by:

Step 1: Open NVIDIA Control Panel (can be found in your sytem tray found in the bottom right of your taskbar)

Step 2: Select ‘Manage 3D Settings’ and select ‘Program Settings’

Step 3: Find and select Warhammer 40000: Darktide (darktide.exe) in the drop down list

Step 4: Find and edit the ‘Max Frame Rate’ feature in the list (about halfway down the list of features) and set it to your desired value [I chose 57 just to be able to see if it was working compared to the buggy 60fps cap rate in the game options and didn’t bother changing it since].

Step 5: At the bottom right of the NVIDIA Control Panel, select ‘Apply’

If this helps even one person out and/or gives the Dev team an additional analysis vector then I am happy!

Burn the Heretic! Kill the Mutant! Purge the Unclean!