Performance Issues - Micro Stuttering

I’ve held off posting because I’ve been trying different settings and hoping a patch or something would drop, but I am having practically unplayable performance issues right now. Before I describe the issue, here are my computer specs :

CPU : Processors: AMD Ryzen 9 7900X 12-Core 4.7GHz (5.6GHz Max Boost)
GPU : NVIDIA 24GB GeForce RTX 4090
MOBO : MSI PRO X670-P WiFi
MEMORY : 32GB CORSAIR VENGEANCE DDR5 (2x16GB) 5600MHz
OS : MS Windows 11 Home

With a system like this I figured I should at minimum be able to run this game on Medium settings, but even on that setting I get micro-stutters every 2-5 seconds. the game just freezes up for a little bit, long enough to make aiming in melee cumbersome and aiming with ranged practically undoable. I’d love some help finding the right settings for my PC, I originally just let the client set my graphics and then tried letting the NVIDIA GeForce Experience do it. I even tried playing with everything off and graphics on the lowest setting possible. Nothing has resolved it, I really want to play the game, but in this state it just leaves a sour taste in my mouth. I know “It’s Beta”, this is why I am reporting it, happy to work with someone to see if we can get to the bottom of the stuttering especially if others are experiencing it as well.

2 Likes

I had similar issue with a 13700K (8P cores + 8E cores = 24 threads) and managed to reduce the hitching / stuttering occurence by reducing the Worker Threads in the launcher settings.

My default worker threads setting for this CPU was 21, I reduce it down to 8 and it has smoothen the overall fluidity. It look likes there is a multithreading allocation issue but maybe I am wrong and it won’t help you buth worth a try if you haven’t already tried yet.

No this is valid, I’ve heard that a bunch, and I tried reducing down to 18 with no difference. Mine also defaulted to 21, I’ll try 8 and see what happens. Thank you for the response!

OK just a general update for any devs that might see this thread. I’ve tried a couple different worker thread settings, first I tried 8 as suggested and this was the smoothest experience I had so far, the game actually ran better and this was on max settings for me. I also tried 6 and 12 where the game generally ran better, but still had the stutters just not as much. 8 so far has been the best setting though, still stutters, but not near as much and only half as much as 6 and 12.

Operating System: Windows 11 Pro 64-bit - Version 10.0.22000 Build 22000
Processor: Intel(R) Core™ i9-9900K CPU @ 3.60GHz (16 CPUs), ~3.6GHz
Memory: 65536MB RAM
Mobo: TUF Z390-PRO GAMING - bios 3006
Card name: NVIDIA GeForce RTX 2080 Ti - driver version 526.98
Sound card: Sound Blaster ZxR - driver version 6.0.102.75

I just wanted to chime in, I’ve been having the same issues. The game runs smooth almost all the time capped at 60fps, running on high. However, even in the main hub area, running around seems to cause the game to hitch/drop about 10 fps but immediately jumping back up to 60.

Its a bit jarring even if its infrequent. From me just observing it, its almost as if the game is loading assets or something…

I went ahead and changed my worker threads down to 8 in the game’s launcher, and it seems to have smoothed it out. Although it still does happen! I’ll try messing around with other thread settings and see whats up.

— wanted to give an update

I disabled hyperthreading and now the game is running at the max 6 worker threads available, and now I’m not getting any hitching at all. At least none that I can tell yet.

After doing a little research and speaking to some knowledgeable folks about CPUs and Windows settings it turned out to be a weird little issue with how Windows handles certain things with AMD CPUs. Two things you can try are two go into Core Isolation in your Settings and disable the memory scan it does. The second thing you can do is to go into Device Manage and disable high precision event timing. There was a third thing I did in elevated command prompt but I unfortunately cannot remember the exact command I put in. The first two might help smooth things out for you though.

I did want to add to my general thread that my experience with micro-stuttering has been resolved with those fixes. However the game does still randomly crash very frequently, I know the devs are still looking into it, and since I have a thread open I figured I’d go ahead and paste that here :

GUID: a30bf1d1-2242-45ea-9c98-ab9cdccca910
Log File:
Info Type:


I never had these problems until latest update now its terrible, even after resetting shader cache in game and in gpu drivers. I allso disconnect 1-4x a round which also didnt happen last week.

To be honest, although I have an Intel CPU, I would not be surprised if my issues are also related to Windows 11… Not that I hate Windows or something, lol. But I wouldn’t be too surprised.

The latest patch that was released (today) made the game a lot worse now. But its expected!

I’ll look into this to see if there is something Intel-related I might be able to do. Thanks for the information though!

I wanted to report a bit back on this thread rather than create a new micro-stuttering thread. I think the issues with micro-stutters are related to how the game’s networking works. I ran a few tests by remaining stationary and observing fps graphs, and the only time I experienced micro-stutters was when I was remaining still in the main hub area. If I did it on the login screen or in the Meat Grinder, my fps was stable.

Micro-stuttering while remaining stationary in hub - 1
Micro-stuttering while remaining stationary in hub - 2
No micro-stuttering on login screen
No micro-stuttering while remaining stationary in Meat Grinder