[PC] Launcher/game crashes after clicking play

When I try to launch the game via Steam i get an error message:
vermintideerror01
“The program couldn’t start correctly (…). Click OK to close it.”
and then I get this:
vermintideerror02

General details:

  • Running Windows 10 64 bit
  • Geforce 1060 Strix 6GB

I’ve done the following:

  • Installed the anti cheat software manually from within the game’s folder
  • Made sure I have .NET and DirectX up to date
  • Updated my graphics drivers to the newest (Geforce Game Ready 399.24)
  • Tried both the DirectX 11 + 12 versions
  • Copied the “C:\Users<name>\AppData\Roaming\Fatshark\Vermintide 2” from a previous Windows installation where the game worked
  • On first launch I noticed that Steam only installed 1 prerequisite and it only took a split second
  • Rolled back to a previous Geforce driver (doing a clean installation), testing, and updating to the newest driver again cleanly. No change.

As far as I can tell the error 0xc0000142 indicates missing system files. My suspicion is that I might be missing some runtimes libraries or something, but I can’t find any info on what runtimes the game uses.

vermintide2_launcher.log (13.3 KB)

I found out the game would start if I picked modded realms. The screen would just be completely green or black depending on which intro video was playing. After coming to the main menu the game would crash with a DirectX/Stingray error.

I tried rolling back the graphics driver with 4 different versions going all the way back to March. Then I reinstalled the newest on cleanly again, and now the game works perfectly if I pick modded realms. I’m still getting the same error if I start it on the normal realms.

Finally solved the problem. For some reason Windows hadn’t been installing updates. In fact when I went and wanted to look for updates I was told I couldn’t install updates because my PC was turned off (I’m not kidding). I figured out that I was missing a major build update for Windows and found a separate installer for the newest build on Microsoft’s website. After installing that, everything works perfectly.

So it seems error 0xc000142 really does mean that system files are missing. Just posting the solution here in case anybody else happens to have the same problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu