Game crash after i launch it

Hi, i bought Vermintide 2 two weeks ago. The first time i tried to launch the game was 2 days ago, and it never worked, since then i’ve tried many times and many things (changing the visual quality of the game, launching it with or without v-sync, creating an exception in my anti-virus and firewall, “repairing easy anticheat”, ‘Verify Integrity of Game Files’, made sure i had the latest version of Geforce Experience, i even deleted the game once and downloaded it a second time) but nothing worked. What makes it worse is that i can launch the benchmark, AND the “moded realm”, both works fine, but the regular “realm” does not.
So i come here hoping that my issue will be resolved.

I’ve tried pretty much all the possible solution i’ve seen online, but nothing worked.
I really hope that you can help me fix my issue because i really want to play this game with some friends, best regards.

This is most definitely isolated to Easy Anti-Cheat, seeing as the ‘Modded’ realm works. I understand you’ve already tried repairing Easy Anti-Cheat, but could you please:

  1. Remove the ‘Certificates’ directory located here:
    C:\Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\EasyAntiCheat
  2. Proceed to repair Easy Anti-Cheat using the EasyAntiCheat_Setup executable located here:
    C:\Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\installers\EasyAntiCheat
  3. Use the ‘Verify the Integrity of Game Files’ option:

Right-click Vermintide 2 in your Steam library sidebar
Select ‘Properties’
Select the ‘Local Files’ tab
Select the ‘Verify the Integrity of Game Files’ button
When complete, close and reopen Steam

…Failing that, see if a ‘Selective Startup’ changes anything:

  1. Press the Windows key
  2. Type ‘msconfig’ and select ‘System Configuration’
  3. On the ‘General’ tab, select ‘Selective Startup’
  4. Deselect ‘Load startup Items’
  5. Reboot your PC
  6. Launch Vermintide 2 as normal, and see if the issue persists

when you say “remove”, you mean “delete” ? Just making sure because i don’t to do something wrong and English is not my native language.

Yes, delete :slight_smile:

I’ve just tried both of your solution, and it still doesn’t work. In the setting of the launcher i saw something called “debug mod” could it help with my issue ?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu