New patch FPS drop

So after today’s patch (Nov. 24th) I noticed framerate performance is worse than ever. Before the patch I would get~90 frames average, now after the patch i struggle to get 50, I have not changed any of my graphics settings since the patch, if this is “improved” performance, then I don’t want it.

1 Like

Was just about to post this as well.
Before update 1.0.8 I was running with these settings hitting 60 (capped framerate) most of the time except during particularly heavy hordes (ie the end of the smelter mission with flamers and grenades all over the place).:

1440p, 90 HFOV
DLSS on Balanced
Sharpening Off
Everything on high (Except DoF and Motion Blur which are turned off)
Raytracing Reflections > Low
Raytracing Global Illumination > High
Max ragdolls > 12

Now with the same settings, I’m getting 30-40 most of the time with stutters during action. Turning Raytracing off completely, I get smooth 60 except there are stutters during hordes (any horde, even hordes that were no problem before the patch with Raytracing turned on).

Ryzen 5600X
RTX 3060
32gb RAM

Yeah performance is getting worst and worst…was so hyped for this game but at this rate it will be playeable 2 month from launch.
I know the team is hard at work but damn I really hope this game can have a smooth launch

yup, the performance got even worse

I wouldn’t be surprised if they’re adding extra debugging to the production build to understand the GPU hangs. This will slow down the game if that’s what they’re doing.


Glad to hear im not the only one who saw a performance tank on today’s patch, I run a 9700k intel processor and nvidia 3070, I should have no issues running it lol.

Absolutely atrocious performance on 3080ti + ryzen 5 3600x after the patch, 50 if there’s any enemies at all, around 40 during average fights and drops to less than 30 if it’s something more intense.
Lowest possible settings including fov, dlss on performance.

all you guys’ hardware sucks you need at least an rtx 4090

1 Like

Went from 65 (before this patch) to 35 FPS at 4k - I have a 3090; even setting it at very low (DLSS ultra and no ray tracing) I still only get 35-40 frames

Hello, i have the same issue but after looking into it, it seems like my settings don´t stick.
I have a 4k Monitor and have set my settings to 1080p, i can see the correct settings but they do not work.
before i had around 120 fps, now i only get 35 - 40.
I also have amd fidelityFDC 2.0 activated.

Same here, the performance is much worse after the patch. On top of the lower fps I’m experiencing a lot of delay.
The crashes I could tolerate and still enjoy playing, but not combined with performance getting worse.
Devs sure have to push themselves hard to get the game in a playable condition in a week before launch, I feel bad for the amount of overtime some have to do.

It seems tied to mob density, or a lock of some form; neither my GPU nor CPU are busy at all

After this patch, I looked everywhere for anything about fps drop from. Can you please try using the optimal setting in GeForce Experience and let me know if you FPS is back to normal? I had 45 fps after this patch then used Experience and now I am back to 100 FPS and the game looks great.

Optimal from geforce experience has changed from ‘medium ray tracing’ to ‘low’ for my setup - I did try using the ‘optimise’ button in geforece and it did not help (it just made the graphics slightly worse and the frame rate the same)

for those running the game in 2160p, don’t

Ok so strangely using Geforce optimal settings made the game a little smoother even tho it put everything on high, but the drop persist in some area it still goes at 40 frames (mostly area with a lot of transparency it seems but also area with nothing going on)

My performance improved with 1.07 by about 20-30 fps which was most welcome but 1.08 has killed those gains in some areas of the game - mob density (endless horde anyone?) would obviously make it worse but this is not even close to acceptable performance.

I’m running with the following rig:
RTX 3070 Founders Edition
Ryzen 5 3600
16gb Ram

I’ve got all settings on low, all sliders set to minimum, DLSS on balanced, sharpening On and worker threads at 9 but whilst I can get up to 160fps in the Psykanium in actual games my frames are regularly dropping below 60 and I even had frame drops below 30 in the recent patch when a big horde spawned.

You need to find ways for those of us with decent GPU’s but maybe slightly older CPU’s (still meets recommended) to take the load off the CPU because my GPU is not being stretched right now.

Bit embarrassing and ironic considering Fatshark’s Nvidia promotion.

So that’s why. I thought it was just my computer acting up.
But, with minimum settings on my potato, I’ve gone from “it’s a bit laggy on the smelter mission and during hordes” to “I don’t even need to try blocking when someone has recently thrown a grenade, and what weapon is in the characters hands is not representative of what the server currently thinks I’m wielding”. Might have been the patch, indeed.

After 1.0.8 I’ve had really bad FPS drops. Before I was running at around 55 fps normally, dropping to around 45 when a lot was happening. Now it often drops to 35, and sometimes dropping to 10-15, even if nothing special is happening, or freezing, which never happened before. I tried reducing the graphics, which increased the baseline fps to about 70-80 fps, but it didn’t change the drops at all.

I have a RTX 3070, a i5-8600k overclocked to 4.9GHz, 16GB RAM. I was running at 4k, DLSS on quality, ray tracing off, and other settings at roughly medium (had a lot of them high before 1.0.8, but turned them low now).

I also keep disconnecting and crashing, which I never did before (other than when there was server issues and my teammates did at the same time). This especially happens during loading or changing maps (like entering meat grinder), but it sometimes happens in the middle of a map too. When I disconnect during a map, it seems to have issues reconnecting and crashes during reconnect.

There’s also a weird issue where Steam doesn’t notice the game closing, so I need to restart Steam to be allowed to restart the game. This happens both when it crashes, and when I close it normally, every time. I’ve tried running a “verify integrity of game files”.

I turned my graphics down further, and it didn’t help the issues at all. So I wondered if it could be RAM related, and noticed that the anti-cheat was taking a lot of RAM, and that all the RAM was in use (not unusual, the game should take all it can). But I closed my browser and as much as I could of other things that was running in the background, and that seemed to help a lot. I still crash sometimes, but less, and I’ve gotten much less fps drops. So it’s almost back to pre-1.0.8 with higher graphics and browser running. Is it possible that 1.0.8 perhaps introduced some debugging tools or similar that makes the game use more RAM (and CPU, causing other people stable fps loss)? Or there could be a memory leak somewhere.