Load times on windows are almost 3 times that of linux

We kindly ask that you complete the questions below. With this information, we can investigate your issue properly.

Issue Description:
Load times on windows are almost 3 times that of linux.

Crash Report (If Applicable):
[Please see instructions on how to provide a crash report in the pinned Topic]

Error Displayed (If Applicable):

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Play Chasm Logistratum as Ogryn (Skullbreaker)
  2. Attempt to pick up the second Grimoire
  3. Crash

Using both amd cpu and gpu (im using ryzen 5600x and 3600x on two different pc’ s) and 6700xt as gpu on both pcs.
On windows it loads in around 1 48 ish minutes , meanwhile on ubuntu linux using proton experimental , it takes around 37 seconds to load from start to the in game hub.

Using ssd as host for OS and nvme for games. I have tried multiple solutions here and there but it looks like using that cpu gpu combo of amd results on windows throttling the access to the game resources?

Also it sometimes maxes one core 100% which matches the game throttling while loading (loading icon stutters way more on windows).
Mission Name (If Applicable):

[Steam/Microsoft Store]
Player ID:
[Steam ID/Steam Profile URL/GamerTag]

Approx. Time of Issue & Timezone:

Reproduction Rate:
Once - Rare (<10%) - Unusual (<25%) - Common (<50%) - Often (<75%) - Constant (100%)

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here
    console-2023-03-26-15.37.19-4be3ae62-568f-489d-af42-63557a2ed059.log (88.2 KB)

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here
    darktide_launcher.log (34.1 KB)
1 Like

Look in to whether Windows Defender (Antimalware Service Executable) is interfering in this situation and whether you need to add any exclusions. Real Time Protection especially, can interfere with loading times

Does not work , tried selective startup too , added new rules for firewall (already had ) and added exception for microsoft defender , even turned it off/shut down my computer , similar load times . I already reinstalled windows , even swapped ssds.

i have noticed the loading icon shutter too, if you are saying it does not happen on linux, could it be related to multithreading/gpu async compute not being enabled on load time when on windows?

on my machine (sata ssd with bitlocker, ryzen 3600, 32gb ram and 6900xt) the load icon stops spinning for quite a while, the same applies to fire particles from load screen.

i do not get any isses in play, works smooth like a butter there.

There is a bit of shutter only during first 2s when players are sitting in a dropship and when entering hub (1s there, i can see assets loading as i start my run to melk)

Yeap same stutter on windows , smooth as butter on linux. I have tried everything to fix it on windows but no luck. I will stick to linux from now on i guess.

HW GPU Scheduler = false

could you compare this value (from console log) on both linux and windows?

also, if you could attach console log for linux, it would help, maybe one of the rendering options causes game to fallback on linux and somehow that path is more optimized :stuck_out_tongue:

console-2023-03-27-16.44.54-0450e0ec-16d0-484f-9b33-174db59de06a.log (135.6 KB)

This is the linux console logs , HW scheduler is off there too

linux launcher logs
darktide_launcher.log (435.5 KB)

I wouldnt be surprised if it was something amd related , wouldnt be the first time on this game.

linux render is at dx12.0, while dx12.1 is on windows. linux one complains about big upload inrendering pipeline and resizes buffers… maybe this is that?:wink:

hope FS figures it out, it would be great to get these stalls fixed

I can try to use DX 12 instead of 12.1 on windows see if that does something . Also bruh , you do be reading logs.

1 Like

Now im trying to run darktide through dxvk on windows see if that does something .So far it does not work ,lets see if i can manage to get it up and running.

oh, another thing, linux detects u have 12gb of ram on gpu while windows detects you have 0. i wonder if that wont cause some bad defaults to kick in

ive did some simple experiment that confirms that on amd drivers game pauses on windows (blocks rendering thread) when model are uploaded to gpu, one by one

how to reproducte:

  1. go into the mournigstar
  2. go into player cosmetics
  3. chose upper or lower body (any other section with a few of bigger 3d models is needed)
  4. you will see on the left side of the screen that list of available cosmetics will have loading animation (spinning circle)

at this point, there is 0.1s stuttering of your character when models of cosmetics load one by one.

once all models load stuttering of character stops

you can go back to cosmetics screen and go inside the upper and lower body section again to observe the on load stuttering.

i believe the same happens when loading the game, just the bigger models are loaded, hence stuttering is more visible and hence it takes longer to load game

@ppsoy could you please check if on linux this does not happen?

i can maybe clip it and send both video and logs. Almost no stutter compared to windows , like literally 0. All models are loaded on character select , takes about 1-3 secs tops then smooth sailing.

1 Like

@FatsharkJulia would it be possible to get update on this? this issue is visible everywhere in UI and on every map load.

every time when new models are loaded it shtutters, for example that happens when maps load (1…2s stutter) and enterring mission lobby.

each time new person joins or gets ready (model animation changes, hence needs to get loaded) game freezes for 1s. if you get 3 people get ready inediayely game freezes for 3s.

there is no crash or any issue other than the stutter, it looks very annoying

i think it only affects amd gpus (6000 series for sure, msybe others too)


@FatsharkJulia could you please update us on this? are you able to reproduce this behaviour on your end?

I’ll re-raise this with development on Monday!

1 Like

Bit of an update , im experiencing similar issues on warframe , where assets take a bit more time to load ,but that can be done due to it loading shaders after a while of not booting up windows so i will test a number of reboots. ( false alarm it was the shaders that were not cached).
Perhaps darktide is redoing the shaders on windows and not keeping them stored?

1 Like

@FatsharkJulia any update on this?