Launcher still is failing now mods won't work

Issue Summary: The VT2 launcher is failing to load still even after the latest patch for me. Bypassing the launcher - presumably due to the mods not all being up to date - means my game is buggy.

So now I’m stuck with mods I can’t disable (I can’t really even find where they are marked enabled in the config files if this info available that’d be good).

Note the launcher was broken last patch, I was hoping this patch would fix it. Using Windows 10 Professional. No other programs have any issues.

Steps to Reproduce:

  1. Launch the launcher

Reproduction Rate (Choose One):
Constant (100%)

Additional Information:


07:21:51.294 [Launcher] Steam name: Finaldeath
07:21:51.298 [Launcher] Local time: 18/10/2018 20:21:51
07:21:52.443 [Launcher] [Main Window]
Directory Analyses:
[binaries] Num Files: 25, Total File Size: 39991392
[bundle] Num Files: 6887, Total File Size: 51366237234
[launcher] Num Files: 73, Total File Size: 33826542

07:21:52.444 [Launcher] [Main Window] OS Version: Microsoft Windows NT 6.2.9200.0
07:21:52.499 [Launcher] [Main Window] Launcher was started by: Steam(8036)
07:21:52.502 [Launcher] [Main Window] [Load Settings] Load settings from: C:\Users\Andrew\AppData\Roaming\Fatshark\Vermintide 2\launcher.config
07:21:52.539 [Launcher] [Main Window] [Load Settings] Load settings successful
07:21:53.617 [Launcher] [Main Window] [SysInfo] AdapterId: 0 (NVIDIA GeForce GTX 980) OutputId: 0 CurrentResolution: 2560x1440
| AdapterId: 0 (NVIDIA GeForce GTX 980) OutputId: 1 CurrentResolution: 1680x1050
| Processor
| Manufacturer: GenuineIntel
| Name: Intel® Core™ i7-4790K CPU @ 4.00GHz
| Caption: Intel64 Family 6 Model 60 Stepping 3
| Maxclock: 4001
| Total Memory: 0
| Available Memory:0
07:21:53.668 [Launcher] [Main Window] [Game Settings] Detected OS Version 10 >= 10, allowing dx12
07:21:53.807 [Launcher] [Main Window] MainWindow invocation error: System.Windows.Markup.XamlParseException: Set connectionId threw an exception. —> System.IO.FileLoadException: Could not load file or assembly ‘UserControlLibrary, Version=, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. Could not find or load a specific file. (Exception from HRESULT: 0x80131621)
at Launcher.ModWindow.System.Windows.Markup.IComponentConnector.Connect(Int32 connectionId, Object target)
at MS.Internal.Xaml.Runtime.ClrObjectRuntime.SetConnectionId(Object root, Int32 connectionId, Object instance)
— End of inner exception stack trace —
at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
at System.Windows.Application.LoadComponent(Object component, Uri resourceLocator)
at Launcher.ModWindow.InitializeComponent()
at Launcher.ModWindow…ctor(GameSettingsHolder settings)
at Launcher.MainWindow…ctor()

Mods are enabled/disabled in the config file here:

AppData\Roaming\Fatshark\Vermintide 2



I’d suggest unsubbing to all mods and deleting the entire Vermintide 2 folder in App data, then verifying the game files in Steam. This will clear out some local settings, like keybinds and the like and your video settings too, as well as perhaps putting you in the prologue next time you run the game (which you can leave the moment you gain control of Kruber).

Thanks for the tips, didn’t know it was in AppData. I’ll clear out my stuff so mods don’t crash me and at least then I can play the game with glowy eyes.

Hope the .NET app can be a bit more solid in the future though, glad you have bypass enabled though.

I got annoyed after having no mods so went hunting for the bug - based on the errors above I found the UserControlLibrary.dll file in common\Warhammer Vermintide 2\launcher

I renamed it to UserControlLibrary.dll.old and revalidated it to redownload.

Magically it’s fixed. File is identical - according to the MD5 and SHA1 hashes. I have even disabled Windows Defender so no idea what was blocking / stopping / messing this up. Man Windows 10 is just bizarre.

Next time I might reinstall the game from scratch - full delete of the entire directory after removal too.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord