KNOWN ISSUE: Keybindings Resetting at Random

We are aware of and looking in to an issue where keybindings are resetting at random.

Existing reports may be merged here, to help us keep track of the issues being reported.

My keybinds resets whenever I re-open the game. so far I’ve haven’t experience my keybinds reset randomly during in-game.

2 Likes

What the title says. Everytime I load the game I have to redo my key bindings. The closed beta test had the same issue. Please fix this!

1 Like

Can you try checking the file permissions on your settings file

I am using a gamepad and the toggle settings such as crouch and sprint or inversion reset to default when I start up a new game. I just reset the toggle to where I want it before each match so I wont go in with default settings by mistake.

1 Like

Standard keys that have been swaped around (e.g. space for dodge instead of jump) are fine. Any special keys that are not part of the default get set to unassigned everytime the game is started.

Settings were persisting through sessions for the past couple days. This morning they were resetted.

user_settings.config file is not in read-only.

Having the same issue. I’ve rebound almost all the keys i need day 1 and it got saved. i rebound 2 more keys since then and those 2 keys get reset every time i launch the game.
Where’s config file at?
Oh yeah, my user_settings file is not read-only. Other settings (video/audio) seem to save fine.

I have a similar issue with FPS cap resetting

both keybinging reset everytime I restart the game:
wield primary weapon: mouse wheel up
wield secondary weapon: mouse wheel down

Adding my woes to this thread.

I was messing around with trying to get some version of scroll wheel tag working.

Now I have to manually rebind “tag” and “selection next weapon” every time I start the game. ALL my previous keybinds are set, it’s only these two. It’s not reverting them to default, they’re simply unbound when I load the game.

The settings file isn’t read only. I’ve also noticed that DT sometimes will turn RTX on or off. It feels a bit random, always gotta check a couple settings when I log in.

I can redo all other keybinds and they will save just fine, even after a crash. But for whatever reason, the “Weapon Special Actions” and “Tagging Wheel” actions will revert to [UNASSIGNED] every time I re-launch the game. These keybinds will work after I’ve re-bound them, but will revert upon the next launch. It doesn’t matter if the game crashes or I close it manually, these 2 keybinds reset every time.

I’m playing on the Steam version of the game. Keybinds are 0 and MMB respectively, though I’ve tried binding them to other keys and they still revert to [UNASSIGNED].

1 Like

Exact same issue here, really thought it’d be fixed before launch.

Config not read-only and graphics settings on custom.

1 Like

I’m in the same boat and it has not improved through beta or in 1.0. Very frustrating. Looking through the settings file it shows nothing for controller or mouse stuff, while I can find the corresponding lines in the files for Vermintide 2. My settings are definitely saving for other things, like graphics options. I’ll try transposing the lines from the V2 config over to the darktide one.

Only my sprint key becomes UNASSIGNED every time I load up. Everything else seems to stay the same.

I use azeron keypad and its associated software as well as a logitech mouse with macros (key assignments). So I do not use a keyboard to play the game. This might be why I dont have other reset issues but no clue why only sprint resets.

Inversion of Y axis resets to off every time I close Darktide. Probably one of the smallest issues, but could get annoying during the beta if I was jumping back into a game I oft dropped from at the beginning.

Platform is Steam

Player ID:
[Steam ID/Steam Profile URL/GamerTag]

NEISJ4462 OR FIGHTN4JUSTICE

Reproduction Rate:
Constant (100%)

Everytime I launch the game, my keybindings reset for the deployment option for meds/ammo, and for the Auspex. Everything else saves besides these 2 keybindings.

We kindly ask that you complete the questions below. With this information, we can investigate your issue properly.


Issue Description:

A few days ago I swapped my keybindings so I wouldn’t accidentally use my secondary weapon while doing a Zealot penance. After I did I changed everything back, but my keybindings will now randomly reset to my first changes. I am unable to change it in the options screen they list the correct bindings already, but when I’m in the game it won’t ‘update’ and will be stuck with the old bindings. This means I can’t use my ranged at all.

Crash Report (If Applicable):

Doesn’t cause a crash.

Error Displayed (If Applicable):

No error to display.

Steps to Reproduce:

It happens seemingly at random while joining missions or in the meat grinder.

Mission Name (If Applicable):

Any

Platform:
Steam

Player ID:
Mentalseppuku

Approx. Time of Issue & Timezone:
Most recently happened during a game I ran around 6:30 pst est 12-4

Reproduction Rate:

It’s become common. I re-installed and the problem persisted.

Upload Supporting Evidence:

Console log:

console-2022-12-04-21.52.40-2e3a6003-9073-48b4-a2da-c6f29a63bb31.log (415.0 KB)

Launcher:

darktide_launcher.log (217.1 KB)