KNOWN ISSUE: Keybindings Resetting at Random

Can confirm although it’s not at random. The user_config is NOT readonly (yet it doesn’t appear to store keybindings in this file anyway?!)

Turning off steam cloud just shifted the problem.

Previously wanted to bind the Q key to the “blitz” action. It would become [unassigned] each time I started a new session.

Now with steam cloud disabled, the Q key bind is persisting, but I’ve been trying to bind the SHIFT key to both run and tag (which WAS working prior to disabling steam cloud), now on each new session both the SPRINT and TAG actions are [unassigned] and I have to rebind them on each new session.

You’d have thought they’d have got this right by now with two Vermintide games under their belt :frowning:

Hopefully this gets fixed soon as it’s a real pain for such a seemingly simple thing.

Issue Description:
Whenever the game starts, the key binding for the Quick Wield action, has been cleared.

Steps to Reproduce:

  1. Start the game
  2. Log in on a character
  3. Open key bindings.

Mission Name (If Applicable):


Approx. Time of Issue & Timezone:
Every time game starts, since it released on early access.

Reproduction Rate:
Constant (100%)

Upload Console Log:
Log contains personally identifiable information. I’m not uploading that for everyone to view.

1 Like


We kindly ask that you complete the questions below. With this information, we can add it to our database for investigation.

Issue Description:
I’ve tried changing my tag keybind from the mmb to keyboard keys and run into two issues, the lesser one is that sometimes the keybind does not stay assigned between sessions or operative changes (couldn’t find a reason that it does work sometimes and doesn’t others) and when this happens the keybind is set to “unnassigned”. The more important issue though is that occasionally changing the keybind seems to make the tag and tag wheel functions inoperable, even if you attempt to swap the keybind back to mmb. The inoperable tag / tag wheel I was also unable to find a solid reason for, it’s only happened twice but on both occasions it’s been the case that it worked fine set to my keyboard keybind, then I quit the game, and when I started the game again I realized during a match that although the keybind was showing it assigned to the correct key, they would not work on key press, changing back to mmb or any other key did not make the functions operable again.

Steps to Reproduce:
[Please add the steps that can help our QA department in reproducing the issue. For example:]

  1. Change tag and tagwheel keybind to a keyboard key
  2. Change operative / quit game
  3. Re-enter as new operative / start game
  4. Check tag keybind to see if still assigned / attempt to use tag and tag wheel

Mission Name (If Applicable):


Player ID:
[Steam ID/Steam Profile URL/GamerTag]

Approx. Time of Issue & Timezone:
12/12/2022, 19:21

Reproduction Rate:

Upload Supporting Evidence:
[Screenshots, recordings, links to Twitch VODs, etc.]

Upload Console Log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide\console_logs
  4. Locate the console log that corresponds with the session in which the issue occurred, by looking at the timestamps in the log names
  5. Upload here

Upload darktide_launcher.log:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Darktide
  4. Locate the darktide_launcher.log in this directory
  5. Upload here

Thank you for your report! Could you please provide us with your launcher log file, as well as the console logs that correspond with a session where you had this issue?

I believe the instructions to locate these files are at the bottom of your post :slight_smile:

1 Like

2022-12-13 logs :
console-2022-12-13-06.09.46-c30e4127-bae4-45b8-a26a-2904b364482c.log (6.6 KB)
console-2022-12-13-22.58.28-64b5c239-8f29-44d8-9ec4-39b0cd627df6.log (330.3 KB)
console-2022-12-13-01.51.54-d2a63b2f-1e69-4f71-86fc-3e5870ccc5a7.log (296.7 KB)

2022-12-17 logs :
console-2022-12-17-09.55.15-d6926a92-9ae1-4d9c-9ca1-967250d32354.log (981.7 KB)
console-2022-12-17-12.01.28-b0cf34f6-4329-47a3-826b-3df2ec9d4be4.log (150.6 KB)
console-2022-12-17-12.12.18-af72cac3-90df-4285-8247-78dffaaee074.log (50.8 KB)
console-2022-12-17-00.28.44-161979bf-c4c9-4277-ba80-470471830163.log (265.8 KB)
console-2022-12-17-12.16.03-a63d6210-d50d-4b75-950b-1a602a45f428.log (50.7 KB)

Launcher log :
darktide_launcher.log (816.0 KB)

Attached logs from original post day and today.

Also I’ve so far been able to remedy the issue. What I did was : open the keybinds menu, set all keybinds to default using the “hit spacebar to reset to default” option, then change them to my desired keybinds. After doing that the keybinds seem to be staying between game instances. The most recent two console logs under 2022-12-17 should be the ones where the keybinds stayed properly, all the others should have been ones where they reset after quitting.

And just incase it’s relevant, I noticed before finding the fix that only non-default keybinds under “Ability” were being reset, while non-default keybinds under “Movement” were staying between sessions. e.g. I changed dodge from “Space” to “Shift” and it stayed between sessions, but changed tag to “B” and it did not. Also I noticed that changing keybinds manually to their default key, e.g. changing quick wield from “Q” to “Y” then from “Y” to “Q” caused the quick wield keybind to change to “unassigned” between sessions (before the aforementioned fix) even though it was technically still on the default keybind, so the issue seemed to maybe not have to do with the bind itself but with the fact that the player changed it at all


Thank you for the update. Have you had the issue where the tag wheel stopped working recently or is it just keybind issues?

Haven’t had the tag wheel not working issue since making the original post, and afaik I haven’t seen other people have the issue either so, idk maybe the machine spirit was just in a bad mood that day /shrug

1 Like

Still having problems binding the “q” key to the “blitz” action.

Same deal as mentioned in another thread. The binding appears as “unassigned”. I can set it for the session, but on quitting the game and loading at a later point, the binding is cleared. Other key bindings for other actions have persisted fine.


Steam ID

Approx. Time of Issue
06/01/2023, 11:45AM UK

Reproduction Rate
Every new game launch

Console Logs
console-2023-01-06-11.53.46-6f3dc004-c8f5-4e1a-8428-b5dcd489fcff.log (25.3 KB)
console-2023-01-06-11.39.38-9b2cd9ac-4dca-4ad0-8d21-681d50250b41.log (134.3 KB)

Launcher Logs
darktide_launcher.log (995.6 KB)

Also, not quite related to the key binding issue, but similarly, certain graphics options also don’t “stick” as it were.

When I initially launched the game with detected settings, it set ray tracing on to “low”. After my 3080ti almost melted and set fire to my house I turned it off which had no effect. Nor did exiting the game and re-launching.

A fix has been mentioned here. Low and behold, turning ray tracing off doesn’t turn everything off so again I had to manually edit my user_config file.

Totally agree about the lack of any key binding mapping in the user_config file so not sure where the actual key bindings are stored!

Issue Description:
After every restart of the game, special attack keybind needs rebinding
Steps to Reproduce:
Restart the game
Player ID:

sames, I have to redo my controller settings every time I launch the game. The proper settings persist if I change operatives or go to the main menu but if I close the game then I’ll need to do it again next time

1 Like

Same here, even before the update… controller sensitivity and aim acceleration.
Have you tried the new aim assist settings?

When i set “quick wield” to mouse scroll up or down, it resets to back to nothing after a game restart.

Controller keybinds are different. Why did you do this to us controller underlings. :frowning:

  • Sprint + weapon special action (clicking both sticks at same time, L3 + R3) now opens up text chat. This has gotten me killed twice already. I have to react quickly and press start on PS4 controller to close chat. I’d like to completely disable text chat on controllers, but rebinding keys on controller is currently not an in-game feature

  • The barter and inspect action have been switched. Holding square now barters, and pressing R3 inspects, when it used to be the reverse since the beta. Why the change?

I’m sure there’s more, but if I’m not able to customize my controls beyond “default” and “advanced”, can you at least not change them?

I use an xbox one controller and ever since the update, my right trigger doesn’t respond, meaning I can’t attack and making the game unplayable. I’ve tried it on multiple other games, including Vermintide 2, and have no problem. Is there something I can change to fix this?

Issue not resolved.

I believe I have a solution, firstly here’s the tl;dr steps to fix.

  • Disable Cloud sync in Steam
  • Open the game, set your controls

At this point you should notice your keybinds not resetting.

Now if you want to re-enable cloud saves, you need to grab the new default file.

  • %APPDATA%\Fatshark\Darktide should have a default.sav file now and possibly default.old
  • Copy the default.sav file to /userdata//1361210/remote
  • Make sure to remove the extension so it is no longer .sav
  • Now if you re-enable cloud sync it will upload this correct file to the steam folders with your keybinds.

Some things I noticed possibly telling more of the story.
My default file originally was about 5kb and originally was very old. So likely there was a patch change at some point maybe adding more keybind options that’s why they got stuck as unassigned perhaps. I’m not exactly sure. There’s clearly a flag somewhere whether or not use the cloud, to load and save that default file.