High Worker Threads = Crash <-- Devs Please Fix

Switching to 1 worker thread for more stability works most of the time, but the game’s optimization and performance even on high-end rigs is terrible and relies heavily on DLSS/FSR.

Being limited to just 1 thread guts performance that much more, this is an action FPS game; we need high frames… at least 60 fps stable (which is still not great).

I’m surprised this hasn’t been fixed yet, it’s seemingly the main issue/fix people are having.

Going to chime in with my own crash log. The game runs fine on 1 Worker Thread. 2 Worker Threads gives a crash in mid-mission, and I just tried with 3 Worker threads and the game crashed while loading into the Mourningstar. I have an i5-9600K and an RTX 2070 with 32GB of DDR4 RAM.

EDIT: Sorry, here’s the actual log itself.
console-2022-11-25-04.00.56-7a409bc3-610d-4f79-af30-dc8e5809a329.log (44.6 KB)

GUID: 7a409bc3-610d-4f79-af30-dc8e5809a329
Log File:
Info Type:


I see no update here since 2 days, but still adding my stone:
ryzen 7 3700x
geforce 3070

  • with more than 1 worker threads = a lot of crashes in windows 11
  • with default thread count i had no craches in windows 10

i did multiple windows CLEAN reinstalls over the weekend to test it out

Cheers

It’s definitely not just Windows 11, this is happening to me to on a Windows 10 device. My specs:
CPU: i9-11900K, 8cores.
Display: NVIDIA GeForce RTX 3090
Memory: 32 GB
OS: Windows 10 Pro

I could not pinpoint any particular thing that was happening in game which corresponded with the crashes. It felt very sporadic. But once I reduced the worker threads to 1, the game stopped crashing during missions. FPS suffers tremendously as a result of running on a single thread, however.

console-2022-11-26-17.43.01-cd80873d-e15a-4bb4-a58c-54f738fc6a53.log (155.0 KB)
console-2022-11-27-01.22.10-98837972-12ab-4a15-965b-abf700865d84.log (950.6 KB)
console-2022-11-27-04.30.49-b59e8793-cb09-4240-bc0e-c0140bbe1836.log (298.8 KB)

1 Like

Having the exact same problem. I crash within a few minutes of launching the game, setting worker threads to 1 fixes the crashes but gives me about 20 fps during hordes and the game becomes very jerky in movement.
I want to remember that this started / became much more apparent after one of the beta patches. I think it was 1.06.

I reduced worker threads from 13 to 6 and that seem to fix the issue, i manage to complete one whole game while previouslz it crashed after 5 minutes

Still the same problem like in the beta reducing the worker treads to 1 resolves the problem but the game get very choppy and laggy from 120 fps to 40 at best.

I’m rly fed up with this how hard can it be to implement multi treading in 2022?
This game feels like a big advertisement for the rtx 4000 with so many gimmicks no one uses but impact performance massive for older generation cards.

I uploaded around maybe 300 log files I don’t bother to upload them now you should know now the problem and hopefully a solution.

System:
Win 11 Version 10.0.22621 Build 22621

MSI B450M Mortar Max
AMD Ryzen 3700x
32 GB RAM 3200 Mhz
Asus TUF RTX 3080 OC
Sata SSD

GPU Driver: 526.98
AMD Chipset Driver: 4.11.15.342
Bios Version: 7B89v2H

I have the same problem is really hard get any progress on the character, no getting exp from the missions most part of the time crash on the ending and no chance to reconnect. Expect this to be fixed after the beta but the issue is still there and not only crashing on the missions but crashing anywhere in the game, on the main menu, on the loading screen, etc.

1 Like

Exactly the same here. Anything other than 1 worker thread = complete and unpredictable instability.

O/S: Windows 11 Pro 22H2: Build 22621.525
GPU: RTX 3080Ti
CPU: Intel 9700K
RAM: 32GB 3200 Mhz
Storage: SATA SSD
GPU driver version 527.37
Game Build: Microsoft GamePass - Although it happened in the Steam closed beta during October.

It’s the only way for me to play it without crashing at the moment. It sucks because as everyone says, lowering the threads saps performance, no matter how much eyecandy you sacrifice. Sad this was also an issue in the closed beta. Would have thought it would ship fixed. :frowning:

1 Like

Crashing 5 times per game, not receiving anything at the end… what an absolute clownfest.

1 Like

New drivers (527.37), still crashing.
console-2022-12-02-07.48.40-5bfa3c8b-ace7-4ad8-9c41-465b219071a2.log (146.6 KB)
crash_dump-2022-12-02-07.48.40-5bfa3c8b-ace7-4ad8-9c41-465b219071a2.dmp (828.8 KB)

The only real fix for me has been rolling back to WIndows 10, no crashes ever since.

I’m having the same issue

8700k
3080 ti
32gb ram
windows 11

this is what it says in the crash dump

FILE_IN_CAB: crash_dump-2022-12-02-22.06.41-aae69e93-de62-48ba-a4f5-1e645b9852d8.dmp

NTGLOBALFLAG: 0

PROCESS_BAM_CURRENT_THROTTLED: 0

PROCESS_BAM_PREVIOUS_THROTTLED: 0

CONTEXT: (.ecxr)
rax=00007ff6f00e57e0 rbx=00007ff6f0888c01 rcx=000000505a1fe5f0
rdx=0000000000000000 rsi=000000505a1fe5f0 rdi=0000000000000000
rip=00007ff6f00e5804 rsp=000000505a1fe2b0 rbp=0000000000000000
r8=0000000000000018 r9=000000000008001f r10=00007ffb83520000
r11=000000505a1fe500 r12=000000000000e690 r13=0000000000000000
r14=0000000000000000 r15=0000000000000004
iopl=0 nv up ei pl zr na po nc
cs=0033 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010246
Darktide!vswprintf_s+0x7b4:
00007ff6f00e5804 893c2500000000 mov dword ptr [0],edi ds:0000000000000000=???
Resetting default scope

EXCEPTION_RECORD: (.exr -1)
ExceptionAddress: 00007ff6f00e5804 (Darktide!vswprintf_s+0x00000000000007b4)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 0000000000000001
Parameter[1]: 0000000000000000
Attempt to write to address 0000000000000000

PROCESS_NAME: Darktide.exe

WRITE_ADDRESS: 0000000000000000

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.

EXCEPTION_CODE_STR: c0000005

EXCEPTION_PARAMETER1: 0000000000000001

EXCEPTION_PARAMETER2: 0000000000000000

Really frustrating as it runs like garbage at worker thread 1, but runs smooth as butter at 6 but crashes often

An update on how this problem is being ddealt with would be nice

Another couple of crashes today. Experimenting with upping the worker threads. I have it set to 6/6 and was running amazingly well and stable after this week’s update (Windows Store/GamePass version). Just crashed now, so here’s the output:

GUID: ad793387-ab51-4361-8b7e-da72eae0c86b
Log File:
Info Type: