Freezing about 3-4 minutes into a game

GUID: b13a23f9-727d-4428-b78e-d4a04d8fc477
Log File:
Info Type:


The game just freezes about 3/4 minutes into a game and I cant quit it except by force quitting using the task manager. The music continues to play while the game is frozen. It doesn’t freeze in the tower, only in game.

Things I have tried:

  • Removed my overclocks
  • Removed all mods
  • Checked temperatures and stability in other games
  • Fresh graphics driver install
  • Playing weaves instead of normal game
  • Deleted and reinstalled the game
  • Ran EAC setup thing
  • Deleted user settings from %APPDATA%/FatShark/
  • Played a game in mod realm (no freeze in modded realm, but I only played one game)

console-2021-04-11-04.46.47-7eef1040-b467-422e-bbac-7c04fb5cd9dd.log (192.1 KB)

More things I have tried:

  • playing different careers and weapons:

It seems that the game only freezes when using any bardin career with masterwork pistol or cog hammer

After swapping out and trying different weapon combos, my cog and dwarven 1911 theory seems to be wrong.

How new is your PC @stormaes? We’re noticing those with Ryzen CPUs have had to update their BIOS to ensure maximum compatibility between the motherboard and CPU, usually in new builds, although the symptoms don’t match up entirely with what you’re experiencing it may be an option worth exploring.

My PC is fairly new. Although I’ll update my bios now to exclude that as a possiblity.

Do you have any other suggestions?

@FatsharkJulia I tried updating my bios to the latest one. I also updated my chipset drivers, I still got a freeze within a few minutes.

GUID: 2c6f9853-82d2-4ed9-b9fd-d9f27d08ae56
Log File:
Info Type:


console-2021-04-11-13.52.49-ca0520c2-cd88-43e2-93d6-bc31db6750bc.log (192.1 KB)

That’s unfortunate. I can’t see what the issue is from the crash reports/console logs unfortunately, it’s actually cut-off at the end and excludes the information we need. I’m seeing more of this lately so that’s potentially an issue in itself.

Within the launcher’s ‘Settings’ menu, try lowering your ‘Worker Thread’ count to 6 and/or switching to DirectX 11 to see if that produces better results.

I forgot to put it in the list but I have actually tried both those things.

I am aware of the logs being cut off. I was hoping you could see more from the crash dump.

Seems to be some issue with EAC.
Playing the game in the modded realm causes no freeze.
I removed all references to EAC in the launcher and binaries directories, and it runs great with no freezes, however EAC says that I’m untrusted.

I think I worked it out.

LightingService, ASUS bloatware to control led lighting on my motherboard, is detected by EAC as suspicious.

1 Like

Heh, nice work! Usually Easy Anti-Cheat displays an error in the lower right-hand corner of the screen when LightingService is detected. How annoying it never appeared for you - it would’ve saved you some hassle! Glad to hear you’ve sorted it out.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu