EasyAntiCheat Preventing Game from Launching


Another day, another issue in which my game now straight up no longer launches due to “System32” errors in relation to EasyAntiCheat. Modded works just fine. It loads up and I can run the game as if it were normal, but I want to play in Official and get my chests and reds. Either way, attached to this post are the error messages I’m receiving, as well as a detailed outline of the actions I’ve already taken in an attempt to rectify the situation while still failing to do so.


These are the error messages I’ve been receiving when trying to load into Official Realm. I followed the links to the site which gave me options of which I exhausted. Here is what I’ve done so far:

  1. Deleting the .sys file.

I navigated to the EasyAntiCheat.sys through System32 and the Drivers folder, deleted AntiEasyCheat.sys, had it reinstall automatically, and tried relaunching the game. This did not work.

  1. Verifying the game through EasyAntiCheat

I opened EasyAntiCheat’s driver and had it reinstall and repair itself where V2 was concerned. This also did not work.

  1. Enabling Service through RunPrompt

I ran a prompt using the command services.msc and switch the Startup Type of EasyAntiCheat to Automatic and applied the fix. This also did not work.

I’m not sure what’s happening. I verify the game caches once every two to three weeks, I keep it updated, and I have literally done nothing different from one day to the next on my computer. I rarely venture into system folders without aid because I’m somewhat technologically inept and don’t want to mess things up. All I’ve really done lately is play V2 in official and write up Word Documents for TRPG’s and job hunting. So running the same routine, day in and day out, only to be met with major game issues ever since the update happened has me wondering what’s going on.

Any further assistance or suggestions would be greatly appreciated, as I would like to get back into hunting for all the red skins in the game.

Thank you for your time.

Nevermind! I Googled the error and found a FatShark troubleshooting post. The steps taken in the image below solved the problem! Sorry about the post!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.