Official Realm does not work

When I launch the game (its the same in windowed, full screen & borderless full screen) it just sits as a black screen. My computer is not frozen and I can still do things. After about a minute I can hear the opening cinematic for Fatshark. But after that still nothing. I have updated my drivers to the best of my knowledge. Im not super savvy when comes to troubleshooting these issues. Ive looked up possible solutions online but i couldn’t find anything that worked for me yet. The game does run fine in the modded realm, so its just the official realm that doesnt load up. I do not have any mods, and i have reinstalled the game to double check, and verified game files multiple times. Any advice would be appreciated.

Specs are: -Intel® Core™ i7-7700HQ CPU @ 2.80GHz -NVIDIA GeForce GTX 1050 T -Intel® HD Graphics 630 -8GB Ram -Windows 10

Sounds like perhaps this is related to Easy Anti-Cheat. Could you please try repairing Easy Anti-Cheat via the EasyAntiCheat_Setup executable located here: C:\Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\installers\EasyAntiCheat

Keep me updated! :slight_smile:

1 Like

Yeah ive tried that one too a few times. Attempted again now and still nothing. Uninstalled the EAC and then reinstalled too. No changes. I dont even get a crash error, unless i close the game before i hear the Fatshark opening sequence. I Dont think its related but its

GUID: d32b6816-8974-4df8-979d-2763bc4caec1
Log File:
Info Type:

[Engine Error]: Unloading a locked resource #ID[17b6b101], lock count: 11, was cleared: false. Make sure you destroy all resources pointing to the package before unloading it.At D:\agent-work\data-dir\engine_release_bogenhafen_08_14\runtime\foundation\resource\resource_manager.cpp:871 in function stingray::ResourceManager::ensure_unlocked

I’m not sure it’s related either but I’ve popped it over to development regardless. :slight_smile:

Could you try briefly disabling any Firewall or Anti-Virus software and seeing if the issue perists? Wondering if that could be interfering with Easy Anti-Cheat somehow.

No changes after disabling the firewall or anti virus. Just does the same :man_shrugging:

That’s a shame! Let’s make sure Easy Anti-Cheat is enabled within your ‘Services’. This can be done by:

  1. Navigate to the Task Manager
  2. Select the ‘Services’ tab
  3. Select the ‘Open Services’ button, located at the bottom of the window
  4. Locate ‘EasyAntiCheat’ within the list
  5. Right-click it and select ‘Properties’
  6. Change ‘Startup Type’ to ‘Automatic’
  7. Save your changes
  8. Reboot your PC
  9. Launch Vermintide 2 as normal

Should this prove to be unsuccessful, you may need to contact Easy Anti-Cheat directly. They’ll be able to provide the best advice in this situation: https://www.easy.ac/en-us/support/vermintide2/contact/tech/

Be sure to include as much information as possible in your message to them, and please let me know if there’s anything I can help with.

I will try this later tonight and let you know, thankyou.

I switched startup type from manual to automatic, and still no change. I suppose i will contact EAC. Thank you for the help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu