Easy Anti-Cheat won't start. Game starts without EAC

Hello everyone.
Launching through the launcher, there is no banner with the EAC download bar, game starts immediately.
The game has loaded, but in the game I do not see the lobby and the forge menu (item creation) and the pedestal with trophies are not available to me.
Also, when choosing a new class for Bardeen(Engineer), the game crashes with a crash report.
(Below I attach links to a video with a problem)
console-2021-02-14-10.52.31-2d478b6d-4446-460c-95ab-3811789cb3a7.log (110.8 KB)
GUID: 9e85741c-3b7e-4b3e-be49-110b6b89f3ac
Log File:
Info Type:

[Script Error]: …ult_player_unit/inventory/simple_inventory_extension.lua:1634: attempt to index local ‘slot_data’ (a nil value)

Hello! Is it possible you’re accidentally launching the ‘Modded’ realm, as opposed to the ‘Official’ realm? Your realm can be changed using the checkboxes next to the ‘Play’ button within the launcher.

Additionally, the crash is something we’re looking in to - apologies for the inconvenience.

I’m pretty sure they’re starting the official realm in the first video (0:18 timestamp).

1 Like

D’oh, I missed that! :woman_facepalming: Thank you.

@Saul_Ratvitz, the console log seems to think you’re playing on the ‘Modded’ realm as a result of Easy Anti-Cheat being unhappy, so we need to determine why that is. Firstly - have you tried repairing Easy Anti-Cheat? This can be done using the EasyAntiCheat_Setup executable located here:

C:\Program Files (x86)\Steam\steamapps\common\Warhammer Vermintide 2\installers\EasyAntiCheat

2 Likes

Hi, thank you for responding.
I run the game only in official mode.
Yes, I have already tried several dozen times to reinstall, fix, Anti-cheat using the file you specified - everything is useless.
Every time you try to start the game in official mode, Anti-Cheat does not start, the game logo with the Anti-Cheat loading bar does not appear - as it should be in all games with EAC support.

I also tried to copy files from the Warhammer Vermintide 2 \ installers \ EasyAntiCheat folder, in other game folders with the word “EasyAntiCheat” - nothing helped. I hope this did not damage the game
I’m just desperate.

Waiting for further instructions

I dreamed for so many years when Bardin would be given a gatling machine gun.
And now this moment has come - but I cannot play.
Very upset =(

Hmmm. Could you please check that the Easy Anti-Cheat service is enabled by:

  1. Open the Command Prompt as an administrator
  2. Enter the command:
    services.msc
  3. Locate Easy Anti-Cheat within the list and double-click it
  4. Change ‘Startup Type’ to ‘Manual’
  5. Save the changes

Checked, the startup type was already set to “manual”.
The result when starting the game is the same
What actions should I try next ?

Sorry to hear that. This will need to be escalated to Easy Anti-Cheat. They usually prefer to speak with our players directly, either you could contact them here: Easy Anti-Cheat or I can do so on your behalf (but please be aware this will increase the turnaround between responses) :slight_smile:

1 Like

I would be grateful if you would contact the EAC and pass on all the information about my problem.
I can wait as long as necessary.
Answers from the EAC team to wait here?

1 Like

Sure, I’ll raise this with Easy Anti-Cheat. I’ll let you know here once I’ve received a response. :slight_smile:

2 Likes

Easy Anti-Cheat have kindly requested a Process Monitor Log per the instructions here: Easy Anti-Cheat

2 Likes

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

I am attaching a link to the process monitoring log
I posted the file on google drive, as the size is large

Super. I’ve passed this on. :slight_smile:

Why not join the Fatshark Discord https://discord.gg/K6gyMpu