Darktide - extreme flicker ingame and menus

Hello Guys,

i have tried almost everything, inclusive lowering settings to all low. I have an extreme flicker issue. it is not just in the armory like some people written, it come spontaniously, everywhere, mostly when some elements, which i can activate or having pop-up instructions appear, e.g. in the match selection area.
Also when just walking from one to another room, it may start flicker. I have recorded it and shared below.
I don’t kmow what to do, it not allows me to play the games as it is. The newes nvidia driver is installed for the 4090 RTX (526.98). It can run without flicker but flicker can come withour any warning at any time. Often it works to remove game from focus (alt+tab) and bring back to focus, bit it come back again. I though previously windowed mode flicker less but this is not true. Any idea what do do?

Thank you in advance

You should have a ‘Frame Generation’ option under DLSS in the ‘Video’ menu. Try disabling that.

1 Like

I’m not using FG, it disables VSYNC and tear like hell and 120FPS feels like 40. As described, i’ve disabled everithing and reduced all to low, it still flicker.

I’ve did some thoughs and i have disabled hardware accelerated GPU scheduling. This seems has eliminated the flickering completly. I don’t think it is a soltion as thtis costs performance.
Please share wih developers to get this analysed Julia.

Screenshot 2022-11-22 173919|689x494

Sorry guys, waiting queues for a paid game, massively consuming the expensive elctricity for nothing (for feeding putin) - THIS IS 100% INACCEPTABLE!!!

The card is consumign 76 watts for your crazy waiting queue…

I’m quite unsatisfied, the HAGS (Hardware Acelerated GPU Scheduling) issue reported is even not mentioned in the “Known Issues” website/blog but it is still (omni) present. No further feedback if it will be resolved. I don’t like such way of treating the users which doing the investigation for the developers.

I have the exact same issue specifed here. But only with vertical sync active and I need that to play on my Qled TV since it’s 60hz. I’ve tried the 60fps limit in options but then I get screen tearing somehow. I’ve tried pretty much everything, and right now I’m forcing the nvidia drivers to have Vsync on but it still flickers but atleast I can see the screen sometimes. Totaly unplayable!

I have a i7-12700K with a 4090 newst drivers on Windows 11. First time in my gaming history I’ve experienced this isses. Been playing on PC for last 20 years!

Fatshark! Please look into this and please give a respond.

Thank you!

Bytemare, disable FG (frame generation), Fatshark enables this mess every patch but you need to disable, FG is disablign Vsync and 120 FPS feel like 40

Dear Fatshark - why are you resetteting the graphical serttings after every recent patch? This really sucks. You can write how often you want - you can change in menu later, i don’t want you change them how you want, for example enabling shitty FG (again and again) and disbling SSR and other unwanted “Tweaks”.
Keep your hands of the settings menü, please fix the bugs, there are sooooooooooo many.

Thanks for your feedback :slight_smile:

I’ve dissabled FR and I do have Vsync on since I want to play in locked 60 on my TV. Problem is, it’s still flickering once a while. Some places bad, and some placed a bit less. Just tried to turn off RT 100% and might be a little better but still… feels like I want to leave this game for now any try in a month or two.

Tierd of messing with settings and just want to play hassle-free.

Hope Fatshark can give a reply regaring this issue at some point and make it a priority soon.

I am having this issue as well. Running a 4080. Gotta be something going on with DLSS, Frame Generation and/or VSYNC on 40-series cards. Not seeing the issue in any other game and just like OP I’ve tried everyting but can’t get Darktide to behave. It ran fine on my 2060s during beta 1-2 weeks ago.

I tried to turn off Ray Tracing completely and it helped alot. Still some flickers here and there but it’s atleast playable now. Everything else is maxed out, framegen is off, just normal dlss. Hope it helps.

Fatshark where are you?

Next patch, still the Subtitle bug unresolved, still HAGS flicker (I have to keep HAGS off, FG don’t work without HAGS) and nothin in the release notes that these items are known issues. I’ve also still not received the Imperial Edition items. Just no reaction. This really sucks. I was thinkign the community work of Fatshark is better but this may be the Tencent red world impact…

Fatshark - any idea, beside the Bugs which you not fixed since weeks, why i need few times press space, space, space, esc and space to finally just to enter the game? I feel like rhesus monkey in a laboratory experiment. This is so annyoing, like the idiotic procedure to disable/enable the subtitles and enabling SSR ON EACH GAME START!
So even just startign the game is hard work guys.

Any idea when we receive the Imperial Extras? Nothing yet received…

Update Patch 1.0.20

Now it become even more extreme annoying - you have to hold space to skip one of the many intro video.
Dear Fatshark, i really starting thinking you are somewhat sadistic? So many space, esc and again and again already and then you adding this holding the space key exercise. WHY??? Why not going directly into the game, without advertising, usless healthcare information etc? I assume you removed mod support to ensure that nobody can skip this idiotic exercise on each game launch? Calling it “sadism” is the rigth, very diplomatic term, a more honest statement will be very likely censored here.
one idea for you, why are you not adding a captcha exercise to confirm the epiepsy warningn screen at every game start?

This is so frustrating, new “features” like space holdng video skip has been introduced (many users were aksign for it :joy: ) but open bugs remain open:

  • Subtitles needs to be enabled/disabled each game start to get rid of them
  • SSR need to be enabled after every game start, it is always Off after game start
  • HAGS results in extreme flicker
  • Extreme monkey game startup action (key pressing rhesus monkey exercise)

at the begining i was thinkign issues are being taken seriously but i have to change my opinion.

An update for Fatshark support:

as i continuing the investigation work on the HAGS issue, which you never confirmed in your “Known issues”, disablign VSync is eliminating the flicker - but the game is then looking horrible with the typical, extreme tearing artifacts, so also this is not a soltution for you full price game but this info may help you in your investigation (im not sure if you are investigatiug, you maybe are more focused on more premium “press & hold spacebar to skip one of the intros” features) ?

it is 13trh of January 2023.
All the bugs listed above are fully unresolved. This is so annyoing.

Yeah I’ve completely left the game and have no hope for it ever. It’s sad, last time I’ll ever preorder a game without waiting a few days or a month to check reviews first. Thanks Fatshark!

This is chinese tencent quality. I have preordered the game as i really loved to play vermentide. This game is a disaster, it runs so bad on a RTX 4090…