Darktide refuses to detect/use my actual GPU

So i love the game. The sountrack is a bop and the game itself is just entire satisfying. That is in the moments I dont have 3 fps. Now i have done literally everything and found a useable fix that slightly worked. Then i tried downgrading to Windows 10. Reinstalled but this time i was paying attention and noticed that the entire time it was using my laptops motherboard Integrated GPU. So now it all makes sense now.

So now i am trying to figure out how to get the game to actually detect and use my actual GPU. Well nothing has worked. Nvidia control panel doesnt seem to help and straight up disabling the Integrated GPU has done nothing except make the game use the Microsoft Basic Render Drivers. Which makes no sense but whatever. I have googled and have spent a couple weeks now suffering with the crap framerate. So i finally decided. Alright lets try the forums maybe they can help me fix something.

Now before anyone even says it. Yes before this I made every setting either off or the lowest is can actually be. Setting the worker threds to 8 like some people suggested and all that Jazz. I have updated drivers. I downgraded to windows 10 which basically had me factory reset the computer so its basically a new computer at this point. At this point i don’t really know what to do. This isn’t even just Darktide it is the same fps drops i would get during Warframe or Tower of Fantasy. It is the most randomest fps drops i have seen. Having nothing to do with whats going on. Literally had a game where my fps dropped after fights. Working fine for just a moment then suddenly dropping. At this point i just want a new PC but i am broke so this is what i got.

My Laptop is an ASUS TUF Gaming A15 17in. It has a Ryzen 7 4800H with a GTX 1660ti, 16gigs of ram and a 1tb SSD

Can you post your console logs and launcher logs

But functionally you have to force the game to use the Nvidia card via the Nvidia Control Panel.

darktide_launcher.log (66.5 KB)
The option to choose my GPU isnt even in the Nvidia Control Panel

https://www.asus.com/support/FAQ/1038387/

You may have to choose it this way if it uses Nvidia Optimus for graphical switching

Let us know if you’ve had any luck with the above. We’re also looking in to similar issues so I’ll add this to our internal report.

It kinda helped but i still need to lower my resolution. But at least now i am able to mostly play the game. Though Darktide still uses the integrated graphics no matter what.