Crash after hitting "Play" Button


After hitting the “Play” button at the launcher the launcher closes itself and gives me a error message

I tried unistalling and re-instaling the Easy anti cheat but that didn’t wordked. It only changed the error code. I also tried removing the “certificates” folder but ended up the same.

I verified the game cache twice and didn’t work either.

So i don’t know what to do next.

The last error code it gave me was this one:

GUID: af5c4661-e1a3-4c0c-b1fb-f0e75c85623b
Log File:
Info Type:

Do you need any extra info?
Could you help me ?


Hello! Are you using Avast or AVG Anti-Virus?

I’m using 360 Total Security Anti-virus.

Could you try disabling it briefly to see if the same issue occurs?

Okay this helped. For some reason the firewall didn’t asked for permissions for this game so it blocked it without a message.

I’ve just added it to the exceptions and now it’s working perfectly.

Thank you very much!

1 Like

You’re very welcome! Pleased to hear that sorted it. :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.