Corrupted Data and Flagged by Easy Anti-Cheat

Just picked up this game on the Skulls for the Skull Throne steam sale last week. Been constant issues right from the start.

I can only play for about 1 or maybe 2 games before the game crashes with a “Corrupted Data” error message, and frequently, Easy Anti-Cheat telling me that I am now “untrusted” and can’t save my progress.

I have followed every recommended troubleshooting step (other than a full re-install of Windows) up to and including:

Verifying game files in Steam (multiple times)
A full re-install of the game.
Re-installing and repairing Easy Anti-Cheat
Completely disabling all firewalls and antivirus protection (I only use Windows Defender), as well as manually setting up exceptions.
Playing on both a strict NAT type and DMZ type connection.
Checking both HD and Ram for errors (and making sure the Ram sticks were both running at the same rate)
Confirming that Windows and my GPU have the latest updates installed.
Disabling the API that runs the lights on my gaming keyboard.

The issue almost always happens when I try and load into a level, but once or twice has happened mid-game. Doesn’t matter if I’m playing online or solo. This is getting really old really fast. I want to enjoy this game, and I do like what I’ve been able to experience so far. From what I’ve seen on the forums though, the blame is almost always placed on the user’s end (failing hard drive, faulty ram, etc.). Though I do find it odd that so many people have reported the exact same issue with this game specifically. As well as the fact that I have literally 130 other games installed that are of comparable, or greater demand on system resources that all run perfectly fine. It’s only Vermintide 2 that I’ve had problems with. I’ve been a PC gamer since the 90’s, and did technical support for a major video game publisher for over 5 years, so I’m not exactly new to trying to figure these things out.

That being said, I think I’ve reached a dead-end with this game. Systems specs posted below in the hope that someone can help me get this game running without blaming my hardware for being the cause (or at least without a detailed explanation as to why).

DXDIAG:
Operating System: Windows 10 Home 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)
Processor: AMD FX™-8120 Eight-Core Processor (8 CPUs), ~3.1GHz
Memory: 16384MB RAM
Page File: 6179MB used, 10968MB available
DirectX Version: DirectX 12

Card name: NVIDIA GeForce GTX 1050 Ti
Display Memory: 12191 MB
Dedicated Memory: 4018 MB
Shared Memory: 8173 MB
Driver Version: 26.21.14.3064

  Drive: C:

Free Space: 31.3 GB
Total Space: 121.3 GB
File System: NTFS
Model: SanDisk SDSSDP128G ATA Device
Drive: D:
Free Space: 94.8 GB
Total Space: 953.9 GB
File System: NTFS
Model: WDC WD1001FALS-00K1B0 ATA Device

+++ WER7 +++:
Fault bucket 1660987793105969806, type 5
Event Name: RADAR_PRE_LEAK_64
Response: Not available
Cab Id: 0
Problem signature:
P1: vermintide2.exe
P2: 1.0.42680.0
P3: 10.0.17763.2.0.0

Unfortunately it’s very hard to determine what could be causing this as this is a particularly mysterious problem which we’re still in the process of learning about. In most cases it’s a result of mismatched RAM speeds which I appreciate isn’t the case for you. The solutions we’ve listed here are based on other players experiences.

I’ve recently spoken to a player who learnt their issue was a result of an unstable RAM overclock, so that’s something worth considering, and another player with MSI Afterburner had to re-scan their overclocks.

I appreciate this isn’t a particularly helpful response but this is something we’re continuing to look in to. This error is driving me up the wall and I’m equally desperate to uncover a one-shot panacea, but unfortunately our recommendations at this time are limited.

2 Likes

Well… I appreciate the candid reply.

For the record, my RAM is not overclocked, and I am not using any sort of 3rd party overclocking or “boosting” software. I believe my particular CPU chipset may have a built-in throttling mechanism, but I’m not even 100% sure on that. It’s never been an issue before.

I feel it may be worth noting that every time I’ve had to verify the game in Steam, sometimes it downloads unverified files (11 one time, and 17 another), but then other times it says all files were verified correctly.

I’m also a bit concerned about being flagged for cheating by EAC. I went so far as to disable both the Steam overlay and the Nvidia overlay, just in case it was being falsely picked up as an aimbot or screen capture software. I also tried playing with an old, non-gaming keyboard just to see if the game was thinking I was running scripts. No luck.

Just a few other tidbits before I go.

I have also performed virus and malware scans. Clean bill of health. I’ve also tried running the game at Medium and Low graphical settings just to see if that made a difference. Again, no luck.

Thank you for looking into this issue. If there is anything else I can provide as far as assistance goes, let me know. I’m a huge Warhammer fan and really want to enjoy this game, so this issue has got my dander up a bit I guess.

I’ll have a chat with development in the morning to see if anybody has any new ideas. I’ll be sure to let you know if we uncover any other leads.

You don’t need to worry about being considered a cheater by Easy Anti-Cheat, it’s simply chucking up errors as it sees the installation as incomplete - it’s no more than an inconvenience. You can re-enable the Steam and NVIDIA overlay and as long as there’s no cheats running whilst Vermintide 2 is active, you won’t have any problems.

Tried another re-install of the game with firewalls and antivirus protection disabled. Now the game won’t even get past the initial loading screen. :frowning:

GUID: 3adc8ac3-df4f-4e57-9c10-927f1b13d6be
Log File:
Info Type:


Very unfortunate, I can see it’s chucking up another data corruption error. I don’t suppose you’re able to install on to another drive?

We can also reach out to Steam on your behalf and request that they refund you if that’s an option you wished to take, but I appreciate that isn’t the ideal outcome.

Installing to an alternate drive is not really an option. The only other drive I have at the moment is the 128gb SSD with my OS on it.

Again, I would like to point out that multiple methods of error checking have so far found no hardware issues or bad sectors on my HD ( proof if you need it: https://imgur.com/a/5oMdLj7 )

It is, quite literally, only this game that’s having issues.

I even went so far as to manually download Microsoft .NET Framework 4.8 runtime and repair Visual C++ x86 just to see if that might help. It didn’t.

As a de-bugger myself, my first thoughts went straight to there being an issue with my hardware or DLLs, but I haven’t been able to find a shred of evidence that this is the case in over a week of trying to approach this issue from every angle I can think of.

I appreciate the offer of a refund, but I think I’ll just take the $15 loss on the chin, and leave the game in my library in the hope that I may be able to figure out a solution.

Vermintide 2 does seem to be especially susceptible to this issue, so I’m open to the idea that it could be a problem on our end - I’m certainly not ruling it out. I’ll leave that to our brainy developers to decide on though!

I’m equally disheartened that none of the solutions you’ve attempted have worked for you and I apologise that we’re not able to offer more help right now. It really is a case of simply not knowing enough about it. :disappointed:

i have alot of the same issues but alot more… random. meaning sometimes i can play the game for weeks without any problems and for any ammout of hours and sometimes it just crashed gives me corruption errors/anti-cheat eroors even after validateing the files and then working fine after a day or 2 without me changeing a damn thing and it just become very annoying…

Some additional troubleshooting steps I’ve tried:

Clearing the Steam download cache
Changing the Download Region before verifying files
Running a Windows registry cleaner
Running steam As Admin
Adding full read / write security access to the Vermintide 2 folder

A few things I’ve noticed is that I can Verify the game files multiple times in a row, and each time it tells me there are corrupted files that need to be re-downloaded. After running the registry cleaner, I noticed that when I went to launch the game, it seemed to install an “update” for Easy Anti-Cheat. Then the game played fine for several rounds. As soon as I quit the game and re-launched it though, it never even made it past the loading screen before giving me another corrupted data message.

Was the same thing the first time I played the game after installing. Ran fine, until I quit and went to play again later.

Any news or further recommended troubleshooting steps?

In the last week I’ve also downloaded several other games and a couple of massive updates for existing games I have installed (Path of Exile, Warframe, etc.) Everything has been downloading, installing and running just fine. If this is a problem with my hard drive, then it’s a lot more complicated than just failing hardware.

This might seem like an odd question, but do you know if the devs are using a Linux based OS?

Sorry no, I have nothing new to recommend at this time.

Our developers aren’t using a Linux-based OS.

Have you tried playing on the modded realm? Is all fine and dandy there?

(I would assume it is and that the problem is EAC related, but just to rule it out)

1 Like

I have not, but I was thinking about trying that out. Couldn’t hurt. I’ve had suspicions that this might be EAC related.

Thanks for the suggestion!

Had time to try yet? :slight_smile:

I’ve had an insanely busy work week so far. Barely even had time to sleep. Re-downloading the game tonight though, and will let you know how it goes.

Blockquote Had time to try yet? :slight_smile:

So I finally got a chance to try the modded realm instead of official. Still running into the exact same problem, sadly :confused:

It’s kind of a long shot, but I’ve noticed the game tends to freak out whenever I get an achievement, or Steam sends me one of those collectible badge cards. Might just be coincidence though.

The irony of the fact that Steam just sent me a 50% discount coupon for this game today is not lost on me.

Have you tried sfc /scannow etc?

Have you tried running prime95 or similar for an extended period of time to rule out defunct RAM?

What error did you get playing on the modded realm?

Why not join the Fatshark Discord https://discord.gg/K6gyMpu