Connectivity & Ping Issues Since the 4.3 & 4.4 Release

The February update to the Steam client has been monumental in improving the connectivity issues introduced with the 3.4 (Outcast Engineer) patch, however we understand some of our players are still having problems, and connectivity has worsened for some with the release of 4.3 and 4.4 (Sister of the Thorn).

Similar to the last post, please include in the comments below:

  • A description of your connectivity-related woes
  • When did these issues start?
  • Do you have the latest version of the Steam client installed? (‘Steam’ :arrow_right: ‘Check for Steam Client Updates’)
  • Your most recent console log*
  • Your region
  • Your ‘Download Region’ in Steam (‘Steam’ :arrow_right: ‘Settings’ :arrow_right: ‘Downloads’)
  • Your ‘Upload’ and ‘Download’ speeds
  • Do your issues persist with mods disabled? Please check!

*Your console logs can be located using the instructions below:

  1. Press the Windows key + R
  2. Enter %appdata% within the search input and select ‘OK’
  3. Navigate to AppData\Roaming\Fatshark\Vermintide 2\console_logs

Thank you in advance, and apologies once more for the inconvenience. :heart:

Related FAQs:


[PC] Experiencing Matchmaking Issues or Being Connected to Players in Other Regions?

[PC] Playing From Russia and Experiencing Connectivity Errors?

Playing From Turkey and Experiencing Connectivity Errors?

For issues that are not connection-related (such as crashes), please avoid commenting here and instead create a new post in the Technical Support category.

Totally optional, but if anybody would like to be really helpful, a Wireshark log would be super: [PC] How to Run Wireshark – Fatshark

(Please PM me the log as opposed to uploading it here!)

Hello there, since I’ve been asked to post here I’m going to try to resume all the informations I’ve been able to gather.

The problem I’ve been encountering (aswell as a friend of mine) is disconnections at each and every random hordes when we’re hosting. It only concerns non-hosts players, obviously, and only affects hordes. That means the rest of the map is perfectly fine even when lots of rats are present.

I have no idea when the issue started, we both came back for the Chaos Wastes update after a long break and never had any issue before that.

I’m located in France, and use the Paris Server in Steam. Tried the Berlin one, nothing changed sadly.
My upload speed is 0.90 Mbps (not great, but shouldn’t be the issue) while the download one is 13.75 Mbps.
I’m using mods, but even with them disabled the issue is still here. Friend of mine has no mods and encounters the same problems (and “fixes”)

I have no console log to post for the moment since we stopped playing because of this, I’ll try to provide one later.

So far when I host, from what I can tell:

-Sometimes, no problems are encountered. But most of the time, when a horde spawns, everyone but the host has massive lag spikes and end up disconnected. Sometimes people manage to stay in the game, but are unable to play during the horde.

-Scripted hordes, such as end events, are not concerned by this. As usual, not 100% sure about it, but it feels like it.

-I can host and have no problem but only if the game isn’t full. That means up to two people can join me, but a third one and the issue appears for all of them. I’m certain 2 people and 2 bots work fine, the 3 people 1 bot not 100% sure.

-When I’m the one joining my friend, when the issue starts I can see rats walk in place, or move through walls. No hit registers anymore, but I can still see people playing normally (move around, attack, etc.). I can still take damage from ennemies.
Usually I end up being disconnected, but sometimes I manage to stay in game until the horde finishes and then start playing normally again.

That should be all of it, I’ll try to update if I find anything. Thank you for looking into it, much appreciated.


-whenever I am not the host I have falls in the game (lost conection with host).

  • started earlier this week.
    -steam updated
    -Brazil, ES
    -Brazil, Rio de Janeiro
    -50 Mb download, 25 upload
    -with mods and no mods I have loses connection

Velocidade da conexão (Recepção/Transmissão): 100/100 (Mbps)
Endereço IPv6 de link local: fe80::64a6:df58:a1be:28e2%6
Endereço IPv4:
Servidores DNS IPv4:
Sufixo DNS Primário:
Fabricante: Intel
Descrição: Intel(R) Ethernet Connection (2) I219-V
Versão do driver:
Endereço físico (MAC): 1C-1B-0D-F4-00-B6

console-2021-06-19-01.04.47-e5bb23cd-a872-4692-baa9-eb311fbcbf3a.log (2.0 MB)

  • In the majority of the games I play I get the “lost connection trying to reconnect” message at some point in the map. Most of the time I fail to reconnect, and lose the host. This does not seem to be related to my ping (it happens at 65 just as 200), and my latency does not show change during the re-connection attempt either.
    Note, that in the games where there is no disconnection I have no latency related issues at all, nor is there any lag before I get disconnected when it happens.
    When I host it’s the same from the other side: some people have no issues, sometimes one player disconnects (freezes in place, then reconnects / or not) while others don’t, but I also have cases when all the joined players disconnect / try to reconnect at the same time. I don’t play with regular teammates so I don’t know how consistent is all this with any certain player.
    I tried reinstalling Steam (twice), turning off mods and any programs that I can that might interfere.
    After the last reinstall of Steam I actually had a good day when I could do like 5 games in row without problems, but soon enough it’s back to the usual. As I said it sometimes “just works”, but I didn’t manage to detect a pattern. Usually it’s 3 times out of 4 disconnection and if I host I risk screwing over the whole team. At this point I basically can’t play.

  • I went on hiatus for a while and started playing again shortly after 3.4 came out. Ever since then I have been experiencing these issues. When I played before I didn’t have any problems of this sort. While I wasn’t playing I reinstalled Windows on my PC, but I’m not sure if it’s related since other online games I play didn’t develop any problems.

  • Yes, Steam is up-to-date.

  • Vermintide 2 - Consol_log - Google Drive

  • Hungary

  • Hungary

  • Download: 316.18 Mbps; Upload: 22.11 Mbps

  • Yes, I tried playing without any mods enabled and there seems to be no difference.

solved my problem by contacting my internet provider. The strange thing about this problem was that only vermintide 2 lost the connection

what did you tell them/ what did they change?

what file type should we save the wireshark logs in? .txt?

It should automatically attempt to save it as a .pcapng, does it not?

well it does, but I can’t send those files on the forum (not authorized file format)

In that case, please email it to if you can. :slight_smile:

thanks, I sent one!

Hello again!
I’d like to share an issue that I ecnoutered a while ago. Since it’s connection related one, I’m gonna post it here. Guess, I’ll folow the instructions.

  1. Desctiption:
    It’s been a while since I first encountered it (in weave 155 aka condensed pain), but it’s also happened a couple times again recently.
    I had “disconnect” during level download. You know, the one when enemies and party members freeze in places, your attacks do nothing and all of it is followed by “Lost contact with the host. Trying to reconnect” message, that I hate so much.
    At the end of loading, when black screen disappeared, it became clear that I was lagging. My teammates were unable to see neither me nor my messages in game chat, enemies didn’t respond to my attacks etc. But I was able to move forward and that’s exactly what I did. Yet the game detected my presence because I triggered enemy spawns and got my party overwhelmed by enemy waves and specials. Eventually some package got through the poor network connection and I got killed.
    Here’s the video of the issue itself. Sadly, the whole loading process isn’t there, and I lost the original one. Also, it’s a JoJo reference.
  1. This started after 3.4 (or 3.3 update) and still happens.

  2. My Steam client is up-to-date now and was at the moment when it started.

  3. I believe console logs created the day when it happened are gonna be far more useful than the latest one. Here they are: (2.4 MB)

  4. My region is Russia, Moscow region.

  5. My ‘Download Region’ in Steam is Russia - Moscow.

  6. Here are results of ‘Upload’ and ‘Download’ speed test in csv format:
    Speedtest Results (336 Bytes)

  7. Issues persist with and without mods.

P.S. I know it can’t exactly be helped. I’m a Wi-Fi warrior separated from router by sofa, laptop, entire living room, electric meter and cheap Wi-Fi adapter. I’m gonna try some things to improve the current situation, but I doubt technical support can provide any help in this case. I share this mostly for amusement purposes only.
But, if someone in dev team thinks otherwise, here’s all information I can provide.
Thank you for your attention.


Same problem here.

I launch a game in Legendary with a friend.
My friend and other party members are disconnected everytime we face a horde of creatures (we hear the horn in game a few seconds later she reports everything is freezing, then she lost contact, also other party members). The issue is less frequent (to none) in Champion mode, but happens all the time playing Legendary.

Router is set with uPnP.
I called my provider and activated “fastpath” mode on my hardware, doesn’t fix the issue.
I had the same issue with another game I hosted (Police Stories).
Other player I know dont have this issue.

Location is France, steam updated and region is set on Paris.
Dl value is : 10mb/s and upld is 0,9 mb/s (aDSL) my provider (name) is “Free”.

In certain case it seems players are not set on an IPv4 Full Stack, wich means (if I understand well), you share you public IP with other subscribers (cause we are lacking of IPv4) but set on different ports. I don’t know if this is related. The option to ask for an IPV4 Full Stack is disabled by my provider, so I can’t try this one. I’ll try to harass them about that (they dont explain clearly what you can do) and if I can, I’ll share more infos about that.

I guess there are some issues with the provider : I had the same problem with another game recently I hosted (Police Stories), my friend lost connection in the middle of the game, It happens once so I don’t know if it’s related.

Other player I know dont have this issue, but I don’t have any info about their provider.

I’ll try to email my last capture with WireShark (50 mp zipped, its a little heavy :slight_smile: )

Sorry for my awful english.

  • Nico

The last 3 days I’ve been having issues with huge micro stutters making the game unplayable.

I’m used to playing 300 pings games cause I play all around the world but with the micro stutters they are unpredictable like lag so make playing impossible.

It doesn’t matter the pings or connection of the host but I just sort of freeze or the game skips. An example is a SV came up to me and overhead me, I blocked but it killed me through my block and I went down red. Next thing I’ve pulled a Jesus Christ and I’m back up like it never happened.

I’m running a fairly good pc and nothing has changed in the last few days with everything else running fine. I’m on 100/20 internet which I’ve tested as good and validated game files.

Any other suggestions?

  1. Often on legend and especially on cataclysm when a horde starts after a couple of seconds rats start walking through walls and in the air and then I’m disconnected. My ping during this is usually around 60 in the client. This seems to be entirely host dependent since on some games I am fine, but even those hosts have trouble keeping me in the game on cataclysm.
  2. Issues started after the Sister of the Thorn release and have gotten worse since.
  3. I have the latest Steam Client.
  4. console-2021-08-29-06.51.18-7735015f-58d7-4f5c-8b50-f524433ddcb8.log (632.6 KB)
    This contains a disconnect from a host in my country while my ping was shown to be around 60 the whole time.
  5. Region is Finland
  6. Download Region is Finland
  7. 193Mbps down, 44Mbps up
  8. Issues persist with mods disabled.

afaik, this isn’t a connectivity issue. It’s related to horde pathfinding and the host’s CPU being unable to properly handle it.

  1. The connection issue most often appears as enemies standing in place with the same animation palying, enemies running past me, my hits taking seconds to register if the register at all, enemies and myself taking delayed damage, and sometimes I will lose connection with the host. During the whole time the ping stays constant and does not change. The connection issues exists only when large numbers of enemies spawn at once and only when I am the client. This can either be from hordes, events, twitch votes, ect. It is very noticeable with vanilla cata skaven hordes spawning or especially on modded difficulties. If i am hosting none of the clients experience any issues but if we swap hosts I will start having the issue.
  2. I made similar post to this one a few months ago about this same connectivity issue that appeared after one of the Chaos Wastes bug fixes. The issue disappeared after SotT was released but it came back again around the beginning of august/end of july after some unnamed bug patch.
  3. yes steam client is up to date
  4. console-2021-08-29-19.25.10-ba99348b-f5eb-4cbe-8eba-9452ea9bc14b.log (1.6 MB)
    only played one game, it was on athel with skaven the entire map; I was running the sanctioned mods I typically play with though. I did not disconnect but every time a horde spawned i did experience the every issue I mentioned above save for the d/c.
  5. Steam Download Region- St. Louis, MO
  6. Ookla clocks in at 95 mbps DL and 11 mpbs UL
  7. Issue persists irregardless of whether i run no mods or mods, on both modded realm and official realm.
1 Like

Sadly that doesn’t explain why it is always me when playing with 3 friends of mine. The others do not have these problems.