Charge-up on bolt staff gets interrupted. And sometimes block too

When charging up the Bolt Staff as Sienna (Battle Wizard), every now and then it gets interrupted. The interruption looks just like as if I would let go of the mouse button for a split second, but then press it again even though im holding it pressed down the entire time.

The same thing happens every now and then while blocking as well, it only seems to happen in the beginning of a block though. So it will look like this: starting to block, stop blocking for 0.1 sec then go back to blocking. Just as if I let go of the mouse button even though i did not.

Here is what I find extra strange about this; so far I have not noticed these things happening on any other hero or class. Only had it on Sienna. For example, when i hold the mouse button to charge a bow shot of any kind, I have never noticed it stuttering / getting canceled for a split second.

Things i have tried already:
-Mouse starting to break? No. I have tried it in other games, and it only happens in Vermintide.

-Playing around with both the input buffer settings. Tried both on 0, max value and something in between, it still happens.

-Enemies flinching me? No. I have tried to replicate it when there are absolutely 0 enemies on the map. No gas on the ground or anything.

So basically it’s acting as if my right mouse button is starting to break, except it only does it while playing Battle Wizard. Any guesses what could be causing it would be greatly appreciated, very frustrating as Sienna is approaching unplayable with this problem.

EDIT: So im trying to figure out what is causing it. I’ve been playing a different class today and I tried plugging in the cord to my wireless mouse, so far no stutters/interruptions. But im gonna try Sienna next, see if the problem persists.

Still, it would be strange if that was the problem, since it works fine wireless in other games. If I do find out the solution ill post it here just in case it will help anyone else.

I’m having this same exact issue, on waystalker with glaive and swiftbow. Even just holding down left click to spam arrows will have the stream just sputter like i was clicking. Also tried messing with input, reinstalling mouse drivers, etc. Seems to work fine when in the keep solo, and did some solos on modded realm and it seemed to work fine, but in-game with other players the issue resurfaces.

Hi Koffe,

Just a thought, are you using the SteelSeries Engine?

No I don’t think so. That is the program that controls/has settings for the mouse, right?
I am using a Logitech G900. Not a Steelseries.

Also, after playing for several more hours as Sienna with the Bolt Staff, but with the cord to the mouse plugged in, I have not encountered the problem again. So it is playable now at least.

Everything so far points to the problem being when i play with the mouse wireless. Which is strange because i have never felt any stutters/interruptions in other games at all.
Guess i will keep testing.

EDIT: It might not matter, but just realized I should probably have added some basic information on what im using just in case it does.

Windows 7 Home Premium.
Headset: Corsair Void Pro (Wireless)
Mouse: Logitech G900 (Wireless)
CPU: Intel i7-4790K CPU @ 4.00GHz
GPU: Nvidia GeForce GTX 980 Ti

Worth bringing up that wireless mice commonly have issues with interference especially if they are connecting to those little dongles placed next to a USB 3.0 port. Moving it away from 3.0 ports can help a lot or you can use a USB extender to bring it away from potential sources of interference.

I can connect the dongle thingy to the mouse cord if I want it wireless, so I got some range to work with. I usually just put it pretty close to the mousepad down by the foot of the monitor.

Guess I can try and play around with connecting it to another USB port as well, next time i try wireless. But again, I have only noticed this in Vermintide. Seems to work flawlessly in other games.

The only other time I can come to think of when i had problems with it, was pretty early after I first bought it, and I had not yet learned that if you have a fan on nearby that messes with it a lot. So I don’t do that anymore.

So the problem came back, and this was even with the cord to the mouse plugged in, so it was not wireless. I also tried to plug in the cord to my wireless headset just in case that would be disrupting for some reason, but that did still not solve it. I’ve also tried different USB ports for the mouse.

But then again, I have only encountered this problem in Vermintide so far, and now it doesnt even seem to be related to it being wireless. I have no idea what is causing it now.

It is so weird trying to figure out what is causing it, because I have had long gaming sessions this week without a single problem. Then i tried switching weapons / setup to the fireball staff and the problem came back.
What is even weirder is that today when I encountered the problem again, it is like the stuttering/interrupting is worse early on, then it decreases over time. Almost as if i’m working away “rust” on the weapon or something.

I’ll keep trying to figure this out I guess, if anyone else has an idea what it could be im open for suggestions.

What frequency channels are your wireless devices running on? Sometimes if they are running on the same channel, they will cause interference.

Also, try turning off any devices using Bluetooth.

It could still be a wireless problem even if you plug in a cord. Have you also tried updating drivers or uninstalling then doing a fresh install?

I used to use a wireless mouse. It was always picking up interference from somewhere… even from my neighbors when I used to live in an apartment.

I hope you solve your issue!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu