20fps with 7900XT

Issue Description:
After upgrading my PC from Ryzen 5600X with 6800XT to Intel 13600K + Radeon 7900XT, Darktide runs at 20-35 fps even in the Hub on low graphic settings. Missions themselves go even lower.
The GPU doesn’t seem to clock above 1400MHz and won’t even reach 40°C. It doesn’t seem to be used by the game in any meaningful capacity.
The old system easily achieved 60fps and higher on high settings, same monitor.

Attempted Solutions:
All without (or barely any) impact on the problem:

  1. All settings to low (including playing around with FSR 1/2)
  2. various settings in the Driver on/off
  3. checked if Intel iGPU was in use (was not the case)
  4. made sure Darktide is used on primary GPU adapter in Windows graphics settings
  5. verified game files
  6. deleted %appdata%/Roaming/Fatshark folder
  7. various worker threads settings
  8. DDU’d and reinstalled GPU Driver
  9. reinstalling the game
  10. reverting to Driver version 22.12.1
  11. switching between Silent- and OC-BIOS of the GPU


PC Specifications:
Monitor running at 3840x1600
Intel i5 13600k, no OC
ASRock Z690 Pro RS with current BIOS (12.07)
Powercolor 7900XT Hellhound, Adrenaline Driver 22.12.2 (most current)
2x8GB RAM 3600, XMP Profile
Windows 10 Build 19045

The most recent logs:
darktide_launcher.log (73.5 KB)
console-2022-12-23-10.37.56-db7dacd7-767a-4726-8b33-786eb6cba267.log (68.4 KB)

1 Like

First thing, as a 6900xt user, using the 22.12.2 driver gave me a weird issue with frame rates that were still high but not fluid somehow.

Reverting to 22.11.1 solved that. Not sure they do support the 7 series though.
Hopefully some other 7900 users can tell you if they do or not encounter the issue too. If you use Reddit, the AMD community might have more chances for you to share some experience with others.

Disabling v sync, RT, using FSR 1/2 and seeing if it has any impact, you have tried all that already ?
Good luck. Getting the 6900xt near launch, drivers and stability was terrible to begin with and it took a good 7-8 months for things to stabilize fully (and is now surprisingly rock solid).

Thank you for the - genuinely helpful - answer, but sadly the options have zero effect. Post updated with new tests.

I’m guessing that there’s some issues between the game and the driver, to be fixed either by Fatshark or AMD. We’ll see what happens, I’ll just have to do other things in the meantime :smiley:

Sounds like an early adopter amd issue.

Not just amd have the same with my 3080 TI :confused: enormly drops from 120 to 60 over and over.

Don’t bother with Grave, overall negative comments everywhere and pointless remarks.

I have the same problem as you, massive drops in fps in hordes with 5900x and 7900xtx. Should’ve probably waited at least a year before trying the game out.

1 Like

That sounds like a completely different issue. The new AMD gpu’s are known to have serious issues so that is not a “pointless remark,” it is just a fact. This game actually runs well for me on an RX 6900 XT, but it is extremely hard to run. I can do 1080p/custom high settings/150 fps. It does not drop below 100 fps very often.

To prevent this discussion from becoming techno-political: While Grave’s comment wasn’t exactly helpful, it is probably quite true. The GPU drivers don’t appear to be mature enough, which would be an “early adopter problem”. There are probably millions of products in the last decades that would fit into this category of problems.

My card itself doesn’t appear defective, since other games such as Stellaris or Anno 1800 work just fine. And Darktide itself ran very well on my previous card, a 6800XT.

I was just innocently hoping for someone to magically appear with a solution such as “switch that button and voilà!”. I posted similar bug reports on the AMD forums as well as the appropriate subreddit, but no luck so far.

Merry Christmas everyone :slight_smile:

Ryzen 5900x and RX 7900 XTX @ 3440 x 1440p / max settings / no RT / FSR 2 Quality

I’m getting 140 fps in Hub… 130 fps in game and 85 fps with full horde.

Also, 150 hours and not a single crash, even with my previous RX 6900 XT, since beta.

Make sure to clean install AMD gpu drivers, chipset drivers and check CPU utilization in game. Definitely not a driver issue, used both 22.12.1 and 22.,12.2.

Did you test the performance with other CPU heavy games? you said Anno 1800 ran fine but did the performance decreased or increased?

Harbi, I didn’t have any crashes either (that I can remember).

But you are talking about a slightly different GPU on a very different platform.
I did - as originally stated - a very clean install of the drivers, more than once even. I completely switched out the motherboard + CPU, so clean chipset install as well.

CPU utilization seems fine. Tested the mentioned games + Conqueror’s Blade, all work just as expected. Total War: Three Kingdoms works fine in game with low fps in the main menu for whatever reason.

Just because you don’t have any problems (which is excellent!), doesn’t mean all system configurations are equally fine.

My intent wasn’t to invalidate your issue of course, just wanted to counter the issue of it being an early gpu adopter problem. I forgot to add Win 10 build 19044 and 16GB ram 3600 XMP.

You’ve already done a lot frustrating troubleshooting but unfortunately, I can only help with how I troubleshoot my PC. Just in case you don’t already know this, I do it with 3DMark, as it will check the performance of my GPU and CPU and compare it against all tested ones. It’s a good indicator to check if one of the components is underperforming against average people score.

For example, here is my CPU against 625,342 benchmarks. Mine is overclocked but if it was at stock settings and the score is under the average, means I narrowed the issue to the CPU, RAM or bios.

Please don’t take this the wrong way… ehm… just in case… maybe you could check the windows power option and make sure the CPU is not on power saver mode. I don’t know the game Anno 1800 or Three Kingdoms, are they CPU utilization heavy as Darktide?

3dmark does not represent gaming performance well at all in my experience

Have you tried disabling the e-cores in bios to rule out if it’s a cpu scheduler problem?

You guys are making my Christmas a bit better :slight_smile:

@Harbi : The card performs well in several cases including stresstests, clocks properly to 2600MHz (roughly) and works fine in several games. Just not Darktide and Cyberpunk 2077 for some reason.
Your hint to check the power plan is a very good one! No need to be careful, this has saved quite a few troubled people, mostly on laptops though.

Games like Anno 1800, Three Kingdoms and especially Stellaris are quite hard on the CPU. Vastly more than Darktide, I’d expect.

@MeatShield01 : Amusingly, another helpful fellow on Reddit came up with the same idea. Tried it just now, no change.

Thank you guys for the suggestions! Can’t update the main post for some reason, but we’ll see what else comes up.

EDIT: just for the fun of it I bought 3DMark now and tested the system. My scores are very slightly below the average on both GPU and CPU. Time Spy Extreme didn’t get my GPU above 2300MHz, others seem to reach 2700 (OC probably) and it was stable at 50°C. I expected a lot more.

Maybe I’ll update to Win11 and install the Win11 drivers of my system, just to see what happens. Not sure yet.

Thanks for trying.

One more idea. Can you scrounge another 16 GB of memory from another computer to get to 32 GB to test? Or can you open task manager and track the memory usage of the system while you’re playing?

From the console log files:

— Memory
Physical Total: 16173MB
Available: 9626MB

The way I read this, is your system has 16 GB of memory and when you launched the game ~9.5GB was available. That seems a little low to me. Looks like somehow you’re already using ~6.5 GB of memory before the game starts to load. Looking at my logs, I am only using ~4.25 GB of memory when I launch the game. My system is being used solely for playing games, so no extra anything. But 6.5GB before launching a game seems a bit high.

From the launcher log:

10:40:41.960 [Launcher] [Launch Game] [Process Exit] Peak physical memory: 7640793088
10:40:41.960 [Launcher] [Launch Game] [Process Exit] Peak paged memory: 13251399680

The way I read this, the game used peaked using ~7.5GB of physical memory, of which you had ~9.5GB available, however it requested allocation of ~13GB from Windows. On paper, you look like you’re running out of memory physical memory.

Hey, so I bought 3Dmark just for you :smiley:

I tested the Time Spy since I saw you showing results from that benchmark.

Here are my results:

5900x and 7900 XTX @ 2560 x 1440p / max settings / no RT / FSR 2 Quality - in Darktide. Whatever I do, CPU does not go over 35-38% in the game. I believe my system is up to snuff.

In a separate post here in Performance Feedback, I did say that I did the correct procedure of using DDU, I am as well on latest build of Windows, latest AMD chipset, latest BIOS and as well 22.12.2. for the 7900 XTX. (22.12.1. had the same results/fps while playing Darktide). Of course XMP is enabled @3600MHz cl16-19-19-39 (G.SKILL F4-3600C16D-32GTZNC), Infinity Fabric @1800MHz. Game is on Samsung 980 Pro.

I have in fact already ordered another 16GB of the same RAM. Will arrive a little late, though.
It is weird though that the same Windows with the same RAM had no issues before. It is a bit strange though to seemingly have so little available RAM. A quick check appears to see one or more Hyper-V Services at fault. Will deactivate virtualization for a bit, I wasn’t using it anyway currently.

I’m installing Win11 now to see what happens :smiley:


I have installed Windows 11 and NO MORE PROBLEMS. Something got messy in Win10 after all.

100FPS on highest settings in Darktide.
I thank everyone for your continued help!! Merry Christmas everyone!


There is a lot of bloatware in windows you can uninstall and disable, windows should not use much ram after that. If you haven’t, update bios, graphics driver, ssd firmware.

Thats good to hear, grats :smiley:
Now get back into the game, a lot of heretics still need to be undone