Ryzen 9 5950X with 3080TI, any other setting to try?

Certainly playable, but I feel like I should be getting better performance. Afterburner benchmark throughout a mission:

Darktide.exe benchmark completed, 91856 frames rendered in 1076.062 s
Average framerate : 85.3 FPS
Minimum framerate : 50.2 FPS
Maximum framerate : 139.8 FPS
1% low framerate : 50.3 FPS
0.1% low framerate : 27.2 FPS


  • AMD Ryzen 9 5950X 16 Core
  • 3080TI
  • 32GB RAM DDR4 3000
  • M.2 SSD

Settings: VFOV 65, 2560 x 1440, DLSS Automatic, RT off, AO Low, Fog Low, DoF off, Bloom off, Skin Sub on, blur off, all lens off, 12 ragdolls, anything else high

Worker threads set to 28 (30 max, 29 recommended). Newest drivers installed.


nah just wait until the devs decide to optimize their game


I’m in a similar boat with a ryzen 9 7950x and 3080TI. FPS numbers seem very similar, that’s pretty bad performance considering the specs.


It seems to revolve around AMD and 3000 series, but some people have much less issues so its kind of wack

Just as a possible helpful tip here, try setting the worker threads to 4-6-8 and check again; the default may actually make things worse overall.

You can also try setting the CPU core affinity to the physical cores. Since EAC denies you access to the running EXE you can set it on the LAUNCHER as it spawn the EAC exe that spawns the GAME exe.

Here is a powershell command/script to set affinity on the launcher to physical cores:

# 0x55   = 4 physical cores
# 0x5555 = 8 physical cores
# 0x555  = 6 physical cores
# 0x555555  = 12 physical cores
# 0x55555555  = 16 physical cores
Get-Process "Launcher" | Where-Object {$_.Path -like "*\Steam\*"} | ForEach-Object {$_.ProcessorAffinity=0x5555 ; Write-Output $_.Path}

What is the performance diff with this?

On latest update performance seems a lot better with my system. I also updated my windows 10 to 22h2 manually (was on 22h1) and overall windows perf seems to have improved to. Not 100% sure if placebo or not.

bruh your gpu sucks you need at least a rtx 4090 that’s the problem

also try turn off gsync, I have 3080/5600x and turning off gsync made my game way smoother

Lower worker threads to something like 12 and see if there is any difference. Tbf it is laughable that hardware is which BETTER than the hardware I was thinking about upgrading to (3080) is giving this kind of frame rates deviations.

Yeah based on recommendations above I’m currently running on 8 with gsync off (the changing affinity to physical cores didn’t appear to have much of an effect on my rig). It’s maybe made a touch of difference overall, but I’ll re-benchmark a few missions tonight to get the actual numbers. It does seem to be some sort of deeper issue around series 3xxx cards and AMD processors though (from only anecdotal evidence reading through posts here and on reddit).

1 Like

Generally AMD CPUs tend to be clocked lower than Intel. I would expect that in a game with a lot of enemies the CPU clock speed might make a difference for min/max fps.

We all have seen the blog from one of the Darktide leaders. Their assumption seems to be PC gamers don’t care about performance, which frankly is a wrong assumption to make in my experience…It could be just a lazy excuse on their part.

OP, just wanted to pitch in that I have a very similar setup (3080, 5900X), and I’m getting nearly identical performance–yours should be like 5 to 10% better than mine. I’m going to fiddle with worker count and affinity, but I’ll be keeping an eye on this thread since you and I will likely have similar fixes.

Could be something weird about the AMD + 3080(TI) setup?

Possible fix? Another user with a similar setup said that disabling GeForce Overlay helped.

Nice, worth a go. I have the recording stuff turned off, but hadn’t disabled the whole overlay - will try that first :+1:

I gave it a try and it seemed like it was baseline smoother. Sitting at about 80 to 100 in missions between hordes. I still saw stutters and dips, especially during hordes, but that’s nothing new.

Also, this is far from scientific or thoroughly tested on my part, but I also tried the Worker Count setting (currently at 10 but I’ll probably go with the folk wisdom of setting it to one per physical core), and it seems like my CPU was better utilized.

You’ve got 12 physical on your 5900X right? Try 8 as well to check how that feels.

Good call. I will when I have more time to play.

Interesting initial result - will run a series of tests over the evening but just wanted to let you know that a clean install of the newest nvidia drivers (527.37) appears to have had an impact.

Test setting
Rig: Ryzen 9 5950X 16 Core, 3080TI, 32GB RAM DDR4 3000, M.2 SSD
Aux settings: gsync off, nvidia geforce overlay disabled, nvidia drivers 527.37
Game settings: VFOV 65, 2560 x 1440, fullscreen, DLSS Automatic, RT off, AO Low, Fog Low, DoF off, Bloom off, Skin Sub on, blur off, all lens off, 12 ragdolls, anything else high, 8 worker threads
Map(s): Relay station TRS-150

02-12-2022, 18:09:37 Darktide.exe benchmark completed, 123789 frames rendered in 1167.093 s
Average framerate : 106.0 FPS
Minimum framerate : 55.9 FPS
Maximum framerate : 176.0 FPS
1% low framerate : 63.9 FPS
0.1% low framerate : 23.7 FPS

Note: I noticed it immediately on load in - was getting 100 looking down the hall rather than 80-90

What’d you use to run the benchmark?