Xbox 1 error 0x82D40003

Hello. I saw a post by gre on the same subject and it is locked. I do not know how this forum works. I just made an account here in hopes that you can help solve this problem.
I am experiencing the same problem as gre. I have not shared this game and i have bought it outright. Nothing on xbox troubleshooter helps.
Can you give me advice how to fix it and get back to vermintide ?

1 Like

FYI its not just you. I’m currently having the issue as well as one of my Xbox contacts. I submitted a ticket through support for this last night (hence why I didn’t post here) and am waiting on reply.

(Only reason I bring this up here is to let you know its not just you having this issue).

1 Like

@martin.madalik Are you able to PM me your Xbox Gamertag, please? One of our console crew will look in to it, but unfortunately being a Friday there’s likely to be a delay until Monday. Sorry about this.

So preemptively, I called Microsoft support this weekend just in case it was an account issue, and to no avail. Went through every reset step, including factory resetting my Xbox, redownloading my profile, uninstalling and reinstalling the game, etc, none of which worked. At the end of the call, the recommended contacting you.

I think I see whats happening!

So, looking at my purchase history on the Xbox, I see I purchased Warhammer: Vermintide 2 - Ultimate Edition back at the end of October. This bundle includes the base game and two DLCs. If I click on the bundle, it stated “Install Now” on the right hand button like I would expect. HOWEVER, if I click into one of the bundle items, say the base game or the Shadows of Bogenhaven DLC, the right hand button is incorrectly coming up as “Buy”.

I checked several other bundles I’ve purchased in the past, and these all have the items in the bundle marked correctly as “Install”. Only Vermintide 2 has it marked as “Buy”.

Therein, what I believe is happening is sometime this week, anyone who bought the Ultimate bundle now no longer has credit for “buying” the individual items in the bundle (like it should), it just gives credit for the bundle as a whole. Because of this, when you go to start the game, it thinks you have not purchased it yet, throwing the 0x803f8001 error (which is the “You don’t own this” error)

Will try contacting Microsoft again about this, though I’m not sure the proper channel for heavily technical issues like this. The phone support people on the weekend aren’t trained in anything outside the normal script so I don’t know how much help I’m actually going to get.

(Edit, additional: I contacted MS again with the theory presented above. They verified my purchase, verified I should own the game and its should play it no problem. They verified that the game should be showing up as “Installed” but isn’t. Aka, e,verything presented above verified. Their solution, again, was to contact Fatshark support…)

1 Like

Hello. My gamertag is EachDutchess42. Thank you for your answer and have a great weekend.

FYI, I checked in with four other people who have Vermintide 2 on Xbox, two with Ultimate Edition, two with regular edition. The two with regular editions can play the game fine, the two with the Ultimate Editions cannot enter the game. This is consistent with my theory outlined above.

1 Like

Thank you for the additional information @JohnnyInterfunk, it’s appreciated. Our console crew are actively looking in to this issue.

No problem. Let me know if I can help in any other way.

@FatsharkJulia Hello i can see that i have written a my xbox handle wrong in here and that is probably why my game is not still working. My handle is EachDuchess42 sorry for the spelling error on the first time around.
@JohnnyInterfunk same problem for me. I also bought the ultimate edition and have the same issue as you do.

@martin.madalik Ok no problem, I’ve passed this information on - unfortunately we’re still waiting on Microsoft to address this issue.


If anybody else reading this is affected by this issue, or knows anybody that is, please provide Gamertags.

1 Like

@FatsharkJulia I’m affected as well, my GT on xbox is “db1phantom” I believe I have been experiencing this issue for a week now and haven’t been able to play vermintide 2 because of it. May Sigmar guid your steps in fixing this issue.

I will PM you some gamertags. Thanks for making the list. Looks like I’m going to miss another Sunday V2 session unfortunately at this point, but at least we have forward momentum on this.

Hello, I am having the same problem, my XB gamertag is “Neganix”.

Seeing as this problem is now two weeks old and counting, I’ve created a complaint thread here on Microsoft support:

https://answers.microsoft.com/en-us/xbox/forum/xba_gapp/vermintide-2-error-0x82d40003-for-ultimate-edition/6ac9a210-c68c-4115-94f1-ada8653e249d?tm=1554817049237

Not sure what else to do. I strongly suspect this is a Microsoft problem, so maybe badgering Microsoft into fixing the store will help move this along.

1 Like

Hi everyone - could you see if this is still an issue in a couple of hours and report back to me, please? I say a couple of hours, as it may take some time for the changes to apply.

@FatsharkJulia (this is typed 7 hours after your most recent comment)
Unfortunately no, after downloading the 25GB update there has been no change and I receive the same error when trying to launch the game as I did before.

Gah, what a nightmare. Ok, back to Microsoft…

So sorry about all of this.

(8 hours in) To back up db1phantom, still not available. The game is still marked incorrectly as “Buy” in the online store, where it should be marked as “Install”. This indicates the old problem is still there (vice being a new issue).

Same thing here, not working. As @JohnnyInterfunk stated, the problem is most likely related to the issue that the game shows up with “Buy” instead of “Owned” in the Xbox marketplace. I too believe that the problem is mostly in Microsoft’s end.

I also noticed that now the Ultimate Editition in XB store includes Back to Ubersreik as well. I have bought the Ultimate Edition before Ubersreik was even released and this version of the Ultimate Edition is nowhere to be found anymore. So maybe the problem is caused because of this change / mix in the product IDs?

Why not join the Fatshark Discord https://discord.gg/K6gyMpu