Worker thread: optimal amount for 9900k

Hi all

Ive been having a few stutter issiues (and 2 cores being used more then the rest)
My frames are hovering between 144-120 (walking aorund)
droping to 100-70 in combat (expected)
but i messed with worker threads, and since then ive noticed hicups/stutteres even at high frames.

So for my chip, what should i set my worker threads to?
as the interwebs is giving me conflicting info

Kind regards

Are you using Avira Anti-Virus? I ask as it’s been known to interfere with the workings of the cores in that sense.

What is your ‘Worker Thread’ count currently set to?

I have a 9900k. Was originally playing this game on a 7700k.

My worker thread count has always been on 13 (one below max I believe) and I have never had issues with stuttering outside of typical DX12 initial cache business. That said I am now running the game on DX11 because DX12 has been more unstable in terms of crashes.

1 Like

antivirus is turned off, ive yet to retry on 13 threads. was on 8. i will update as soon as i get chance to play in a few hours!

Ok, played this for a while, and the hitching (stutters) happens (at 144-120 fps)
check on hw monitor, 2/3 cores are around 95%, whilst the others are hovering around 50-65%

Its something my comp does not like about verm 2, and ive got presets on high, and turned down shadows (do it in all games, bad habit)

so tested for several days now, and played other games (grim dawn, gears 4, kf2)
and its just verm 2 which has this issiue, and i cant change affinitys as the game locks me out of it (as from what ive read the game uses 2 cores for itself)

overall accroding to HW monitor when in game (and horde starts) my overall cpu usages is around 60-75% and gpu around the same, and heat is 54 on gpu, and 68 on cpu

so im at a loss what it is!

i mean its not unplatable, but i cant stop noticing it!

any ideas/suggestions? (i bumped my worker count back to 13)

Ok sorry to spam this post!

But ive found my issiue (might help others!)

i reverted my drivers for my graphics card just now, and the stuttering has all but ceased for the most part! alot better then it was! the remaining stutters im putting down to not having a gsync monitor :stuck_out_tongue:

Revert drivers for graphics card back to 431.60 (that will get rid of the stuttering effect for the most part)
secondly: invest in a gsync panel (im so 2015 i know)


This is helpful information! Thank you for the update. :slight_smile:


Your CPU has 16 threads :

I am used with the same formula than mashmonster, max less one. It works very good like this !

You can overwrite this setting by tweaking your config file :

(in my home it is C letter but if you installed your game in D, or any other drive replace the letter in the path)

C:\Users\YOUR_USER_NAME\AppData\Roaming\Fatshark\Vermintide 2

Look for the file : user_settings.config

First copy this file and paste it in a “backup” folder, to have it back in case of wrong manipulation.

When it’s done, you will edit the original one in this path with this software :

Edit it with :

Search for the value :


And set instead :
max_worker_threads = 15


Bonus : Look for process_priority

Set :
process_priority = “high”

Try this in game.

Ok seems like i had some kind of placebo effect

Whilst it is somewhat better, the core usage remains 95-98 percent on two cores, whilst the other 14 are hovering bettween 50-75% and when it reaches the high 90’s, it causes the hickup

did not have this till a few weeks ago! alltohugh the reverting of graphics back to the older driver software did help a little bit, but its still there!

was there any back end change around a month ago to core count? as i had more stablity with my i7 6700k with no stutters

just a bit worried!


Indeed in this game when one of your physical core is reaching >90%, FPS decreases.

DId you try the changes we recommanded to you, by editing the value at 15 worker_threads?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.