Often incredible stuttering issues - seems to only run off 2 CPU cores?

System: Nvidia 3070, Intel i7 9700k, 16 Gb ram, Windows 10.

Most of the time when I start up the game, there will be massive stuttering issues so bad it even effect my ability to turn in game. When I’ve attempted some troubleshooting on my own, I noticed that the CPU was not being used fully - it seemed to be stuck at 50%, and would not go any higher even while the game was struggling. I eventually found that when this is happening, the game is only using 2 of my CPU cores. I can’t figure out why this is happening, and why it doesn’t happen all the time. I’ve tried removing all of my mods and fiddling with various settings. Video settings, directx 12/11, even changing the worker threads back and forth seems to have no effect on this. When this is happening the game is unplayable, and sometimes it will stay like this no matter how many times I restart the game or the computer.

In the linked video above I tried to show my settings, including the cpu monitor that showed only 2 cores being used. In the video, the first time on DX12 I had the issue, with visible stuttering issues. The second time on DX11 worked completely fine. A third time, with changing absolutely no settings, still on DX11, the issue was back. While in game I put video settings to lowest to show that this did not change the issue at all.

If there are any suggestions on what to try next, I would appreciate it. Thank you.

Update: Apparently starting it in debug mode seems to fix it, or at least it hasn’t shown up the last 4 times I started the game in debug mode. Dunno if that helps.

Hello! Please:

  1. Load up Vermintide 2 as normal
  2. Open the Task Manager
  3. Select the ‘Details’ tab
  4. Right-click vermintide2.exe
  5. Select ‘Set affinity’

In that window, are all CPU cores checked?

Sorry, forgot to check this for a while. After checking Vermintide in the details tab, I see that only cores 7 and 8 are checked - the same ones my CPU monitor says are being used. I am currently trying to figure out how to change this affinity - when I try, it says access denied, despite me being an administrator. This also happens when I try to change the priority. Hopefully I’ll be able to figure it out, but in the meantime any ideas would be appreciated.


Edit: I am able to change affinity on other programs, just not Vermintide.

Last time we saw this, a player’s Anti-Virus was interfering with their set Affinity. It’s my understanding the Anti-Virus set the Affinity for our anti-cheat service Easy Anti-Cheat, which Vermintide 2 then inherited. It’s worth looking at what’s set for Easy Anti-Cheat to start with, and whether your Anti-Virus could have something to do with it.

I think it’s fixed now! On your recommendation I checked out the affinity for the easy anti cheat. While the easy anti cheat itself looked to be running on full cores, the eaclauncher was only going on two. What’s more is I poked around in more random applications than last time, and found that there were actually others that were being bumped down to 2 cores as well. I use the built in windows defender and virus protection, and I poked around a little bit but couldn’t quite figure out how to see if they were interfering with vermintide/anticheat.

I did happen to see another program that was apparently installed with my headset software that I forgot about - Razer Cortex. I saw that there was a tab that let you do some kind of system management to “optimize” gaming settings for your computer? I had forgotten that the thing even existed. In any case I uninstalled it, and after doing a couple test launches of Vermintide I haven’t noticed any issues. If the issue pops up again I’ll post an update, but I think for now I can consider this fixed.

Thanks for all the help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.