Vermintide 2 stops responding when joining or starting game

Hello there. I have just upgraded from Windows 8.1 to Windows 10, and Vermintide 2 (V2) does not seem to like that one bit. It worked perfectly with no issues beforehand. No Mods. Here is what happens:

  1. In the launcher, ‘Play’ is greyed out. I am using the temporary workaround to sort this issue.
  2. The game starts fine and I can get into the lobby as any character.
  3. If I join game using Quickplay or start a lobby, the game 90% of the time it will find a game, try to join it and then hang when it starts loading. V2 CPU usage drops to 0% and becomes unresponsive. The other 10% when it loads, I can determine no cause. It will likely crash regardless after 15mins in the same manner.

I cannot provide a crash report because the game never truly crashes. Log files normally terminate mid-statement, although a commonality between them is a long list of lines like this, typically right before the end of the log files:

“[Lua] [Matchmaking] Lobby hosted by [Player Name] failed lobby match due to ‘wrong mission (dlc_bogenhafen_slum ~= fort)’”

These are the things I have tried to resolve the issue by looking at other Tech Support threads in these forums. None have resolved the issue:

  • Verifying V2 files on Steam.
  • Reinstalling the game.
  • Deleting the V2 folder in the AppData/Roaming/Fatshark Directory.
  • Setting Graphics to Low.
  • Changing Display mode (Windowed/Fullscreen etc.). All modes have this error.
  • Updating Graphics Drivers for GPU, clean installation too.
  • Updating Windows 10 to most recent version.
  • Turning off all overlays (Nvidia; Windows 10; Steam).
  • Running Steam as Admin.

I have probably done some other things, but I cannot remember them right now. Thank you.

Could you try reinstalling/repairing the Visual C++ 2015 Redistributables please?

Vermintide 2 relies on the Visual C++ 2015 Redistributables, and a broken installation may result in an unstable experience.

Please uninstall the existing version of the Visual C++ 2015 Redistributables, reboot your PC and reinstall from the Microsoft website: Download Visual C++ Redistributable for Visual Studio 2015 from Official Microsoft Download Center

If an error is displayed claiming the redistributables cannot be installed as a newer version is already installed on the PC, please reinstall the Visual C++ 2017 Redistributables instead.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu