Unable to join games of friends and friends to join mine, Connection timed out

I’ve played Vermintide 2 with a friend and my brother multiple times without problems in the past, but yesterday and today I was unable to join their session or have them join mine. I’ve followed your guide, but it didn’t help. I can’t even join them in public lobbies and they can’t join mine. I’ve even reinstalled the game.

My brother is in the same network, his and my computer connected to the internet via Ethernet cable straight to the router.

This is odd! Would you be able to try connecting to WiFi instead, to see how that behaves?

Didn’t work.

The interesting thing is that others can join my sessions without a problem. Completely random people join just fine, can move around and even start a game and finish it without a hitch, I can join a random running game and have no problems either.

It can’t be the general internet settings on my rounter, from what I’m gathering, since my brother can connect to the game servers just fine, only once I try to join his lobby or he tries to join my lobby it stops working and times out.

I’ve also tried unfriending my brother from my Steam friends list, thinking it might have a connection with that, but no, didn’t work either.

Ok, update: We three all have ExpressVPN and my brother and my friend could join each other with VPN enabled. They’ve now tried turning it off and now they are able to join my lobby. We are not sure why that’s the case, because we’re basically required to have VPN on due to an interesting connection of our ISP (we have the same) to the internet backbone, and it works in all other games with and without VPN connection.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu