Since the new update (1.0.5.1) can't even play

I have verified my files and everything the update wanted me to do, but now I cant even launch the game. Anyone knows if I can fix this somehow ? Or do I have to wait for some kind of fix from Fatshark ?

I am also having an issue running the game. I think it has something to do with EAC. Getting:

Windows popup
Untrusted system file (C:\Windows\System32\bfllr.dll)

and

Vermintide popup
GUID: 845eb913-9742-4477-bcf1-70200f65f089
Log File:
Info Type:


I am currently working on this but wouldn’t mind input from others.

So things that don’t fix the issue.

-Verify Game integerity

-Restarting the computer

-reinstalling the _CommonRedist
-deleting %AppData% Fatshark
-restarting the computer

-Reinstalling Vermintide

-sfc/scannow

-Reinstalling steam

That seems a common problem among users of a certain network card.
If you have a Killer NIC, have you tried reinstalling the Killer Control Centre?

Source: https://www.killernetworking.com/driver-downloads/kb/faq/70-game-will-not-launch-due-to-bfllr-dll

Thanks that worked. Though also updated WLAN manager too.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu