Crash at launch, easy anti-cheat dll issue

Game always crashes during launch due to easy anti-cheat error “Untrusted system file C:\Windows\ System32\nvd3dumx.dll”

I did sfc /scannow which did a 100% verification and did not find any integrity violations.

I see EAC is a terrible software and this issue is very common for a lot of people. When I delete the software I can of course run the game but cannot play online.

I’ve done restarts, uninstalls, installs, update and clean install graphic drivers and this issue persists.

I assume there is no solution to this based on other numerous similar cases with EAC, then I would like to move forward with a full refund of this game from my steam account.

I’ve been a vermintide fan for years and its a shame fatshark’s corner cutting anti-cheat software has to ruin it for so many people.

Please include as much information as possible in the description of your issue and include any crash reports produced (if applicable).

If you have already submitted your issue via the Fatshark Support Portal, please avoid double-posting here. You Support Portal query will be answered within 24 hours, Monday to Friday.

1 Like

Sorry to hear this. The error does seem to be referencing a NVIDIA DLL.

A clean driver re-installation is what we would recommend here, which I’m aware you’ve already tried.

If your hours played is less than 2 hours, you can request a refund directly via Steam. Otherwise, please send me the URL to your Steam profile and I can ask our Community Manager to submit a refund request to Steam.

Hey there, i’m also getting the same error at the launch.

  • “Untrusted system file (C:\Windows\System32\nvd3dumx.dll)”
    – Somehow i found a new nvd3dumx.dll and replaced, but i was pretty sure it was not the problem

and now getting same error with another dll;

  • “Untrusted system file (C:\Windows\System32\nvwgf2umx.dll)”
    – But i cannot replace this one, dunno why. Can you please help me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.