Rubberbanding/sttutering lag in official realm

Hi Fatshark
Playing this game since release on xbox one x. Great game, love it so much so I picked it up on discount for PC (Steam) when I heard about WoM expansion. Have decent PC, fresh win 10 up, game installed on SSD. Done some legend true solos in modded realm, and game feels just right, animations butter smooth, responsive controls, game just never drops below 80fps on high setting and there was no stuttering at all. Than when I switch to official realm, join game in progress, everything feels smooth at first, than suddenly horde spawn, screen is filled with rat activity and game start to be choppy and laggy. Just every little rat on screen shifts and teleports around, missing hitboxes, taking damage thru block, huge delay on weapon switch, micro freezes, feels like 300-500 ping while my readings are like 50 ping. Its so frustrating, nobody else complaining about lag when it happens on my side, seems im only one affected. Using MSI Afterburner so I can confirm there was no frame drops, also there was no major ping spikes, no overheat when lag happens. It just feels like 60-80% packet loss in network traffic going on, but I was unable to detect packet loss on my side. I used to ping google 1000 times in background while playing vt2 with pubs and there was 0% packet loss. Pretty sure its network related issue since I have exactly same problem on xbox since day one. At the moment using wired internet connection 30Mbs down 5Mbs up. Yeah its poor connection but I have no such issues in similar P2P games like WWZ. Anyway already tried to switch to another ISP, got better speeds like 70Mbs down 30Mbs up with slight increase at ping compared to first ISP but problem was still there. Coop part of game is unplayable for me, took 3.1k damage last night on fort map cataclysm diff, downed 5 times or so as footknight, log file attached, it was awfull experience. In other hand when I host game in official realm, game perform much smoother but when horde spawns some weird micro freezes may occure randomly, if I got hit in front of horde during freeze my helth bar is gone just like 5-8 rats stacked attacks on me. Other players complained at random lag spikes so I prefeer not to be host. Most likely my CPU have hard time cuz my network not play well with clients joining game, more players in game more sluggish game feels to me when hosting. Modded realm no problem, official realm unplayable.

Other things I tried to resolve my problem:

  • opening steam P2P ports on PC / xbox live ports on xbox
  • setting network to DMZ mode
  • replacing network cables with cat6 ones, replacing router/modem entirely
  • changing ISP
  • connecting thru 4g network
  • turning off just everything on my network including IPTV
  • trying out cloudflare and google DNS servers
  • turning off antivirus protection and firewall on both PC and router
  • DX11/DX12, all game settings to lowest possible, huge fps boost 120-300fps but still lag
  • small network packets
  • turning off all mods
  • Steam download location: Hungary, Greece (actualy located in Croatia, not listed)
  • replacing monitor (144Hz FreeSync On, VSync Off)

Something just feels off. I know that at least games on consoles go thru large testing groups to ensure final product reach certain quality and its highly unlikely that its netcode fault. I still blame netcode, have no problem playing other P2P games online. Why is this game so different?
attachment.rar (292.5 KB)

Sorry to hear you’ve had such a rough time with this! I’ve raised your report with development who will hopefully be able to advise us on how to proceed. Due to the weekend, there’s likely to be a delay in response until next week - apologies for the inconvenience.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Apologies for the late response, we suspect this is related to our anti-cheat service (Easy Anti-Cheat) and is something we need to look deeper in to. Unfortunately we don’t have any solutions to recommend but I wanted to let you know it is something we intend to check out.

Well, first of all thank you for getting back in touch and pointing out EAC as possible source of issues ruining my experience. Actualy it make perfect sense, but I have no clue what can make it go bad like that on my side. It appears like packet filtering/loss. As I already mentioned above, have similar issues on xbox version of game since day one. Guess console version rely on third party solution like EAC as well to proxy all incoming and outgoing network traffic.

I can assure you there’s no cheating tools or services running in background on my PC. Its clean legit windows 10 installment with 0 malware threats so far.

I’m kinda desperate here, cant do much on my own. Repairing EAC service doesnt make it any better. Tried to stop EAC process running in background while in official realm and theres apparently no improvements. Thanks for your effort, keep up with good work

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.