Random Crashes - Access violation (0xc0000005) in build cd937a0ba267

Hey there, I’m here to provide information on the Access Violation crashes on my end, in hopes this will help resolve the issue for me and others. I will also be including what I have tried on my end to avoid getting the problem.

Edit: After I first encountered the issues no mod whatsoever has been in use and to be sure I unsubscribed from all of them as well

I have done the following as well:
Firstly I was on W7:

  • Thread count adjustments
  • Updated drivers ( not clean)
  • Closing unnecessary apps

After upgrading to W10:

Sidenote: noticed significant improvement in FPS after going from W7 to W10. Previously ~40fps on DX11 low settings > 60+ on medium DX12 post-Win10 upgrade.

Not in exact chronological order!

  1. Fatshark guide to checking system for errors etc
  2. Clean latest GPU drivers reinstallation
  3. Steps I followed to avoid the access violation errors.
  4. Tried different “Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\SubSystems\Windows > SharedSection=SharedSection=1024,20480,yyyy” yyyy values (original 1024 > 2048 > 4096 > 12228) as suggested on AutoDesk forums.
  5. Clean Boot
  6. Thread adjustments
  7. GFX settings adjustments
  8. AMD Software not running any ‘enhancers/optimisations’ for games
  9. Uninstall and reinstall (maybe something leftover in registry from previous installments thats conflicting?)
  10. BIOS version checking, running the latest version available for my MOBO.
  11. No connection between hosting and joining others’ games.
  12. Adjusted page file sizes from auto, to previously 1.5 of my RAM as initial and max to current seen in the logs.
  13. Kaspersky scan, Malwarebytes scan which revealed only PUPs.
  14. Stopping non-Microsoft services.
  15. Tried adding compatibility options and/or Run as Admin on Launcher, dx12 exe.
  16. Running with Dx11 or Dx12 doesn’t change anything besides FPS.
  • Haven’t encountered this/these problems in other games.
  • Game is not located on same drive as OS.

Two recent console logs from the crashes(they all have same case as in title):

Doesn’t seem to be any connections for the occurrences in the logs for this prior to access violations, but I’m not a dev ofc.
Console logs I uploaded to ufile as 7zip

Quick sample for the moment of crash (CPU OC’d to 4.25ghz):

14:55:30.948 [Lua] [GameNetworkManager] game object created go_id=461, owner_id=110000137046de3 go_type=player_projectile_unit go_created_func_name=game_object_created_network_unit
14:55:31.621 [Flow] current health: 0
14:55:31.621 [Flow] current health: 0
14:55:31.681 [Flow] current health: 0
14:55:31.736 [Lua] [GameNetworkManager] game object was destroyed id=461 with type=player_projectile_unit, object_destroy_func=game_object_destroyed_network_unit, owned by peer=110000137046de3
14:55:32.709 [Flow] current health: 0
14:55:32.709 [Flow] current health: 0
14:55:32.718 [Flow] current health: 0
14:55:33.737 [Flow] current health: 0
14:55:33.737 [Flow] current health: 0
14:55:33.778 [Flow] current health: 0
14:55:34.795 [Flow] current health: 0
14:55:34.795 [Flow] current health: 0
14:55:34.853 [Flow] current health: 0
14:55:36.250 <>Access violation (0xc0000005) in build cd937a0ba267
accessing address 00007FF78C55FFFF from 00007FF78C55FFFF<>
<>
{00007ffb54590000, 001f5000, 9bed63d6, 21a98f2d-1a75-74d8-7d39-9428c4aab0dc, 00000001, ntdll.pdb}

0x00007ffb54590000:0x00000000000a0bae KiUserExceptionDispatcher
0x0000000000000000:0x0000000000000000
<>
<>1<</Crash version>>
<>wt_7<</Thread name>>
<>win32<>
<>cd937a0ba267<</Build identifier>>
<>release<</Build type>>
<>Developer Build (1.3.6717.0)<</Product version>>
<>4298fba2-96b8-45c4-bf3e-2f2d750523f6<>
<>— CPU
CPU: Intel(R) Xeon(R) CPU W3690 @ 3.47GHz (actually 4.25ghz)
Vendor: GenuineIntel
Logical processors: 12
Family: 0:6, Model: 2:12
Type: 0, Stepping: 2
Features: SSE SSE2 SSE3 SSSE3 SSE4.1 SSE4.2
Feature bits:
EBX: 00000010 00100000 00001000 00000000
ECX: 00000010 10011110 11100011 11111111
EDX: 10111111 11101011 11111011 11111111
— Memory
Physical Total: 12285MB
Available: 8050MB
— OS
Windows version 10.0 build 19042, 64 bit
Windows 10
Machine ID bc9c8018-f508-4c82-8313-ffd8f9ea1095
— Graphics
Graphics card: Radeon ™ RX 480 Graphics (DirectX 11.0, 4075MB)
Graphics card: Microsoft Basic Render Driver (DirectX 11.0, 0MB)
— Network
Network interface: Realtek PCIe GbE Family Controller #2 (IPv4, IPv6)
Network interface: Realtek PCIe GbE Family Controller (IPv4, IPv6)
Network interface: Kaspersky Security Data Escort Adapter (IPv4, IPv6)
— Input
Input device: Mouse (18.1): Mouse
Input device: Keyboard (19.4): Keyboard
Input device: Generic (17.0): USB Keyboard
Input device: Generic (17.0): TUF GAMING M5
Input device: Generic (17.0): HyperX Virtual Surround Sound
<</System Information>>
<>C:\Users\I5\AppData\Roaming\fatshark\Vermintide 2\console_logs\console-2021-04-27-14.51.30-4298fba2-96b8-45c4-bf3e-2f2d750523f6.log<</Console Log>>
<>C:\Users\I5\AppData\Roaming\fatshark\Vermintide 2\crash_dumps\crash_dump-2021-04-27-14.51.30-4298fba2-96b8-45c4-bf3e-2f2d750523f6.dmp<</Crash Dump>>
<>
Memory
Total: 12285 MB
Available: 9234 MB
Used: 3050 MB
Peak Used: 3050 MB
Debug Memory
Total: 0 MB
Available: 0 MB
Used: 0 MB
Peak: 0 MB
Page File Memory
Total: 30285 MB
Used: 5062 MB
Peak: 5322 MB
<</Memory Status>>
<>
RazerChroma
CrashMonitor
navigation
cjson
lcurl
rule database
tobii_eyetracking_plugin
wwise_plugin
<>
[Log end]

Event viewer log of the crash:
No errors or anything that would stand out during the crash in other logs.

Update: Managed to play a half of a campaign in CW and a full one right after without crashing while using only 3 threads (half of actual cores) and what was interesting that in the end of the legend CW campaign scoreboard it was as if I had crashed up until the last mission or so and had 90 kills in total, 2 specials, whereas that cannot be true as I killed upwards of ~20 specials in one map at some point. Maybe this can help pinpoint this matter further.

Wow, this is the most detailed report I’ve ever seen!

Did these crashes start with Chaos Wastes for you, or prior to that?

Thanks! I think? I guess I really don’t like when things aren’t working as intended. :thinking:

Prior to Chaos Wastes the game was running fine on my system. Would crash dumps help out as well or are they just console logs written differently?

Update: In my case it seems to have been overheating/overclocking that caused the access violation errors. I did a thorough clean on PC today, applied new thermal paste and downtuned to 4ghz and managed to play 3 CW campaigns in a row without crashing using 3 threads.

That being said, from past experience and having run 8 threads before just fine, I think something has been left unoptimised or god knows what, as temperatures at even lowest settings are pretty high. I’m saying this after the first time around i got crashes every 2 minutes, seems to have been uneven thermal paste/MSI afterburner. I was more worried about temps before but i’ll keep an eye on CPU usage tomorrow, but the cores were definitely not being utilised at high %'s.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Why not join the Fatshark Discord https://discord.gg/K6gyMpu